1. otacon's Avatar
    Hi all,

    My Z30 runs OS10.3.1.632.

    Phone ran out of battery at about 10.30pm last night. Put it on charge at 11.00pm. Woke up at 4.30am this morning and still can't start the phone.

    Now the phone seems to be in a reboot loop. I see the red LED come on for 3 seconds, then blinking yellow LED for 5 seconds, then red LED for another 3 seconds, then blinking yellow LED... looping and looping.

    Plugging the Z30 into the computer is no use. Every time the red LED comes on, Link tries to connect but loses connection as soon as the red LED goes off.

    Any idea what's wrong and how can I revive my Z30?
    Last edited by otacon; 10-10-14 at 02:14 PM.
    10-10-14 01:57 PM
  2. Bla1ze's Avatar
    Run the autoloader again or go back to an official OS using an autoloader. Even if the computer won't fully find it, the autoloader most likely will and should kick it back to life. Of course, it'll wipe everything but them the breaks when you're running a leak.
    10-10-14 02:56 PM
  3. otacon's Avatar
    Have reloaded software via BB Link. OS successfully loads, but powering on the phone (pressing power button for 10 seconds) gives a Red LED and nothing else.

    Reloaded leaked OS via autoloader. Same result. No joy.

    Everything was fine till it ran out of battery... What could have gone wrong?
    10-10-14 08:03 PM
  4. otacon's Avatar
    UPDATE:

    Seems like the phone is switching on... I called from my home phone and got a ringing tone. BUT, no response from the Z30. No ring, no vibration, no screen... Nothing!!
    10-10-14 08:32 PM
  5. otacon's Avatar
    ANOTHER UPDATE:

    Screen is totally black (off), and i double pressed the power button to turn on screen reader. Touching the screen gives responses, with the Z30 reading out what app, and 'unknown'... screen remains off all the way.
    10-10-14 08:41 PM
  6. olllllo1978's Avatar
    I actually had this same problem on my VZW Z30 not too long ago. All of the sudden, my screen just went black like phone was off but if i held the power button down to turn it off and then back on, the LED would flash and I did the same thing where I test called it from my other line and it would ring through but not even the back light on the screen nor any display response. I just kept trying to do hard rests and turn it off and back on, even tried reloading the OS and still nothing. I ended up swapping on warranty. I had assumed the screen went out. But the odd thing was that particular handset was a warranty replacement I had for literally a week prior. Out the 4 Z30's I've gone through now that was the only one I saw that issue with.

    Posted via CB10
    10-11-14 11:44 PM
  7. otacon's Avatar
    Yes, I have come to the same conclusion. Screen just died all of a sudden. And guess what?? I bought this phone off someone who just got it replaced by warranty!! Talk about coincidences!!

    Anyway, I can't claim warranty as I don't know who the retailer was, and AFAIK BB does not accept warranty claims direct (at least where I am). Guess I'll have to fork out AUD60 for a screen replacement and get it done myself...
    10-12-14 04:43 PM
  8. forbid3n's Avatar
    Same thing just happened to me on the exact same os. Something is causing the screen to not come back on but it responds to touch. This really sucks, going to try reloading os to fix the issue. I feel like its an os issue maybe loading one of the new leaks will fix it
    10-18-14 10:33 PM
  9. forbid3n's Avatar
    Hi all,

    My Z30 runs OS10.3.1.632.

    Phone ran out of battery at about 10.30pm last night. Put it on charge at 11.00pm. Woke up at 4.30am this morning and still can't start the phone.

    Now the phone seems to be in a reboot loop. I see the red LED come on for 3 seconds, then blinking yellow LED for 5 seconds, then red LED for another 3 seconds, then blinking yellow LED... looping and looping.

    Plugging the Z30 into the computer is no use. Every time the red LED comes on, Link tries to connect but loses connection as soon as the red LED goes off.

    Any idea what's wrong and how can I revive my Z30?
    Hey, I ended up ordering a new screen on Amazon. It cost $57 shipping included! Replaced the screen and everything works fine now.

    The screen I had in my phone was one of the 2.0 revisions, the one I got was 3.0 I guess those ones definitely have a defect.

    If you remove your screen, you'll see the revision number stickered to the back of it.

    Good luck!

    Posted via CB10
    jas1978 likes this.
    11-08-14 12:43 PM

Similar Threads

  1. Replacement z30 on the way
    By ronpfid in forum BlackBerry Z30
    Replies: 17
    Last Post: 10-17-14, 12:05 PM
  2. How do I transfer my contacts from a Nokia c-06 to my BB Z30?
    By CrackBerry Question in forum Ask a Question
    Replies: 4
    Last Post: 10-15-14, 06:45 AM
  3. Replies: 8
    Last Post: 10-15-14, 01:28 AM
  4. attachment too big error on my z30
    By viper-85 in forum BlackBerry Z30
    Replies: 3
    Last Post: 10-10-14, 04:00 PM
  5. Is Verizon getting the z30 anytime soon?
    By BBMan1121 in forum BlackBerry Z30
    Replies: 2
    Last Post: 10-10-14, 08:35 AM
LINK TO POST COPIED TO CLIPBOARD