1. drew8484's Avatar
    the bottom third of my screen started flickering and then blacked out. the functions under blackout still work, but obviously I can't see what's what. I've tried numerous hard resets and turned it off and on many times. has anyone else expierenced this. I'm assuming its hardware and have my IT director working on a replacement. I wish Verizon had the classic released so I could go directly to that.
    02-11-15 10:37 AM
  2. Oglon3r's Avatar
    Seems like you applied considerable pressure on that part of the screen.
    Screens are about 40USD$ on ebay.
    And the procedure is very easy and quick.
    Try it it could save you a lot of pain and trouble.
    How long have you owned your z30 for?
    It may also be under warranty still.


    Supporting the people's struggle worldwide via my STA 100-5, Z30.
    Carl Estes likes this.
    02-11-15 12:20 PM
  3. drew8484's Avatar
    no excessive pressure. I've always babied my blackberries. it is still under warranty. I just wondered if anyone else experienced this.
    02-11-15 03:30 PM
  4. OneofLittleHarmony's Avatar
    Probably the keyboard. Do a reset.

    Posted via CB10
    02-11-15 03:47 PM
  5. FF22's Avatar
    Certainly sounds like a hardware issue. Good luck with a replacement.
    02-11-15 06:48 PM
  6. muker1515's Avatar
    I have that too. It would blank out the keyboard but I could still "type" but I found out it's cold and the bottom half just doesn't work. So I just hard it up and it will come on again. But now there is a small black bar at the bottom that doesn't work at all anymore.

    Posted via CB10
    02-11-15 06:50 PM
  7. Mike_Luchia's Avatar
    I've just started having the same issue. Usually starts during the night when it's on charge, when I wake up, bottom 1/3 of screen is blank. I do a couple of reboots and the screen comes back on. During the first reboot the bottom 1/3 is still off because you can't see the status of the restart. After the second reboot (sometimes it takes 3) then you can see the status of the restart and you can see the bottom 1/3 is back on again.

    I've also got some "flicker" of about 2/3 of the screen, looks a bit like a fluorescent light would flicker, usually when it's plugged in. I'm contemplating moving to the Passport so if I do, I'll buy a Z30 screen and replace it after I've upgraded then sell it. If not, I'll hang on until my contract is up and see what else it out there if it lasts until then.

    Mike
    03-19-15 09:54 PM
  8. StephenZ30's Avatar
    That happened to me too just last night!

    I was in Settings and the bottom half of the screen simply went grey/black. I said, "What?!", actually, "WTF?!" in my high-pitched voice, but kept calm and went back 2 screens before it simply righted itself. Hmmm.....

    I'm running the recently released, very sh1tty .1767 upgrade on a Z30.
    03-21-15 11:07 AM
  9. FF22's Avatar
    That happened to me too just last night!

    I was in Settings and the bottom half of the screen simply went grey/black. I said, "What?!", actually, "WTF?!" in my high-pitched voice, but kept calm and went back 2 screens before it simply righted itself. Hmmm.....

    I'm running the recently released, very sh1tty .1767 upgrade on a Z30.
    I know it gets tedious to install/load another OS but so far, knock on wood, things seem okay (well, other than keyboard sounds which I barely hear!) on

    Software Release 10.3.1.1784
    OS version 10.3.1.2582
    03-21-15 01:11 PM
  10. Mike_Luchia's Avatar
    Mine is getting worse. Happens every time it's in sleep mode for a few hours. I've ordered a new digitizer in case that's the problem. (wanted to switch to white anyhow)
    03-21-15 01:23 PM
  11. nt300's Avatar
    This could be an issue with SUPER AMOLED displays. If a pixel burns out, it's noticeable. UT your issue seems like a hardware issue, RMA it.

    Sexy White Z30
    03-21-15 05:03 PM
  12. Mike_Luchia's Avatar
    This isn't a case of misc pixels burning out. People are experiencing the same area of the screen going dark, the bottom 1/3 and it comes back after reboots or various other techniques. I'm starting to think it might be OS related because it began for me before the last official OS update, was gone while I was on the official OS, and returned after I installed the latest leak.

    Either way I ordered a replacement digitizer (ordered the white on this time and a white door) as I wanted to switch to the white Z30, at least until my contract is up in October, then maybe I'll have enough $$$ for the Red Passport.
    03-21-15 05:16 PM
  13. StephenZ30's Avatar
    I know it gets tedious to install/load another OS but so far, knock on wood, things seem okay (well, other than keyboard sounds which I barely hear!) on

    Software Release 10.3.1.1784
    OS version 10.3.1.2582
    I've been checking 3 or so times a day to see if I'd get this update "naturally" from BB.

    I'd really prefer not to use an autoloader. But, if I do start pulling my hair out (because of the keyboard sounds, which I gather your .1784 has not resolved), I'll go back to .1581, which worked really well for me.

    Posted via CB10
    03-21-15 07:42 PM
  14. Trouveur's Avatar
    I've been checking 3 or so times a day to see if I'd get this update "naturally" from BB.

    I'd really prefer not to use an autoloader. But, if I do start pulling my hair out (because of the keyboard sounds, which I gather your .1784 has not resolved), I'll go back to .1581, which worked really well for me.

    Posted via CB10
    No need for an autoloader, just use Sachesi to do a non destructive update.


    Posted via CB10
    03-22-15 06:35 AM

Similar Threads

  1. Replies: 5
    Last Post: 05-01-15, 08:24 AM
  2. Like New White Z30 STA 100-5
    By docfreed in forum Buy, Sell, Trade - Sold / Archived
    Replies: 35
    Last Post: 03-02-15, 03:05 AM
  3. Z10 screen broken - screen price
    By Ukkash Na in forum Ask a Question
    Replies: 7
    Last Post: 02-15-15, 04:48 AM
  4. Is z30 black materials far better than z30 white?
    By Ashraf Altayeb in forum BlackBerry Z30
    Replies: 7
    Last Post: 02-13-15, 09:43 AM
  5. My Z30 is having a groundhog day moment :(
    By Riddymon in forum BlackBerry Z30
    Replies: 7
    Last Post: 02-11-15, 02:22 PM
LINK TO POST COPIED TO CLIPBOARD