1. Ian Porter's Avatar
    Hi all - I've had my Z30 (STA100-5) for a few days now... I was able to get Unlocked Android Runtime working on my device with a debug token installed. I then converted my APK's to BAR and loaded without any issues on the STOCK factory official 10.2.0 version.

    Now I loaded the leaked 10.2.1.1055 onto my Z30 - no issues. (however on the about / general shows software version 10.2.1.176??)

    Now - the step
    Turned on Development Mode. (NO DEBUG TOKEN)
    Installed UAR bars version 10.2.1.1.13 ... waited 10 mins...
    Hard reboot (2 volume buttons)
    waited 10 mins after restart...
    attempted to load APK - NO go (fails with error Installer has stalled. Cancel Installation?)

    -- I've tried various methods getting this to work - debug tokens, turning on/off development mode, different UAR's and haven't been successful at all.

    How do I know the AR is running on the device via the device? (memory usage?)
    Once the UAR files are loaded - Does Development mode need to be on to install the APK's afterwards?
    Is there a solution to getting this working on my Z30 - With UAR - no debug token?

    All help is appreciated! -- Thanks.
    Ian

    EDIT! -- I reloaded the device with the unlocked 10.2.1.1055 full OS installer.
    - hard reboot after doing basic setup
    - copied the apk's and installed without any issues for most.
    - some apk's don't work as they need to download extra content?
    --Found out that I did not need the UAR bars installed at all, and nothing special is needed to get it working.
    -- I was able to hide the bar at the bottom in android apps - which ran smoothly.
    -- It is also activated on corp. network with policies that disable development mode - and i can STILL install the apk's!!

    Thanks all!
    Last edited by Ian Porter; 12-03-13 at 01:18 PM.
    11-29-13 03:16 PM
  2. byrdbrained's Avatar
    I get the same error on my Z10, but I usually just let the installation continue. I can't recall at the moment but I think to get it to continue you have to pick the counter-intuitive choice of "Cancel". When I set up my Z30 with the .1055 leak I'll see if it's any different. Yes - I GOT A Z30!!!!!
    11-29-13 03:23 PM
  3. Ian Porter's Avatar
    wow - so keep waiting and pressing cancel - and it eventually goes?

    I had a Q10 and gave it up for the Z30 ... best decision i made so far... need a good case now...
    11-29-13 03:26 PM
  4. byrdbrained's Avatar
    wow - so keep waiting and pressing cancel - and it eventually goes?
    That's what seemed to work for me, and everything installed despite running into the message with most - if not all - of the .apk's I downloaded.

    EDIT: Just noticed you said "keep pressing cancel". I usually only had to hit cancel once and it would go after that.
    Last edited by byrdbrained; 11-29-13 at 03:46 PM.
    11-29-13 03:31 PM
  5. byrdbrained's Avatar
    I had a Q10 and gave it up for the Z30 ... best decision i made so far... need a good case now...
    I picked up the BlackBerry OEM Transform case, but only because I'm afraid of going naked and then dropping the bloody thing! I have the same case on the Z10 and it worked well for me. It seems just a hair's breadth sleeker on the Z30, as though they made it a bit thinner. I especially noticed it around the corners.
    11-29-13 03:34 PM
  6. m1kr0's Avatar
    It usually works after you force the android run time in to start. Hard reboot your phone (volume buttons). Install Skype from BB World and then start Skype, wait until fully loaded. Shut down Skype. You should be ready to roll now. Please try and let us know.
    11-29-13 03:38 PM
  7. kbfynn's Avatar
    I updated my Z10 to 10.2.1.1055 and it works fine. Bought Z30 over the weekend and have tried to update using the link to the leaks, and no luck. Please help, send me a link that works

    Posted via CB10
    12-02-13 11:50 AM
  8. Ian Porter's Avatar
    It usually works after you force the android run time in to start. Hard reboot your phone (volume buttons). Install Skype from BB World and then start Skype, wait until fully loaded. Shut down Skype. You should be ready to roll now. Please try and let us know.
    I Hard rebooted Z30 - I installed Skype via BB World - I was unable to load Skype - It would "look" like a window is opening and then shoot back to the app screen. Thanks for your help so far!!
    -- Would it matter that I previously attempted to sideload the UAR via Chrome? Can I check the device to see if these are running?
    12-02-13 01:49 PM
  9. Ian Porter's Avatar
    I picked up the BlackBerry OEM Transform case, but only because I'm afraid of going naked and then dropping the bloody thing! I have the same case on the Z10 and it worked well for me. It seems just a hair's breadth sleeker on the Z30, as though they made it a bit thinner. I especially noticed it around the corners.
    I went with the Otterbox - snagged it at the local flea market for $40 CAN cash... -- works great.
    12-02-13 01:50 PM
  10. funkymixx's Avatar
    Did you ever find a working leak for the z30?
    12-05-13 03:15 AM
  11. Ian Porter's Avatar
    Yes -- check the forums - 10.2.1.1055 works great.
    12-06-13 09:24 AM

Similar Threads

  1. BBM not Delivering Messages after Upgrade to 10.2.0.1803
    By luigieagle in forum BlackBerry Q10
    Replies: 8
    Last Post: 12-06-13, 05:13 PM
  2. When do you expect the official release of 10.2.1 ?
    By Andre_QC in forum BlackBerry 10 OS
    Replies: 21
    Last Post: 12-02-13, 10:32 AM
  3. Replies: 34
    Last Post: 12-01-13, 08:58 AM
  4. How to get rid of the tutorial icon
    By m69c44 in forum BlackBerry 10 OS
    Replies: 15
    Last Post: 11-30-13, 07:11 PM
  5. Z10 Unlocked on Sale
    By mkelley65 in forum BlackBerry Z10
    Replies: 4
    Last Post: 11-29-13, 03:19 PM
LINK TO POST COPIED TO CLIPBOARD