1. TravelGuyYYZ's Avatar
    Hello Everyone,



    I can use some assistance. I have had the BB Z30 for about a month. A friend has went the Android route and when he saw me using my BBM Curve he showed up the next day with the Z30. I know... amazing friend! By far the best phone I have ever used but I have a issue...



    The Z30 will not turn on / charge after battery was drained to 0%



    A few hours before the battery was fully drained (I went to bed without plugging it in...) I updated the software to the new 10.3.1 For the few hours I used it before I went to bed everything was fine and I was really impressed with the update. Woke up the next day to the current issue.



    I then jumped online and was shocked that this seems to be a well known issue with the device. Only commentary I`ll add is for such an advanced technology it seems to be a very silly issue to have.



    Currently I have had the Z30 plugged into the wall charger for over 24 hours and this is what happens when I attempt to turn on the device:



    Solid Red light comes on for about 30 seconds
    Solid Amber light comes on for about 2 minuets

    Screen stays dark for the entire process.



    A few hours ago the Blackberry logo would come up on the screen and then show a charger icon with a line running though it before going to a dark screen and shutting off.



    I came across the article about opening the back of the device and disconnecting the battery and connecting it again but surly there must be another way to get the Z30 back in working order. Other than telling me that I should never allow the battery to run so low before charging I would appreciate any advice out there.



    Thank you kindly in advance.
    02-22-15 10:08 AM
  2. anon(9208252)'s Avatar
    Try holding the volume up and down buttons in until you see the blue loading circle, it might take a min or so.

    try this first

    also make sure you have it plugged into the wall charger not usb
    02-22-15 10:25 AM
  3. TravelGuyYYZ's Avatar
    Hi WITHDRAWL,

    Thank you for your response and advice. I have tried the volume up and down button reset for longer periods of time such as 3 and 5 mins but to no results other that the Blackberry Logo and the LED lights coming on.
    02-22-15 10:37 AM
  4. anon(9208252)'s Avatar
    Well i think you might have to reload the software, and using a auto loader is the best way, have a read here and see if your comfortable with it,.

    [Guide] How to Load an OS Using Autoloader - Page 4 - BlackBerry Forums at CrackBerry.com
    Centerman66 likes this.
    02-22-15 10:41 AM
  5. jrocke0w0's Avatar
    Have you tried "stack charging " the phone? (search it) The PlayBook had/has issues with charging after a deep discharge as well (haven't heard of it before on a Z30 tho) trick being when the red led turns off, unplug the charger. Wait a couple seconds and plug it back in. You have to repeat the process until it finally starts to boot (this can be a lengthy ordeal but has worked countless times on a PlayBook) good luck.

    Posted via CB10
    02-22-15 11:18 AM
  6. AwJm's Avatar
    Happened to my Z30.. had to get a replacement... there was/is no apparent fix...
    02-22-15 07:40 PM
  7. TravelGuyYYZ's Avatar
    Thank you everyone for your tips and advice.

    Current status is that the unit still will not fully turn on or charge. I have left it charging continuously for over 2+ days.

    The options that have been suggested are: Stack Charging, Reloading the software via my PC and or disconnecting the battery and reconnecting it.

    I have also sent Blackberry a direct message and have yet to hear back from them and am now coming across other messages messages saying that others have experienced the same with the Z30 as well.

    I`ve had Blackberrys for what the past 10 years... and I have never had the issue like this. So what the battery went down to 0% before charging... such a silly problem for any electronic device to have.

    I will continune to attempt all methods that have been suggested. Hopefully one of them works.

    AwJm - can you clarify... did you have to replace the battery or the whole phone
    02-23-15 05:32 AM
  8. AwJm's Avatar
    AwJm - can you clarify... did you have to replace the battery or the whole phone
    Had to replace the whole Phone... it's an ugly bug that plagues some Z30s..

    Posted via CB10
    02-23-15 07:15 AM
  9. TravelGuyYYZ's Avatar
    Update

    The Z30 is now working.



    After almost 3 days of being plugged into the wall and attempted to restart it many times over... its seems life is now back in the unit and it is charging. Currently at 6%.



    For the Z30 it seems like a lesson has been learned. Always make sure the phone is charged.



    Still a very foolosh problem for an advanced piece of technology to have though.



    Not sure it was the update to 10.3.1 that helped caused the issue or not. I guess all I can do is make sure it stays charged and monitor the situation.



    All the best to anyone who has this issue. Hopefully by just leaving the unit plugged into the wall charger for 3 days the problem as it did with mine will correct itself.



    Thank you all that made comments and suggestions.
    TrueKulcha likes this.
    02-23-15 07:34 AM
  10. non-vtec's Avatar
    I've run the phone down to 0% many times and never had that problem.

    Sounds like your battery pack may be starting to fail.

    Expect possibly poor battery performance from now on. Or may not fully charge properly in the future.




    Posted via z30
    02-23-15 09:24 AM
  11. joeragan's Avatar
    I've run the phone down to 0% many times and never had that problem.

    Sounds like your battery pack may be starting to fail.

    Expect possibly poor battery performance from now on. Or may not fully charge properly in the future.




    Posted via z30
    What OS version are you running on?

    Posted via Z30STA100-2/10.3.1.2267
    02-23-15 11:32 AM
  12. ExplicitPromo's Avatar
    This is a major issue with z30 and 10.3. I have it but different. Phone works but screen stays black. Won't wake up. If plugged in the the charger it wakes up fine and will wake up a couple times after unplugging it but then boom. Black screen

    Search Google. More and more reports of this every hour now. Even here on cb

    Posted via CB10
    03-02-15 06:49 PM
  13. SomeoneOrOther's Avatar
    A colleague of mine is experiencing this right now with her Z30, only happened after the 10.3 update. From the sounds of it, it seems like a software issue triggered by 10.3 (and possibly related to the OS improperly recognizing battery life)?

    Here's a blurb from BlackBerry's (RIM's) Knowledge Base:
    KB36766-BlackBerry 10 smartphone Screen appears blank or black and will not power on after software update

    They'd better address this soon....but with a blank screen, what to do in the meantime?
    03-02-15 07:04 PM
  14. igotaq's Avatar
    A colleague of mine is experiencing this right now with her Z30, only happened after the 10.3 update. From the sounds of it, it seems like a software issue triggered by 10.3 (and possibly related to the OS improperly recognizing battery life)?

    Here's a blurb from BlackBerry's (RIM's) Knowledge Base:
    KB36766-BlackBerry 10 smartphone Screen appears blank or black and will not power on after software update

    They'd better address this soon....but with a blank screen, what to do in the meantime?
    Get BlackBerry to repair it or replace the display yourself.

    Posted via CB10
    03-02-15 08:40 PM
  15. SomeoneOrOther's Avatar
    Get BlackBerry to repair it or replace the display yourself.
    Posted via CB10
    It's not a display hardware issue, it's software, and most likely defective firmware at this point (since a factory reset doesn't solve the issue). Getting a replacement phone from BlackBerry would be the quick fix.
    03-03-15 10:49 PM
  16. ExplicitPromo's Avatar
    Get BlackBerry to repair it or replace the display yourself.

    Posted via CB10
    Read this.

    http://btsc.webapps.blackberry.com/b...ListHelperImpl

    It's not the screen. Another user has already put new screen o. And same thing. It's firmware

    Posted on my now almost useless z30 that won't wake up
    03-03-15 11:28 PM

Similar Threads

  1. Why I can't download torrents on the new 10.3.1?
    By Telvin Mason in forum BlackBerry Passport
    Replies: 11
    Last Post: 03-15-15, 07:53 PM
  2. Randomly Forced to HUB .. anyone else get this?
    By ianbordas in forum BlackBerry Passport
    Replies: 1
    Last Post: 02-23-15, 09:44 AM
  3. Swipe up to minimize order 10.3.1 customized ?
    By Labba Labbala in forum BlackBerry 10 OS
    Replies: 5
    Last Post: 02-23-15, 02:12 AM
  4. Strage battery behaviour after update
    By Gabbello in forum General BlackBerry Discussion
    Replies: 3
    Last Post: 02-22-15, 10:37 AM
  5. Why am not getting BB 10.3 update on my Z10 stl100-2?
    By CrackBerry Question in forum Ask a Question
    Replies: 1
    Last Post: 02-22-15, 10:08 AM
LINK TO POST COPIED TO CLIPBOARD