1. bops2466's Avatar
    Hi All,

    I'm in the process of upgrading from a z10 to z30. Got my new device this afternoon and got it up and running. Did a OS update and installed 10.3.1.2267. All worked fine. the phone was receiving emails and notifications. I then powered the phone down to insert the sim and SD cards and have not been able to turn it back on. I get the red led flash on for a second but that's it. Tried reloading the OS. Tried loading a 10.2 OS but no luck.

    Any ideas or is this phone phucked?

    Bops
    02-23-15 01:25 AM
  2. Oglon3r's Avatar
    Try everything mentioned on this post
    http://forums.crackberry.com/blackbe...p-help-948316/

    To summarize run autoloader or try hard reset.

    Supporting the people's struggle worldwide via my STA 100-5, Z30.
    02-23-15 04:54 AM
  3. bops2466's Avatar
    Hi,

    Tried all that. Looks like the phone works but the screen is black. The notification LED blinks and BB Link recognises the phone connected to the computer.

    Anything else I can try? This is so annoying as the phone is less than 24 hours old.
    02-23-15 04:00 PM
  4. TrueKulcha's Avatar
    Have you tried reloading the OS via autoloaders? You can also connect to link and do a factory restore if you're more comfortable with that.

    Posted via CB10
    02-23-15 08:45 PM
  5. ExplicitPromo's Avatar
    Another blank screen z30

    We need a warning, a sticky In the forums warning users about this. Every hour there is more and more people with this issue

    My is doing the same. So far I have got it to the point where it works properly when plugged in but after a few wake ups it stays black

    I did hard reset, hold volume up and down till it restarts a few times then I did get it to come on. Then I reinstalled 10.2 using autoloader, it didn't help. Tried 10.3 again and no luck

    I'm going to try wiping and going to a different 10.2

    Something in 10.3 is not playing well with some z30's. BlackBerry must get us a fix fast

    Posted via CB10
    03-02-15 05:44 PM
  6. ExplicitPromo's Avatar
    http://btsc.webapps.blackberry.com/b...ListHelperImpl

    BlackBerry have now Admitted it's an issue.

    Posted via CB10
    03-03-15 12:00 PM

Similar Threads

  1. Advanced Interaction not working
    By sumeet satapathy in forum BlackBerry 10 OS
    Replies: 34
    Last Post: 05-18-15, 02:04 PM
  2. Replies: 2
    Last Post: 02-23-15, 11:19 AM
  3. Regarding Screen rotation Lock not working
    By KSahir in forum Ask a Question
    Replies: 4
    Last Post: 02-23-15, 10:57 AM
  4. Still not seeing 10.3.1 update in China
    By RyanQian in forum BlackBerry Q10
    Replies: 2
    Last Post: 02-23-15, 06:35 AM
  5. Can I get the 10.3 update, even when I have 10.3.1.747 software?
    By CrackBerry Question in forum Ask a Question
    Replies: 1
    Last Post: 02-23-15, 01:38 AM
LINK TO POST COPIED TO CLIPBOARD