1. CdnShockwave's Avatar
    Hi guys,

    I have my unlocked Z30 running 10.3.1.1784 and want to do a backup via BB Link. I've installed Link and Blend, logged in, and all that. But I can only connect via wifi; it's not recognising that it's connected via USB. The phone is charging, so I know there's a connection. But I can't do a backup over wifi.

    Any ideas?
    03-24-15 08:43 PM
  2. FF22's Avatar
    Try a different usb port. Turn off wifi - some folks have found that has helped.

    You could UN and REinstall BBlink.

    Sachesi also has a backup function - a discussion and download can be found in the BB OS Leak subforum.
    kbrant64 likes this.
    03-25-15 12:46 AM
  3. redchilli88's Avatar
    After installing BBlink,reboot your PC. Connect your phone and WAIT. Until such time as the PC recognises your phone, install the software and connect and ask you for your password. WAIT for confirmation that you are recognised and connected to your PC. Open BBLINK, and wait until BBLINK recognises your phone and ask you for the password. Put your password and you should be operational. Note: All these posts about being connected does not mean you are recognised. You need to be both. ( I can be connected to you over the Internet or the phone but I do not recognise you, therefore I am not accepting you- sounds familiar ? )

    Posted via Z30 or Red Passport.
    03-25-15 02:43 AM
  4. JerBru's Avatar
    There are problems with Windows 8.1 if that is what you are using on you'd pc

    Posted by Jerbru
    03-25-15 07:33 AM
  5. anon(9188202)'s Avatar
    There are problems with Windows 8.1 if that is what you are using on you'd pc

    Posted by Jerbru
    I am using Windows 8.1 on both my home and business PC's and have no problems using either Link or Blend.

    I initially had a similar problem because of my Kaspersky Antivirus software, but troubleshooted a solution (Uninstall Kaspersky, install Link/Blend, reinstall Kaspersky - just disabling Kaspersky prior to installing Link/Blend did not work).
    03-25-15 07:49 AM
  6. CdnShockwave's Avatar
    Running Windows 7.

    I had some progress last night. While tinkering with the settings in BB Link, I accidentally did a wipe/restore (woops) and when I got it back up and running, BB Link detected my Z30... but since it had been wiped, there was nothing to back up. Fortunately, I just lost my contacts (which I still have on my old phone anyway... it was just a pain putting them all back in manually since my old phone is a relic).

    So I put all my contacts back in, downloaded the TWO apps from BBW that I use, got rid of the things I didn't want (like foursquare and linkdin) tinkered with all the settings to get the phone to run just the way I like it, and then I get home today and no dice, no USB detected.

    My suspicion is that I've changed some setting somewhere on the phone that's preventing BB Link on my computer from recognising it. I noticed when I swipe down that, in the quick settings, BB Blend is not in blue and I can't seem to enable it. It says my device isn't paired with a computer to use BB Blend, which is odd since BB Blend and BB Link on my computer have no trouble recognising and accessing the phone via wifi. It's just the USB it doesn't seem to recognise.
    03-25-15 06:47 PM
  7. jawler's Avatar
    Perhaps this is too late for those with the problems connecting Z30 via USB in BBLink.
    Anyway, the definite solution is this:

    1. Uninstall the BB Desktop Software 7 (BBOS) from your computer, and have only BBLink. (it is said that you can run both BBOS Desktop as well as BBLink on the same pc however, if you do, BB10 devices will only connect through Wi-Fi and won't be able to back up. this is because the BBOS Desktop driver has priority over USB network interface.

    2. Once BBOS Desktop is uninstalled, then turn the wi-fi 'off' your BB10 device, then turn off the BB10 device, then connect via USB, and when you do this, your computer will automatically pick up the driver from your BB10 device, and your device may reboot (if not just turn it on and wait couple of minutes).

    3. Open BBLink, and wait for the password prompt screen to log into your BB10 device.

    That's it, all done.
    FF22 likes this.
    07-08-15 01:01 PM
  8. ptdsb's Avatar
    That fix worked for me, thanks. After months of being unable to back up. Also I noticed that the version of the desktop software I downloaded was dated this week on the BlackBerry website. So it a new version? I don't know if that's made a difference too as I'm sure I've tried all the other stuff before.

    Posted via CB10
    FF22 likes this.
    07-10-15 03:33 PM

Similar Threads

  1. BB Link
    By stevec66 in forum Ask a Question
    Replies: 1
    Last Post: 05-04-15, 03:30 PM
  2. CrackBerry.com not the CrackBerry.com it used to be
    By stinckyfoot in forum Site and App Feedback & Help
    Replies: 28
    Last Post: 04-29-15, 01:22 PM
  3. Need help--Unable to install Link
    By Droidophobe in forum Desktop Software
    Replies: 5
    Last Post: 03-26-15, 06:11 PM
  4. Replies: 5
    Last Post: 03-25-15, 09:22 AM
  5. Replies: 4
    Last Post: 03-25-15, 12:16 AM
LINK TO POST COPIED TO CLIPBOARD