1. the_radeon's Avatar
    Hey there,

    I've been using my Z30 for more than a year. Out of the box, it worked flawless. But since recently, it has started working strange.

    Browser does not respond well, like when I try to open history, it takes like 30 seconds to open that
    Music shortcuts doesn't work sometimes
    Screen flickers whenever the screen is turned on.
    and RAM management sucks! It cannot even hold Instagram, Music Player and browser at once. (I only have less than 10 android apps, and I'm using a task manager to kill background processes)

    and sometimes hotspot and bluetooth are not toggled when I press the relative buttons, I have to restart the device each time.

    I've tried reloading the OS but didn't work. My current version is 10.3.2.2836
    Please do not give foolish answers like Have you tried soft resetting your device, have you tried reloading the OS bla bla bla. I HAVE ALREADY TRIED THEM!

    Is there any other stable version than 2876? I have tried reloading the OS at two different occasions in two different computers (once last December and the other last month, May)

    The device is an STA100-2 running OS 10.3.2.2876, SW release 10.3.2.2836
    06-03-16 10:20 AM
  2. Dunt Dunt Dunt's Avatar
    .2876 wasn't the most stable OS that I have used... but it was usable.

    If you have tried reloading the OS (without restoring any data), and are still having issues.... I'd go back to an older version that you were happy with. Not sure if you have a Carrier device or unlocked, but if a Carrier version try their current official release. Then test if for a little while befroe reloading all your accounts and apps... test to see if one of these impacts your performance. Do not restore your data from a backup, and if you must... try to wait and see if it works before doing a full or better a limited restore.

    Also I found that the number of Account in the HUB and the length of time you allow those to sync for can be an issue.
    06-03-16 10:34 AM
  3. the_radeon's Avatar
    .2876 wasn't the most stable OS that I have used... but it was usable.

    If you have tried reloading the OS (without restoring any data), and are still having issues....
    Yes I have tried reloading the OS without restoring the data, and still I'm having issues. and my device is factory unlocked. What are the options available?
    06-03-16 10:45 AM
  4. Dunt Dunt Dunt's Avatar
    thurask has most every OS version out there.... http://forums.crackberry.com/bb10-le...rchive-943672/

    I think 10.3.2.2639 was pretty stable... give it a try.

    What does your Device Manager show is using most of the memory?
    the_radeon likes this.
    06-03-16 11:04 AM
  5. Avenzuno's Avatar
    Since the start of this year, for my VZW 100-3 Z30, I've been very happy with the very stable OS Version 10.3.2.2813 (Software Release 10.3.2.2530). I urge the OP to try that one.

    Posted via CB10
    brookie229 and Ariz72 like this.
    06-03-16 09:51 PM
  6. brookie229's Avatar
    Since the start of this year, for my VZW 100-3 Z30, I've been very happy with the very stable OS Version 10.3.2.2813 (Software Release 10.3.2.2530). I urge the OP to try that one.

    Posted via CB10
    Yup, I agree, 2813. Rhymes too.
    Avenzuno likes this.
    06-03-16 10:05 PM
  7. the_radeon's Avatar
    What does your Device Manager show is using most of the memory?
    System it is. and its only around 300MB, and I always have ~700MB free memory. But it won't hold up like it used to.
    06-04-16 08:48 AM
  8. kbalaz's Avatar
    reloading OS from link doesn't work sometimes. If you haven't already tried it, find the autoloader for 2813 as everyone else mentioned, download to your pc and then run the exe from there, wiping and restoring your device
    06-08-16 08:37 AM
  9. VinLou's Avatar
    I have been experiencing 5 months of this behaviour and others. At times its like my phone is hacked and someone is messing with me.

    The other day, my keyboard was acting up, like digital keys would disappear as I type. Lots of flickering happening. Apps are crashing again, like BlackBerry is going down the drain fast, Web browser is completely messed up. All apps do not function properly ANYMORE.

    No Shade Just Light!!! Z30 10.3.2.2639
    06-17-16 04:19 PM
  10. VinLou's Avatar
    Today my email just put up a symbol I haven't seen before, a purple symbol saying I replied to an email.

    Is this a new feature? How did I get it without an update?

    If not, when do features turn themselves on?

    No Shade Just Light!!! Z30 10.3.2.2639
    06-19-16 09:56 PM

Similar Threads

  1. My BlackBerry ID Hacked
    By Abdul Hakim Amir in forum Ask a Question
    Replies: 15
    Last Post: 11-09-16, 05:11 AM
  2. How do I do multiple email deletes on my Classic?
    By CrackBerry Question in forum BlackBerry Classic
    Replies: 2
    Last Post: 06-04-16, 12:16 PM
  3. how can i sign in to my BB id.
    By CrackBerry Question in forum Ask a Question
    Replies: 4
    Last Post: 06-03-16, 08:57 AM
  4. Once flawless.Z30 now w/ all apps crashing
    By tomnyc in forum BlackBerry Z30
    Replies: 3
    Last Post: 06-03-16, 08:32 AM
  5. Most of the links don't have anything?
    By Butterlettuce Dibs in forum BlackBerry Z10
    Replies: 1
    Last Post: 06-03-16, 06:36 AM
LINK TO POST COPIED TO CLIPBOARD