12-15-15 12:09 PM
29 12
tools
  1. lukatrifunovict's Avatar
    It seems that I still have the same issue since I've got this device. People said that the latest leak (10.3.2.2789, done via Sachesi) would do better than older 10.3.x releases, but I have the same strength and WiFi is unstable. It even drops when I get closer like when I get 2 to 3 bars, but less frequently. I even had one while writing this.

    I wanted to ask, has anyone replaced Z30 with another one and did it help for those who had same issues?

    Black, BlackBerry Z30/ 10.3.2.2639
    outlooker likes this.
    10-18-15 03:10 PM
  2. anon(3732391)'s Avatar
    Weak WiFi signal and frequent drop - a hardware issue?-best-answer1.jpg

    I had the exact same problem with my Passport and my Z10 at the same time. Not at first but suddenly my Wi-Fi would go out and it began happening more often. I even added a "relay" to increase the signal.I tried several different things but to no avail.
    The problem turned out to be the router! And it was a good Netgear N600 Wireless Dual Band Gigabit but suddenly it just wasn't handling the 16 components that had been working just fine for a very long time. So, I replaced it with the latest Netgear R6250 Smart Wi-Fi router and that fixed the problem. I now use the N600 as a relay.
    Last edited by Lostboy5151; 10-19-15 at 04:19 PM.
    10-18-15 03:38 PM
  3. lukatrifunovict's Avatar
    Maybe you are right. My sister also has some issues but smaller than mine. It could be because of router firmware or router itself...

    Black, BlackBerry Z30/ 10.3.2.2789
    10-18-15 10:43 PM
  4. anon(6046683)'s Avatar
    Try to set your router only on N, 2,4 GHz, 20mhz, channel 6.
    And delete your profile from the phone.
    Finally reconnect using advanced option 2,4 band without ipv6.

    Posted via CB10
    10-19-15 02:06 AM
  5. jtultu's Avatar
    Depends on what troubleshooting steps have you done to conclude that it may be your Z30 hardware at fault?

    Have you tried using your WiFi on another connection? What was the results?

    Have you tried using various version of OS? What was the results?

    Have you tried a clean install? What was the results?

    Z30STA100-2/10.3.2.2789
    10-19-15 02:07 AM
  6. gwa62212's Avatar
    Had same issue and rebooted my router. Now the phone is connected to Ch1, was previously Ch11. No dropped connection since so I conclude my phone is ok

    From my Z30 STA100-2 on OS 10.3.2.2639
    10-19-15 02:41 AM
  7. Q10Bold's Avatar
    It seems that I still have the same issue since I've got this device. People said that the latest leak (10.3.2.2789, done via Sachesi) would do better than older 10.3.x releases, but I have the same strength and WiFi is unstable. It even drops when I get closer like when I get 2 to 3 bars, but less frequently. I even had one while writing this.

    I wanted to ask, has anyone replaced Z30 with another one and did it help for those who had same issues?

    Black, BlackBerry Z30/ 10.3.2.2639
    Got the same problems with 2x Z30 and one Passport.... :/

    Posted via PP
    10-19-15 03:07 AM
  8. lukatrifunovict's Avatar
    I mostly use one WiFi connection, but I have minor issues with cellular connection, it sometimes drops from 5 bars to 1-3 in about 5 seconds, which is weird. I think that I had some issues with other WiFi connections too, with occasional drop. Even clean install doesn't, if talking about versions older than 2789.

    Black, BlackBerry Z30/ 10.3.2.2789
    Last edited by lukatrifunovict; 10-19-15 at 06:54 AM.
    10-19-15 06:38 AM
  9. anon(6046683)'s Avatar
    Dude try the steps i mentioned above
    The issue is your router settings

    Posted via CB10
    10-19-15 11:21 AM
  10. anon(3732391)'s Avatar
    Maybe you are right. My sister also has some issues but smaller than mine. It could be because of router firmware or router itself...

    Black, BlackBerry Z30/ 10.3.2.2789

    Maybe? MAYBE????
    You doubt me? I'm crushed!!
    Just look at my face. Is that not the most trusting face you've ever seen??
    kbz1960 likes this.
    10-19-15 04:12 PM
  11. lukatrifunovict's Avatar
    Nope, still having issues, definitely not router's fault..........

    Black, BlackBerry Z30/ 10.3.2.2789
    Naveen Jaiswal likes this.
    10-27-15 04:22 AM
  12. paulwallace1234's Avatar
    It's caused by Software, it was fine in 10.2, it's a 10.3 issue; my own's WiFi is terrible, barely picks and networks up and drops the connection half the time

    Posted via CB10 v....not telling
    theGUNNER likes this.
    10-27-15 04:53 AM
  13. Naveen Jaiswal's Avatar
    I mostly use one WiFi connection, but I have minor issues with cellular connection, it sometimes drops from 5 bars to 1-3 in about 5 seconds, which is weird. I think that I had some issues with other WiFi connections too, with occasional drop. Even clean install doesn't, if talking about versions older than 2789.

    Black, BlackBerry Z30/ 10.3.2.2789
    I have exactly the same issue, sometimes signal bar drops for 5 seconds and wifi doesnt work at all. And whats more frustrating is that Wifi IC is not available anywhere. May be could be wifi antenna. I have watched all teardown videos and I am not able to figure out where is Wifi IC or antenna is located. I guess i will throw my phone in the garbage.

    wifi log <3>CTRL-EVENT-STATE-CHANGE id=-1 state=2 BSSID=[$h(*************00:00:00)]
    10-27-15 07:42 AM
  14. lukatrifunovict's Avatar
    I've heard that 10.2 had better if not the best signal in BB10, so it could be software issue, hardware issue, or both. Hopefully the next update that is not leaked (2789) will have better signal, and I will maybe use an autoloader that time, which should refresh my phone.

    Black, BlackBerry Z30/ 10.3.2.2789
    10-27-15 04:53 PM
  15. rotorwrench's Avatar
    I'm not sure if it's a build issue or what but I have a VZW Z30, STA100-3 with update 10.3.2.556 as well as a couple of coworkers and so far our wifi stability and signal strength has been great, and on various routers as I travel quite a bit. There has been the rare dropped connection, as I had a momentary drop last week at another company's facility, but it reconnected almost immediately. That has only happened 3 or 4 times in the last 2 yrs. I've been in locations where others were having wifi issues and I was golden. I'm happy with my phone's wifi performance so far as well as the update.

    Posted via CB10
    10-28-15 12:16 AM
  16. lukatrifunovict's Avatar
    Had issues with WiFi even on 2789, and I downgraded to 2639, because it is official release and supports BlackBerry Protect. I also rebooted router and nothing changed. If 2813 makes any change, maybe I should try...
    And just a few minutes ago, I lost signal again, and I suddenly had strong signal at -57dbm and then after few seconds got back to average strength (around 80 dbm).

    BlackBerry Z30 STA100-5 10.3.2.2474/2639
    12-10-15 04:16 PM
  17. dangerousfen's Avatar
    As Paul said, all was fine when running 10.2. These wifi issues started with the first release of 10.3.

    End of story.

    "Z30 STA100-2 UK" 10.3.2.2474 Get's a Ten from Fen.
    12-10-15 06:37 PM
  18. lukatrifunovict's Avatar
    Gonna wait for 10.3.3, then. Or maybe I'll soon try 2813.

    BlackBerry Z30 STA100-5 10.3.2.2474/2639
    12-11-15 03:01 AM
  19. BoneMatrix's Avatar
    Had issues with WiFi even on 2789, and I downgraded to 2639, because it is official release and supports BlackBerry Protect. I also rebooted router and nothing changed. If 2813 makes any change, maybe I should try...
    And just a few minutes ago, I lost signal again, and I suddenly had strong signal at -57dbm and then after few seconds got back to average strength (around 80 dbm).

    BlackBerry Z30 STA100-5 10.3.2.2474/2639
    So have you ruled out the WiFi AP and/or channel conflicts with other near by APs?

    Posted via CB10
    12-11-15 04:30 PM
  20. 10_z_no gimmick's Avatar
    Had the same issue no matter which options my router was on and even after trying different routers. Finally configured dlink wireless n access point (dap 1360) last weekend and bingo ! , no more wifi connection drops. Well, until now so fingers crossed - but it's been a week though so it should be fine...

    Z30, STA100-2 /10.3.2.2639
    FF22 likes this.
    12-11-15 04:40 PM
  21. 10_z_no gimmick's Avatar
    I forgot to mention that my signal is still emitted from my wireless modem router. Dlink access point just repeats the signal.

    Z30, STA100-2 /10.3.2.2639
    12-11-15 04:43 PM
  22. lukatrifunovict's Avatar
    Problem is, I don't own router, my father does. So I guess I would have to persuade him to change settings for the router.

    BlackBerry Z30 STA100-5 10.3.2.2813/2530
    12-13-15 07:36 AM
  23. ultra07's Avatar
    I had similar issues with wifi on my Verizon Z30. Turns out it was my six year old Netgear router. I just replaced it with a new Netgear Nighthawk AC1900. (model R7000) My wifi signal went from 2 bars to all 4 bars. No more dropped wifi! The phone will connect on the 2.4 GHz or the 5GHz bands! (less traffic on the 5GHz band) Hope this helps!
    FF22 likes this.
    12-14-15 07:33 PM
  24. uinktyo's Avatar
    As Paul said, all was fine when running 10.2. These wifi issues started with the first release of 10.3.

    End of story.

    "Z30 STA100-2 UK" 10.3.2.2474 Get's a Ten from Fen.
    Yeah also mine have problem I think it's not router issue since my ipad and iphone at the same time working well , this problem happened after updated to latest software

    Delivered by my Z30
    12-15-15 08:32 AM
  25. kbz1960's Avatar
    My Z30 hasn't ever done that thru all the OS versions. The only time it did was when it was a BlackBerry server issue.
    anon(3732391) likes this.
    12-15-15 08:44 AM
29 12

Similar Threads

  1. BB10 can only survive with a radical strategy and a vision
    By Superdupont 2_0 in forum Armchair CEO
    Replies: 14
    Last Post: 10-28-15, 01:24 AM
  2. Why isn't my BlackBerry Curve opening when why is it showing a white screen on the display?
    By CrackBerry Question in forum General BlackBerry News, Discussion & Rumors
    Replies: 1
    Last Post: 10-22-15, 10:28 AM
  3. Passport and Blackberrys insurance?
    By shawnreum in forum BlackBerry Passport
    Replies: 1
    Last Post: 10-18-15, 11:06 AM
  4. ReadItNow! updated to version 7.7 with a new grid cover theme, fixes and improvements
    By CrackBerry News in forum CrackBerry.com News Discussion & Contests
    Replies: 0
    Last Post: 10-18-15, 09:30 AM
  5. Opening BBM Channel links in browser (and Apps)
    By SC2Bud in forum General BBM Chat
    Replies: 1
    Last Post: 10-18-15, 09:04 AM
LINK TO POST COPIED TO CLIPBOARD