1. yohannyphm's Avatar
    About 3 month ago I was running out of memory on my old 8 SD card and bought a 64 Samsung SD card, since then I have run several times on the massage Media Card Problem. Since I have a backup file and photos SD card I just formatted the card and get on with my life. Today I got a new issue I tried to format the card and got this message "An error occurred and drivers was not downloaded" can't format card to use with Z30. I placed the card on my GF SG3 and formatted it and was working on the GS3, I inserted it on my lap top an was able to format it. But when placed on Z30 same issue. Any ideas?
    Trouble with 64 SD card and Z30-img_20140426_201536.png
    Trouble with 64 SD card and Z30-img_20140426_201531.png
    Trouble with 64 SD card and Z30-img_20140426_201512.png

    Posted from my flagship Z30 10.2.1.2947/2759
    04-26-14 09:34 PM
  2. thurask's Avatar
    Is the drive formatted as exFAT or FAT32?

    If it's exFAT, use this: How to Format External Hard Drive to FAT32 in Windows
    04-27-14 12:17 AM
  3. pmccartney's Avatar
    I use the Fat32formatter, found in thurask's post above. It was simple and quick.
    I have a Win7 64 PC.
    04-27-14 12:24 AM
  4. yohannyphm's Avatar
    Update
    Command prompt format gives massage" too large for FAT32" Smart disk FAT32 format utility don't recognize the drive. FAT32 Format is doing the job but it will take 3 hours to get it done. Will update. The funny thing is the SD card was working well and suddenly all pictures taken with camera starting not saving on SD. Pictures copied or moved from phone to SD where turned black,file was there,can't be displayed. Old pictures, video and files were able to be read copied and moved. No new data was able to be stored.

    Posted from my flagship Z30 10.2.1.2947/2759
    04-27-14 07:27 AM
  5. habs_fan's Avatar
    Update
    Command prompt format gives massage" too large for FAT32" Smart disk FAT32 format utility don't recognize the drive. FAT32 Format is doing the job but it will take 3 hours to get it done. Will update. The funny thing is the SD card was working well and suddenly all pictures taken with camera starting not saving on SD. Pictures copied or moved from phone to SD where turned black,file was there,can't be displayed. Old pictures, video and files were able to be read copied and moved. No new data was able to be stored.

    Posted from my flagship Z30 10.2.1.2947/2759
    Same thing happened to me.

    Posted via CB10
    04-27-14 07:30 AM
  6. fbloise's Avatar
    Same thing happened to me too. I formated it several times from the Z30 itself and eventually it did fix and settle.

    Not sure what causes this issue.

    Posted via CB10 with 'Berry Z30
    04-27-14 08:35 AM
  7. yohannyphm's Avatar
    Update
    Fat32 Format did the job I used quick format because the long one after 2 hours was telling me it will take 7 hours more and was at 21%. I did the quick format and now Z30 can read the SD. I'm copying all file back to SD will update

    Posted from my flagship Z30 10.2.1.2947/2759
    04-27-14 09:16 AM
  8. yohannyphm's Avatar
    It worked all pictures where copied to SD card. Only the ones during the period of the problem can be seen on device but if copied or transferred to SD they are black. I guess I'll keep those on internal memory and laptop. Thank Thurask, again for all your help

    Posted from my flagship Z30 10.2.1.2947/2759
    04-27-14 10:12 AM
  9. d.roc's Avatar
    I have had some problems with my 64gb from time to time. It's formatted properly, but in the last few months the card has stopped working and I almost lost a lot of pictures. Anyway, I set my One Drive to backup all my pics so I didn't lose anything.

    Brought to you by...My sweet Z30
    04-27-14 01:52 PM
  10. yohannyphm's Avatar
    I have had some problems with my 64gb from time to time. It's formatted properly, but in the last few months the card has stopped working and I almost lost a lot of pictures. Anyway, I set my One Drive to backup all my pics so I didn't lose anything.

    Brought to you by...My sweet Z30
    Just did the same thanks

    Posted from my flagship Z30 10.2.1.2947/2759
    04-27-14 04:06 PM
  11. tjarkmentos's Avatar
    I'm also on Z30 (STA100-5) 10.2.1.2974 and transferred my previous SanDisk Ultra SDXC 64GB from my Z10. This card was previously formatted to FAT32 and works flawlessly in both the Z10 and my Z30. There was such a good deal recently on a SanDisk Extreme Plus 64GB with much faster read/write speeds that I bought one. It comes formatted in ExFat and I tried formatting in the Z30 with the error message after "trying" to download drivers. I formatted it in my computer to FAT32, transferred original photos, music and files to the card and put it in the phone. It seems to work initially, then new photos taken start to just be black and the 17GB of original photos, etc. could not be accessed on the phone. Trying numerous times to format via the Z30 resulted in the same error and not being able to download drivers. I am going to try getting a replacement card to see if this one is faulty, but the original SD Ultra is back in reliable action in the meantime.

    Long story short, I am having the same frustrating problems too!

    Unlocked Z30 on AT&T, 10.2.1.2947
    04-27-14 06:22 PM
  12. Clanked's Avatar
    I got the sony 64gb micro sd...40mb/s....i'm very satisfied in this sd...highly recommend!

    Posted via CB10
    04-27-14 09:49 PM
  13. yohannyphm's Avatar
    Long term follow up
    After FAT 32 the issue seams resolved, but the pictures taken during the problems time period where left unreadable .
    A new issue has started don't know if related, I received a text message from a co-worker with a picture and it was black, he send it back and it came black again. I try with "Open In" from overflow menu and selected Mockit APP and there it was. I just made a Meme and rescue the picture other options didn't worked (scanners or printer APP)
    Also I notice a picture taken with camera can be seen on picture APP on Albums but if I select the picture it got blocked by a Grey bar. I even manage to take a screen shot to recover the calendar but will like to know if it is a security measure a bug or a way to work it around.
    Trouble with 64 SD card and Z30-img_20140505_062748.png
    Trouble with 64 SD card and Z30-img_20140505_065948.png
    Trouble with 64 SD card and Z30-img_20140505_065336.png
    Trouble with 64 SD card and Z30-mockit_04052014204802.jpg
    Trouble with 64 SD card and Z30-img_20140505_062838.png
    Trouble with 64 SD card and Z30-img_20140505_062903.png
    Trouble with 64 SD card and Z30-img_20140505_063109.png
    Trouble with 64 SD card and Z30-img_20140505_062847.png

    Posted from my flagship Z30 10.2.1.2947/2759
    05-05-14 07:01 AM
  14. mberdych's Avatar
    Z30 is not working with Sandisk extreme class. Had the same issues with 2 same cards and then took Sandisk class 10 and no issues.

    Posted via CB10
    05-05-14 01:36 PM
  15. Dat Gui's Avatar
    Never had trouble with mine. But try formatting it. I know people have trouble with other smartphones and 64gb darts
    05-05-14 01:48 PM
  16. Mr_Runningfromlife's Avatar
    can you format on a mac?
    07-01-14 07:13 PM

Similar Threads

  1. Replies: 28
    Last Post: 04-28-14, 11:25 PM
  2. Information on Blackberry Service and its requirement
    By Priyabrata Chakraverti in forum BlackBerry 9720
    Replies: 11
    Last Post: 04-27-14, 03:37 PM
  3. Replies: 15
    Last Post: 04-27-14, 02:32 PM
  4. Red light FLASHING and device wont turn on
    By AJMR2498 in forum BlackBerry Z10
    Replies: 5
    Last Post: 04-27-14, 03:38 AM
  5. Blackberry Z10 with AT&T not providing 10.2 SW update
    By lorwilson in forum BlackBerry 10 OS
    Replies: 1
    Last Post: 04-26-14, 10:02 PM
LINK TO POST COPIED TO CLIPBOARD