1. jupiter8's Avatar
    Since buying my Z30 from a Canadian that got it from Telus, the phone would not update. I was sure that I was stuck on 10.2.0.210. I've tried occasionally and it always tells me there is no update available.

    Well that change today! My phone on T-Mobile is updating to 10.2.0.429 as I write this. Anyone on T-Mobile getting the same?

    T-Mobile 10.2.0.429 downloading now on my Z30-screen-131125-174855.png
    11-25-13 08:47 PM
  2. 512high's Avatar
    I take it your model is a sta100-5? I'm thinking of leaving Sprint seeing they may not carry the z30, and get one that will work on T-Mobile USA. did you have any issues getting service from T-Mobile for that phone? or was that your provider? thanks and congrats!
    11-25-13 09:10 PM
  3. jupiter8's Avatar
    I take it your model is a sta100-5? I'm thinking of leaving Sprint seeing they may not carry the z30, and get one that will work on T-Mobile USA. did you have any issues getting service from T-Mobile for that phone? or was that your provider? thanks and congrats!
    It is an STA100-5. I was already on T-Mobile with my Z10. I just transferred the SIM to the Z30, and it immediately downloaded the T-Mobile user account app and connected without issue. I did have to unlock it since it was from Telus. It works great, no issues at all. But I was a bit surprised when 10.2.0.429 started downloading. It would not load any of the other 10.2. updates past the base version until today.
    11-25-13 09:21 PM
  4. hazarder's Avatar
    I got my Z30 on Friday, and soon as I powered it on I got that update. Same model same carrier

    Posted via my NEW Zed30
    jupiter8 likes this.
    11-25-13 09:24 PM
  5. jupiter8's Avatar
    I got my Z30 on Friday, and soon as I powered it on I got that update. Same model same carrier

    Posted via my NEW Zed30
    That's why I love T-Mobile. Best carrier I've used (and I've used them all).
    hazarder likes this.
    11-25-13 09:32 PM
  6. JJStripes's Avatar
    Wifi calling? I'm on 10.2.1.1055, but I'd consider a step back for Wifi calling.

    Posted via CB10
    11-25-13 10:08 PM
  7. tlegend2012's Avatar
    No Lte Correct?
    11-25-13 10:12 PM
  8. anon5398027's Avatar
    Wifi calling? I'm on 10.2.1.1055, but I'd consider a step back for Wifi calling.

    Posted via CB10
    Where would that option appear ?

    Btw. T-Mobile Germany is also on .429 now.
    11-25-13 10:15 PM
  9. jupiter8's Avatar
    Wifi calling? I'm on 10.2.1.1055, but I'd consider a step back for Wifi calling.

    Posted via CB10
    No wifi calling. I only had that with 10.1 on my Z10.

    No Lte Correct?
    LTE all day long.
    11-25-13 10:20 PM
  10. hazarder's Avatar
    T-Mobile 10.2.0.429 downloading now on my Z30-img_20131131.png
    I restarted my z30 using the volume up/down method. And that icon appeared next to the 4GLTE, I imagine that might be wifi calling? I have no way to toggle it on or off.
    Mind you I deleted the t-mobile app soon as I could. So take with that what you can.

    Posted via my NEW Zed30
    11-26-13 02:15 AM
  11. whatsever's Avatar
    I have a problem that when I call or receive a call the sound to hear from the speakers are not so loud but still I can hear it but for my feeling it need some boosting in loudness. What you people thinking
    11-26-13 03:25 AM
  12. shai404's Avatar
    New features?


    Z10/Q10/Z30
    11-26-13 08:28 AM
  13. gallopiton's Avatar
    Good morning, typing this from my Z30 unlocked from Telus and with the .1055 os installed. I got the update (I am with T-Mobile as well) as soon as I checked for it, and I have LTE signal all the time (I live at North Atlanta). I also think my volume during calls is too low. If anyone knows how to improve this would be great. Thanks

    I have a problem that when I call or receive a call the sound to hear from the speakers are not so loud but still I can hear it but for my feeling it need some boosting in loudness. What you people thinking
    11-26-13 09:12 AM
  14. jupiter8's Avatar
    Good morning, typing this from my Z30 unlocked from Telus and with the .1055 os installed. I got the update (I am with T-Mobile as well) as soon as I checked for it, and I have LTE signal all the time (I live at North Atlanta). I also think my volume during calls is too low. If anyone knows how to improve this would be great. Thanks
    That looks like an older version. My OS version that updated yesterday is 10.2.0.1803, which corresponds to the release of 10.2.0.429.

    T-Mobile 10.2.0.429 downloading now on my Z30-screen-131126-072913.png
    T-Mobile 10.2.0.429 downloading now on my Z30-screen-131126-073359.png
    11-26-13 10:37 AM
  15. jupiter8's Avatar
    New features?


    Z10/Q10/Z30
    I haven't really looked around much as I'm studying long hours right now. I did notice the black theme became available to me, but I think that was in one of the incremental releases between my old base release and the one installed yesterday. I'm happy about that as I've been wanting the black theme in my calendar.
    11-26-13 10:56 AM
  16. jupiter8's Avatar
    I have a problem that when I call or receive a call the sound to hear from the speakers are not so loud but still I can hear it but for my feeling it need some boosting in loudness. What you people thinking
    I hate low volume on phones, and have struggled with many of my previous devices. To me, the Z30 is less loud than my Z10, but is still good for my ears.
    11-26-13 10:57 AM
  17. hazarder's Avatar
    I hate low volume on phones, and have struggled with many of my previous devices. To me, the Z30 is less loud than my Z10, but is still good for my ears.
    Yeah that holds true with me aswell. Super funny, how the speakers are loud but the in-call volume is low. I don't have a problem with that though

    Posted via my NEW Zed30
    11-26-13 11:19 AM
  18. gallopiton's Avatar
    my bad, i meant the 10.2.1.1055 (lazy me, i didn't want to write the whole thing hahaha)

    That looks like an older version. My OS version that updated yesterday is 10.2.0.1803, which corresponds to the release of 10.2.0.429.

    Click image for larger version. 

Name:	screen-131126-072913.png 
Views:	306 
Size:	41.9 KB 
ID:	224417
    Click image for larger version. 

Name:	screen-131126-073359.png 
Views:	305 
Size:	134.7 KB 
ID:	224418
    11-26-13 11:29 AM
  19. tlegend2012's Avatar
    No wifi calling. I only had that with 10.1 on my Z10.



    LTE all day long.
    Now, you're giving me ideas to go buy one and use it on ATT
    11-26-13 11:33 AM
  20. tlegend2012's Avatar
    Where would that option appear ?

    Btw. T-Mobile Germany is also on .429 now.
    must be a tmobile device.
    11-26-13 11:38 AM
  21. Fidel Mercado's Avatar
    Can you use android launchers on BB10 with the new runtime?
    11-26-13 11:40 AM
  22. Bushrover's Avatar
    Thanks for the information and just did a software update check and there it was the 10.2.0.429 update - loving the z30 more I use it
    11-26-13 10:25 PM

Similar Threads

  1. Replies: 17
    Last Post: 12-27-13, 11:27 AM
  2. Why BlackBerry 10 .apk installation isn't Piracy
    By SCrid2000 in forum General BlackBerry News, Discussion & Rumors
    Replies: 70
    Last Post: 11-30-13, 07:10 PM
  3. 10.2.0.429 OS Update for Wind Mobile
    By umarjavaid in forum BlackBerry 10 OS
    Replies: 11
    Last Post: 11-28-13, 01:56 PM
  4. Not able to update to 10.2
    By jacemo76m in forum BlackBerry Z10
    Replies: 11
    Last Post: 11-26-13, 01:38 AM
LINK TO POST COPIED TO CLIPBOARD