03-03-14 08:04 PM
27 12
tools
  1. netnomad's Avatar
    Hi friends

    I bought the Z30 2 months ago and I love it very much!
    In the last 2 months, it works perfectly. Smooth, fast, good battery life...
    But.
    Last night, when I was using the browser to facebook chat with some friend, it turned off suddenly!
    Weird!!! Battery still over 10% I thought. So, I tried to plug in the charger.
    The legend 9900's red light nightmare seems to comeback!
    The lovely Z30 just turn the red light on in about 15 seconds then off. Plug into computer, no chance, computer does not recognize any device.

    I gave up after many failure. Now I leave it at warranty center. Hope they can bring it back!
    02-27-14 11:03 PM
  2. Atmarix's Avatar
    Omg I feel your pain
    Hopefully you get it back soon and fixed

    From my White Z30
    netnomad likes this.
    02-27-14 11:05 PM
  3. BerryRipe's Avatar
    They will give you another if it's not repairable right?

    Keep The Faith ? BlackBerry Q10 ?
    02-27-14 11:05 PM
  4. netnomad's Avatar
    Currently they have no idea what is the error
    02-27-14 11:07 PM
  5. Jakob Greve's Avatar
    Always try turning off / on the device by pressing and holding the volume buttons on the side. Try reloading the os. Post this forum before you reach your conclusion
    02-27-14 11:13 PM
  6. seascape's Avatar
    That sucks. Once when my Z10 seemed to be bricked, I did a pull, and it came back to life without a problem. But I guess you couldn't try that since the Z30 has a nonremovable battery :/
    netnomad likes this.
    02-27-14 11:56 PM
  7. BBUniq01's Avatar
    That sucks. Once when my Z10 seemed to be bricked, I did a pull, and it came back to life without a problem. But I guess you couldn't try that since the Z30 has a nonremovable battery :/
    That is why a lot of long time BlackBerry users want removable batteries.

    Zed 10 with 1925 leak
    02-28-14 07:50 AM
  8. heading4tomorrow's Avatar
    What were you doing, or did you have anything different on your Z30 before red light problem?
    02-28-14 09:47 AM
  9. netnomad's Avatar
    There was nothing strange. Battery level was 10%. No charger plugged in. I was replying some messages then it suddenly turn off?

    Posted via CB10
    03-02-14 09:29 AM
  10. evilcmac's Avatar
    How long was it on the charger?

    Crushed on my Q5 or flicked on my Z30!
    03-02-14 09:38 AM
  11. sosof's Avatar
    Yeah same happened to Z10 and had it replaced. The cause was the charger. I was using the one hand came with my PlayBook. It's not fixable though.

    Did notice any blue screen coming up?

    Posted via CB10
    03-02-14 10:09 AM
  12. heading4tomorrow's Avatar
    Yeah same happened to Z10 and had it replaced. The cause was the charger. I was using the one hand came with my PlayBook. It's not fixable though.

    Did notice any blue screen coming up?

    Posted via CB10
    People have been using PlayBook charges since first Z10 came out and this is the first time I heard that charger messing anything up. Are you %100 sure it was the charger? You seem to be certain somehow.



    Sent from my Z30 using Tapatalk
    03-02-14 12:53 PM
  13. CyberMan2013's Avatar
    Hi friends

    I bought the Z30 2 months ago and I love it very much!
    In the last 2 months, it works perfectly. Smooth, fast, good battery life...
    But.
    Last night, when I was using the browser to facebook chat with some friend, it turned off suddenly!
    Weird!!! Battery still over 10% I thought. So, I tried to plug in the charger.
    The legend 9900's red light nightmare seems to comeback!
    The lovely Z30 just turn the red light on in about 15 seconds then off. Plug into computer, no chance, computer does not recognize any device.

    I gave up after many failure. Now I leave it at warranty center. Hope they can bring it back!
    Try taking out the SIM card and SD card and leave it unplugged overnight then put them back in and plug in the original charger that came with the device and leave it for at least 2 hours and see if it will charge or show any signs of life.

    Posted via CB10
    03-02-14 01:16 PM
  14. sosof's Avatar
    People have been using PlayBook charges since first Z10 came out and this is the first time I heard that charger messing anything up. Are you %100 sure it was the charger? You seem to be certain somehow.



    Sent from my Z30 using Tapatalk

    Yeah I've used it for long time as well but in recent times I started to notice a blue screen coming up and restarting my phone when ever I plug the charger. then it just died the same way with the red lights on. I wasn't sure of the cause at first but when it happened again to my loaner phone it made sense. I stopped using it and the problems disappeared as well

    Posted via CB10
    03-02-14 02:35 PM
  15. diesel0110's Avatar
    There's several blogs/forums that can assist you in reviving a bricked/nuked BB. Especially your Z30. I made sure when I purchased my unlocked z30 from eBay with no phone insurance that that information was available. And the process is much simpler than how it was years ago. I've added a link. Hope it helps, but keep searching there's always ppl on the net with answers and viable solutions.

    http://nerdberry.net/2013/07/09/how-...rry-10-device/

    Posted via CB10
    Last edited by diesel0110; 03-02-14 at 03:15 PM.
    03-02-14 02:48 PM
  16. bbhybridchris's Avatar
    In certain cases such as mine they can be completely bricked with no way to revive them. I ended up purchasing a new on contract Z30 and couldn't be happier. Now I have an extra for parts if need be.

    Posted via CB10
    03-02-14 02:59 PM
  17. heading4tomorrow's Avatar
    Yeah I've used it for long time as well but in recent times I started to notice a blue screen coming up and restarting my phone when ever I plug the charger. then it just died the same way with the red lights on. I wasn't sure of the cause at first but when it happened again to my loaner phone it made sense. I stopped using it and the problems disappeared as well

    Posted via CB10
    That's very scary.
    Which playbook charger? The original one?
    So what are you using to charge right now?

    I hated the normal BB charger, it was too slow to charge it, PB charger has been amazing with all my other devices including my sony cameras, wife's android phone, my 9900, the playbook of course, and all other stuff that had microUSB charging port.
    03-02-14 10:38 PM
  18. kdklein's Avatar
    People have been using PlayBook charges since first Z10 came out and this is the first time I heard that charger messing anything up. Are you %100 sure it was the charger? You seem to be certain somehow.



    Sent from my Z30 using Tapatalk
    My PlayBook charger bricked two z10s. Plugged in for a few minutes then gone forever...both of them. I was ordering them from someone on here who couldn't get them returned because of carrier BS. It was a rather expensive ordeal.
    03-02-14 10:44 PM
  19. BB_makes_it_happen's Avatar
    I've had similar issues. In my case it has something to do with my flip case. I simply run my finger nail to crack open the rear case and the unit boots up. This has always worked - and if the battery was drained - plugged the Z30 in to charge her and I'm back in business. Hope your issue is as simple as mine!

    Posted via CBten with the Zthirty.
    03-02-14 11:15 PM
  20. heading4tomorrow's Avatar
    My PlayBook charger bricked two z10s. Plugged in for a few minutes then gone forever...both of them. I was ordering them from someone on here who couldn't get them returned because of carrier BS. It was a rather expensive ordeal.
    That's really messed up. Why isn't there a thread on PB charger bricking BB10 devices? Did you start a thread on this before, if not, I think you should..
    This is scary as hell, I also got my Z30 online and cannot return or get repairs anymore so it would suck if I lost my primary device to a PB charger.. I have been charging mine for over 2 weeks with it.
    03-03-14 10:32 AM
  21. Dave Bourque's Avatar
    That's really messed up. Why isn't there a thread on PB charger bricking BB10 devices? Did you start a thread on this before, if not, I think you should..
    This is scary as hell, I also got my Z30 online and cannot return or get repairs anymore so it would suck if I lost my primary device to a PB charger.. I have been charging mine for over 2 weeks with it.
    I have used the PlayBook charger for a entire year and my one and only Z10 never died...

    Z10STL100-3/10.2.1.2141
    mjdimer likes this.
    03-03-14 10:36 AM
  22. kdklein's Avatar
    That's really messed up. Why isn't there a thread on PB charger bricking BB10 devices? Did you start a thread on this before, if not, I think you should..
    This is scary as hell, I also got my Z30 online and cannot return or get repairs anymore so it would suck if I lost my primary device to a PB charger.. I have been charging mine for over 2 weeks with it.
    I did start a couple at the time. There have been a few others started since then. I think it is just not a widespread issue.
    03-03-14 11:03 AM
  23. altrax's Avatar
    People have been using PlayBook charges since first Z10 came out and this is the first time I heard that charger messing anything up. Are you %100 sure it was the charger? You seem to be certain somehow.



    Sent from my Z30 using Tapatalk
    I fried two Z10's with my playbook charger... only found out it was the charger when the second one blue screened in my hands while it was on the charger, the first one died overnight on the same charger. If you look hard enough here and on the BlackBerry Support forums you will notice a decent amount of people with similar issues of frying the Z10 (though a lot more often it's with some non BlackBerry Car chargers)

    Needless to say I now only use the official BlackBerry chargers that came with my Z30 and Q10

    Posted via CB10
    03-03-14 03:46 PM
  24. kdklein's Avatar

    Needless to say I now only use the official BlackBerry chargers that came with my Z30 and Q10

    Posted via CB10
    Second that.
    03-03-14 04:08 PM
  25. heading4tomorrow's Avatar
    I fried two Z10's with my playbook charger... only found out it was the charger when the second one blue screened in my hands while it was on the charger, the first one died overnight on the same charger. If you look hard enough here and on the BlackBerry Support forums you will notice a decent amount of people with similar issues of frying the Z10 (though a lot more often it's with some non BlackBerry Car chargers)

    Needless to say I now only use the official BlackBerry chargers that came with my Z30 and Q10

    Posted via CB10
    You mean when you fried it it wasn't official playbook charger? I am using official playbook charger, not some knockoff..

    I can't find those threads you mentioned where people confirmed official playbook charger frying Z10's or Z30's. I don't think it is as widespread as you think it is, or maybe I did not search properly.
    Here are some successful PB charging Z10 results:
    http://forums.crackberry.com/blackbe...10/index2.html
    http://forums.crackberry.com/blackbe...28/index2.html

    I am currently using the official PB charger with Z10, Q10, two different Z30's and used it with 9900 for many months. No problems so far.
    03-03-14 04:14 PM
27 12

Similar Threads

  1. What is your score on Flappy Herbie?
    By Blackman91 in forum BlackBerry PlayBook
    Replies: 19
    Last Post: 03-24-14, 05:18 AM
  2. The 6 mb limit on BBM is being increased
    By ad19 in forum General BlackBerry News, Discussion & Rumors
    Replies: 23
    Last Post: 03-04-14, 02:23 AM
  3. 14 Hours Off My Charger...
    By iNick89 in forum BlackBerry Q10
    Replies: 5
    Last Post: 02-28-14, 06:31 AM
  4. Does Anyone have a Suggestion on Watches?
    By tntmom2013 in forum General BlackBerry News, Discussion & Rumors
    Replies: 1
    Last Post: 02-27-14, 10:09 PM
  5. Replies: 1
    Last Post: 02-27-14, 08:46 PM
LINK TO POST COPIED TO CLIPBOARD