1. Skidoo583's Avatar
    I have owned my unlocked z30 for almost two years and have had no problems.
    It received the 10.3.3 update over the air a few weeks ago and it after the update the hub was glitching bad so I did a factory reset and everything was all good phone worked normal absolutely no problems
    So about a week later I sold the phone on eBay the buyer had zero (feedback)
    About a week later the buyer said the phone wasn't working properly.
    When you open the settings and the window opens it goes blank There is also some of the other factory installed apps not working.
    I put my SIM card in and can make phone calls and the phone I call rings but on the blackberry there is no sound of the call going through also it will not connect to the internet
    Im to attach the video they made.
    03-06-17 08:44 PM
  2. conite's Avatar
    Settings going black is a known issue with 10.3.3. Only cure is an autoloader.
    03-06-17 08:46 PM
  3. Skidoo583's Avatar
    So the buyer probly didn't cause this by the sounds of it??
    03-06-17 08:48 PM
  4. Skidoo583's Avatar
    Can I use the blackberry desktop to do the fix.
    03-06-17 08:49 PM
  5. conite's Avatar
    So the buyer probly didn't cause this by the sounds of it??
    Unlikely.
    03-06-17 09:04 PM
  6. conite's Avatar
    Can I use the blackberry desktop to do the fix.
    10.3.3 has been pulled pending fixes, so if the buyer plugs into Link, it won't help him.

    The ONLY solution is autoloader.
    zruiyin likes this.
    03-06-17 09:06 PM
  7. Skidoo583's Avatar
    10.3.3 has been pulled pending fixes, so if the buyer plugs into Link, it won't help him.

    The ONLY solution is autoloader.
    Ok thank you for the help.
    03-06-17 09:14 PM
  8. Skidoo583's Avatar
    It's been awhile since I've done an auto loader. But if I remember right you can't go down in the os number correct?? If that's true how can I fix this problem if no fix has been released
    03-06-17 10:27 PM
  9. conite's Avatar
    It's been awhile since I've done an auto loader. But if I remember right you can't go down in the os number correct?? If that's true how can I fix this problem if no fix has been released
    Use the 10.3.3.2205 autoloader again. It is unlikely to happen twice.
    03-06-17 10:39 PM
  10. Skidoo583's Avatar
    Use the 10.3.3.2205 autoloader again. It is unlikely to happen twice.
    Thanks again.
    03-06-17 10:51 PM
  11. Skidoo583's Avatar
    03-07-17 12:11 PM
  12. Skidoo583's Avatar
    Does that look correct for the auto loader??
    03-07-17 12:12 PM
  13. Skidoo583's Avatar
    It's doing something. Hope It doesn't mess the phone up more.
    03-07-17 12:15 PM
  14. Skidoo583's Avatar
    Ok it says I have os10.3.3.1463
    Seems to be working now. Going to put my SIM card in and see what happens
    03-07-17 12:25 PM
  15. braulio_jose's Avatar
    Use the 10.3.3.2205 autoloader again. It is unlikely to happen twice.
    It has happened 3 times to me. It would be nice to know what causes this and have a non destructive solution.
    11-09-17 07:20 PM
  16. conite's Avatar
    It has happened 3 times to me. It would be nice to know what causes this and have a non destructive solution.
    Try the 10.3.3.3057 autoloader. I haven't heard of any reports of black setting screen on that.

    You could also give the full blitz a shot if you don't want to wipe.
    braulio_jose and MarCiano274 like this.
    11-09-17 07:24 PM
  17. braulio_jose's Avatar
    Try the 10.3.3.3057 autoloader. I haven't heard of any reports of black setting screen on that.

    You could also give the full blitz a shot if you don't want to wipe.
    With Sachesi? Am I mistaken if I believe I need to get to settings to put the device on development mode? I could not do it if I can't do that. Am I wrong?
    11-09-17 09:08 PM
  18. conite's Avatar
    With Sachesi? Am I mistaken if I believe I need to get to settings to put the device on development mode? I could not do it if I can't do that. Am I wrong?
    No need for development mode on either Sachesi or DBBT.

    But no guarantee that the non-destructive update method will clear out the problem.
    11-09-17 09:24 PM
  19. braulio_jose's Avatar
    No need for development mode on either Sachesi or DBBT.

    But no guarantee that the non-destructive update method will clear out the problem.
    Until now Sachesi does not connect. I'll have to try with DBBT but I am not very optimistic.

    Code:
    [20:47:42] Communication Error: 1 (Connection refused) from 169.254.122.153
    [20:47:44] Communication Error: 1 (Connection refused) from 169.254.122.153
    [20:47:44] Communication Error: 1 (Connection refused) from 169.254.122.153
    [20:47:48] Communication Error: 1 (Connection refused) from 169.254.122.153
    [20:47:51] Communication Error: 1 (Connection refused) from 169.254.122.153
    [20:47:54] Communication Error: 1 (Connection refused) from 169.254.122.153
    Etc.
    11-09-17 09:48 PM
  20. conite's Avatar
    Until now Sachesi does not connect. I'll have to try with DBBT but I am not very optimistic.

    Code:
    [20:47:42] Communication Error: 1 (Connection refused) from 169.254.122.153
    [20:47:44] Communication Error: 1 (Connection refused) from 169.254.122.153
    [20:47:44] Communication Error: 1 (Connection refused) from 169.254.122.153
    [20:47:48] Communication Error: 1 (Connection refused) from 169.254.122.153
    [20:47:51] Communication Error: 1 (Connection refused) from 169.254.122.153
    [20:47:54] Communication Error: 1 (Connection refused) from 169.254.122.153
    Etc.
    Reboot both phone and computer.
    11-09-17 10:39 PM
  21. braulio_jose's Avatar
    Reboot both phone and computer.
    Hi.

    That does not solve the problem. Anyway, the other times it happened I was able to connect during some seconds using BlackBerry link and then the connection stopped working. Therefore it is impossible to backup or to sideload anything.

    I think I know what's happening! Any connection that uses certificates fails. In fact, I can use the BlackBerry browser or Browsie Browser with any site that does not use HTTPS. The Crackberry app does not let me login since it uses HTTPS, for instance. Amazon App Store does not work. BBM says it lost connection. Etc. Anything using certficates fails. That is why a lot of functionality fails, including BlackBerry id not being able to authenticate. I think that is the causality of the blank settings screen.

    Guess what? Whatsapp for BlackBerry works! I guess they are not using the certificate store.

    Do you know of any command I could run from BGShellPlus that could revive the certificate store? I see that there are at least two certificate commands: certmgr_pps and certutil.

    Bests,
    11-10-17 01:08 PM
  22. braulio_jose's Avatar
    Do you know of any command I could run from BGShellPlus that could revive the certificate store? I see that there are at least two certificate commands: certmgr_pps and certutil.
    I've been investigating and I think certmgr_pps actually runs the service for certificates management. It can not be run manually.

    /var/log has info about what could be wrong but I don't have permissions to read the files there.

    My hypotesis is that on some hard reboots (turning off and then on, not just restarting), something gets corrupted, maybe the filesystem (this always happens after turning off and then on the phone). Then the certificate service and maybe others are not started. Since there are many service that depend on the certificate management service to start those are not started (Wifi, VPN, etc.).

    It's a shame a phone does something like that out of nothing.
    11-10-17 03:01 PM

Similar Threads

  1. Replies: 80
    Last Post: 07-30-17, 11:56 AM
  2. BlackBerry KEYone? Chat Reps don't know yet.
    By Ehizzle88 in forum Sasktel
    Replies: 2
    Last Post: 03-11-17, 01:09 PM
  3. Content transfer with dead phone?
    By Formspace in forum BlackBerry Priv
    Replies: 5
    Last Post: 03-07-17, 05:54 AM
  4. updates to BlackBerry apparently for Priv... beta
    By wronz in forum BlackBerry Priv
    Replies: 1
    Last Post: 03-06-17, 04:43 PM
  5. Video Networking project with BlackBerry advice
    By vidgeek897 in forum Rehab & Off-Topic Lounge
    Replies: 0
    Last Post: 03-06-17, 03:23 PM
LINK TO POST COPIED TO CLIPBOARD