1. EFats's Avatar
    No other device in my household has issues with the home WiFi (lots of iDevices, laptops, 5 other BB phones and PlayBook).
    The Z30 works fine other than it seems to take a long time to lock on and unbelievably, it even drops reception once in a while unless I have it right near the router.

    any tips to help figure out what's going on?

    Sent from my BlackBerry 9900 using Tapatalk
    03-12-18 01:57 AM
  2. Dunt Dunt Dunt's Avatar
    What OS version are you on? Might try a different one....
    03-12-18 08:29 AM
  3. EFats's Avatar
    Whatever the latest is for the Z30, can't check right now. It was updated OTA.

    I'm not up for experimental or unofficial builds. No reason to doubt OTA upgrades either, I've have used this for the Z30 and all of my other BB10 devices. (Have Sachesi and tried it before, no particular issue but no obvious advantages either).


    Sent from my BlackBerry 9900 using Tapatalk
    03-12-18 09:56 PM
  4. brookie229's Avatar
    Whatever the latest is for the Z30, can't check right now. It was updated OTA.

    I'm not up for experimental or unofficial builds. No reason to doubt OTA upgrades either, I've have used this for the Z30 and all of my other BB10 devices. (Have Sachesi and tried it before, no particular issue but no obvious advantages either).


    Sent from my BlackBerry 9900 using Tapatalk
    Try disconnecting and deleting the wifi connection in your Z30 then re-connecting using the WPS button on your router and the WPS in your Z30.
    03-12-18 10:04 PM

Similar Threads

  1. Wifi unstable on BBB100-3 after AAV119
    By bb4work in forum BlackBerry KEYone
    Replies: 27
    Last Post: 04-11-18, 09:18 PM
  2. the ear speaker suddenly dies on my K1
    By hrodrig23 in forum BlackBerry KEYone
    Replies: 3
    Last Post: 03-21-18, 01:08 AM
  3. Why does my pc not find srv100 in windows explorer
    By CrackBerry Question in forum Ask a Question
    Replies: 3
    Last Post: 03-15-18, 05:12 PM
  4. Replies: 5
    Last Post: 03-11-18, 12:49 PM
  5. connection wifi issues
    By yeo123 in forum BlackBerry DTEK50
    Replies: 2
    Last Post: 03-11-18, 12:20 PM
LINK TO POST COPIED TO CLIPBOARD