1. anon(2704785)'s Avatar
    Hi everyone,

    I thought I would post my experience with my (formerly) trusty Z30 yesterday afternoon. I had charged the phone all night, powered off, and woke up to the green light indicating that the phone was at full charge. I powered on my device, which was smooth and normal, and proceeded to work. On my break I thought I would check my hub to see what was going on, I clicked on a BBM message and it failed to open. I pressed the back arrow and was taken back to the hub menu, with lag present, and tried again to no avail. I decided to reboot my phone where I held down the power button and selected "restart". The phone did as it normally does and attempt a reboot. A few minutes later I noticed that the phone was frozen on the BlackBerry logo boot screen. I waited several more minutes with the screen frozen in that position and then held the power button down for 10 seconds where I was greeted the LED flashing red for 5 pulses in a continuous cycle. I scrolled through the forums here, and elsewhere, attempting everything I could to fix this issue. I attempted the volume up and down key trick, holding down the power button, connecting the phone to my computer and running an autoloader, using BlackBerry Link and using the IE trick where you go to blackberry.com/updates. NONE of these have resolved my issue. The computer detects and then loses the connection and the light sometimes goes to a yellowish/green back to red with every effort. I called into BlackBerry Tech Support and have opened a ticket with them. I wanted to ask if anybody knows anything else that will fix this issue? I have backed up the device and I purchased it direct from BlackBerry in September of 2014. Needless to say I am extremely disappointed since, like most of you, I have tried to grit my teeth and bear the pain of being a loyal BlackBerry user over the years. Any feedback would be much appreciated! Thank you in advance for your time.
    02-10-15 08:31 AM
  2. Carl Estes's Avatar
    As long as you have all your stuff backed up, I would kick the device back under warranty (less than 1 year).
    sound like you did all of your due diligence/steps available.....
    anon(2704785) likes this.
    02-10-15 09:32 AM
  3. DaFoxGrey's Avatar
    Check the LED blink pattern against the list I linked here:
    http://forums.crackberry.com/blackbe.../#post10301424
    To help determine if it is hardware or software related.
    anon(2704785) likes this.
    02-10-15 09:34 AM
  4. anon(2704785)'s Avatar
    Thank you both for responding! I have since heard back from BlackBerry Customer Support and the individual I spoke to last was able to remote-assist me with all of the steps available to her to no avail. I called back today, two days after the issue was supposedly sent in, and am informed that the repair ticket was never submitted. Shortly after that I get an email apologizing for the inconvenience and then another one immediately after saying that there "may be a charge". Talk about botched customer service. I responded with a disappointed, yet respectful, email and am awaiting their reply. I will keep you posted!
    02-11-15 10:47 AM
  5. Oglon3r's Avatar
    How long have you owned your z30?
    Is it me or from what I see the device is failing after a little over a year of use?

    Supporting the people's struggle worldwide via my STA 100-5, Z30.

    Edit;
    Look at the amount of reported failures in this sub forum alone.

    Attachment 333052
    02-11-15 12:15 PM
  6. relyc's Avatar
    It's just you. Mine was manufactured 11.2013 and works perfectly to this day. I don't think BlackBerry had a higher rate of factory defaults than other brands.
    I also had a Z10 manufactured in 2013 that never had any problems.
    Being a dedicated forum you'll mostly see brand fans eager to try something new (leaks) and people having issues with their phones.

    Posted via CB10
    Carl Estes likes this.
    02-11-15 02:52 PM
  7. Carl Estes's Avatar
    Hey Daddy,

    You've had that device for almost 5 months, and they want to charge you?
    Really?
    One year warranty. It was purchased new, correct?
    I'm sure if you escalate this event, they will take care of it.
    I would try to escalate this to another level. Post Haste.

    Also, if you don't/didn't get insurance for a high dollar device, you can try to get it thru your carrier, usually Asurion, and then wait a while then go for the claim......
    02-11-15 03:10 PM
  8. anon(2704785)'s Avatar
    HI Oglon3r,

    I have owned my Z30 for 5 months. It was purchased brand new from BlackBerry here in Canada in September 2014. I immediately put it into an OtterBox Defender case. Needless to say, it's been cared for a great deal. I did trouble me when searching for a solution to see that a sizable amount of other people have experienced the same or other issues with their Z30.
    02-12-15 06:31 AM
  9. anon(2704785)'s Avatar
    Hi Carl,

    Thanks for the advice. Yesterday, I wrote an email to both the Support Team and a separate email to Mr. Chen, we'll see what happens and I will keep you all posted.

    Thank you all for your contribution to this thread!
    02-12-15 06:32 AM
  10. anon(2704785)'s Avatar
    Hi everyone,

    This morning I received an email from BlackBerry Technical Support and they informed me that they would be sending me a replacement device. I will reserve my satisfaction until I get a fully functional device in my hands but this is a great start and the correct way to solve a problem!

    "Hello Adam,

    Thank you for contacting BlackBerry Technical Support.

    Please be advised that we will be sending you a replacement device by the beginning of the next week. Please bear with us since there was a process error generated on the system while processing the request and we are currently working to correct it. There will not be any charges or cost to you at all.

    If you require further assistance, please feel free to contact us.

    Thank you again for contacting us.

    Sincerely,

    Chris
    BlackBerry Technical Support
    BlackBerry"
    Oglon3r and DaFoxGrey like this.
    02-12-15 08:34 AM
  11. rairhoz's Avatar
    Had that crap last year on my Z10. Software issue. re-install OS. Well, that's what the BB tech told me...

    Posted via BlackBerry Passport
    02-12-15 08:51 AM
  12. Oglon3r's Avatar
    Glad they sorted it out.
    Good Luck!
    What did you wrote to Mr. Chen?
    If you don't mind me asking?

    Supporting the people's struggle worldwide via my STA 100-5, Z30.
    02-12-15 11:10 AM
  13. anon(2704785)'s Avatar
    We tried everything to no avail with regards to re-loading the software. I simply wrote him about my experience and how I have been a BlackBerry supporter since the roller ball days. Hopefully he gets back to me as well!
    02-13-15 06:25 AM

Similar Threads

  1. Why won't my BB PlayBook charge anymore?
    By Mel217 in forum Ask a Question
    Replies: 8
    Last Post: 06-15-15, 01:03 PM
  2. Replies: 257
    Last Post: 04-30-15, 04:21 PM
  3. My bbm is not working. Somebody please help me!!
    By ArmanFami in forum Ask a Question
    Replies: 9
    Last Post: 02-22-15, 07:54 PM
  4. Device Password is on n I still cant reboot? Weird !!
    By gaganjattana in forum General BlackBerry Discussion
    Replies: 8
    Last Post: 02-11-15, 09:58 PM
  5. do you leave 4g on all day?
    By misbah_786 in forum BlackBerry Classic
    Replies: 11
    Last Post: 02-11-15, 03:46 AM
LINK TO POST COPIED TO CLIPBOARD