1. AwJm's Avatar
    Since upgraded to 10.3 persons are complaining that they cannot hear me well.
    I have to basically hold phone right up to my mouth like a walkie talkie for them to hear me..

    Anybody else experience this ?
    03-08-15 07:25 AM
  2. jaydee5799's Avatar
    I haven't had any issues with this. How did you upgrade? Did you load the OS yourself? That is probably the best way to avoid issues.
    03-08-15 07:40 AM
  3. AwJm's Avatar
    I haven't had any issues with this. How did you upgrade? Did you load the OS yourself? That is probably the best way to avoid issues.
    OTA
    03-08-15 07:42 AM
  4. rbtg's Avatar
    if your speaker mic works good then you have a bad mic and you need to change the screen with all accessories on it
    if you sound the same on speaker you need to reinstall your os again
    03-08-15 07:44 AM
  5. prithvi64's Avatar
    Z30 has known issue of Mic. I am also on latest OS 2267 over 2487 bar files and have no issue at all. But, Similar problem was with mine 6 months before and I had to handover to service centre and got replacement.
    03-08-15 07:54 AM
  6. FF22's Avatar
    Download Blackberry Virtual Expert (it may be included in newer versions of the OS). It contains a series of tests.
    03-08-15 09:21 PM
  7. chad1276's Avatar
    These phones are known for mic issues and me myself had replaced two prior to this one for this reason! The same thing happened to me as yourself an upgrade was available I uploaded it and it seemed as if it was the culprit in my issues but it was just how it happened! Z10 and Z30 both have mic issues Google it and you will get plenty of info!! Good luck


    Posted via CB10
    03-09-15 11:17 AM
  8. chad1276's Avatar
    Virtual expert does not have a test for that mic so don't waste your time, it has a speaker phone mic test only the main handset mic has no verifiable test

    Posted via CB10
    03-09-15 11:22 AM
  9. steakman911's Avatar
    You are not alone in mic issues.

    I am on my second Z30 after my first, which otherwise performs flawlessly on 10.3.1.1527 no less...had this issue over the Christmas Holidays...with the Mic slowly degrading to the point that even holding right to my face and speaking quite loud...no one could hear me.

    Took it in to reputable repair shop - guys ran a bunch of tests. He tapped his finger on the mic and could hear it on his test phone quite clearly (I was there when he did this), then tried speaking into the mic..NADDA. He tried to re-load the software to no avail. He seemed to think there was an issue between the noise canceling mics on the right side and the main mic for voice. I ended up buying a new one through Telus for $200 and a 2 yr contract.

    Interesting that a new screen may resolve this issue as per post # 4..?? I was unaware that the mic was part of the screen..??

    Thanx,

    Stk
    03-09-15 11:43 AM
  10. randomroyalty's Avatar
    I am also on my 2nd Z30 due to the main mic issue...strangely enough it started acting up again on the new phone but doing a hard reset (volume up and down simultaneously until the phone reboots) fixed it.

    Posted via CB10
    03-09-15 03:25 PM
  11. LEAS4U's Avatar
    I am also having the same problem. I reloaded the OS and lost the use of the microphone, except when on speaker. Thought maybe i got a bad reload and have reloaded again, with no improvement. Did you ever find cure? BB Z10 OS 10.3.2.858
    Last edited by LEAS4U; 08-16-16 at 08:01 AM. Reason: add detail
    08-16-16 07:59 AM
  12. joeragan's Avatar
    I am also having the same problem. I reloaded the OS and lost the use of the microphone, except when on speaker. Thought maybe i got a bad reload and have reloaded again, with no improvement. Did you ever find cure? BB Z10 OS 10.3.2.858
    I had a similar problem but it was not related to OS reload. In my case it was the sticky substance or glue around the microphone which had melted and covered a part of the hole. I opened the cover and cleaned it up.

    There is a thread in Z30 forum that mentioned this issue, you may want to check it out.

    Posted via my Z30STA100-2/10.3.2.2876
    08-17-16 09:09 AM
  13. Roman Adam1's Avatar
    Yeah, I have had that problem too with my old Z30. Did the same with cleaning out the whole and that did the trick for me. Check it out maybe, could save you a lot of hassle

    Posted via the CrackBerry App for Android
    08-17-16 12:47 PM
  14. joeragan's Avatar
    Here is the thread:

    http://forums.crackberry.com/blackbe.../#post12218711

    Posted via my Z30STA100-2/10.3.2.2876
    08-17-16 09:47 PM
  15. mmhmm's Avatar
    yeah, i have heard about this problem. Maybe blackberry could cover it with warranty?
    08-20-16 02:28 AM

Similar Threads

  1. BlackBerry New device on iOS
    By Loc22 in forum Rehab & Off-Topic Lounge
    Replies: 6
    Last Post: 03-12-15, 12:01 PM
  2. Why won't Skype open on my 10.3 OS Z30?
    By brendangooden1 in forum BlackBerry Z30
    Replies: 4
    Last Post: 03-09-15, 12:41 PM
  3. Unlocked Z30 $350 with 5 easy pay on the Shopping Channel
    By Wireless Gadget in forum BlackBerry Z30
    Replies: 2
    Last Post: 03-08-15, 08:28 AM
  4. Os 10.3.1
    By osama babar in forum Ask a Question
    Replies: 3
    Last Post: 03-08-15, 08:20 AM
  5. Why isn't my internal memory being detected on my Z10?
    By Vijay S in forum BlackBerry Z10
    Replies: 1
    Last Post: 03-08-15, 07:42 AM
LINK TO POST COPIED TO CLIPBOARD