1. TheStoryUp's Avatar
    So I have a Z30, USB powered hub (Macully), and a Western Digital My Passport Ultra external hard drive. I also formatted it to FAT and transferred some mp4 movies onto it.

    Now the WD powers up just fine, same with the hub, and when I connect the hub/WD to the Z30 it flashes twice saying "USB device connected". So it's seems to be connected.

    When I go to File Manager I get nothing though. Not sure what wrong and can't find much literature on the subject at all, maybe there is an Android file manager I can download. Idk, any help thanks.

    01-20-14 07:58 PM
  2. Bla1ze's Avatar
    Reboot your device and try again. I've done the same and my HDD drives works fine. As long as it's FAT, it should see it. You can also try removing the hub from the equation, I don't think USB hubs play nicely.
    01-20-14 08:01 PM
  3. TheStoryUp's Avatar
    Thanks Blaze

    I tried re-booting and removing the hub. When I connect the drive directly to the phone the WD starts to make this weird clicking sound, the light flashes and the phone doesn't flash any messages on the display. I don't think the phone has the power for this particular hard drive. I'm positive I formatted in FAT, but I just did a quick format :/ . I'm in the hospital right now after surgery and this is the time I could really use some movies to watch, it sucks.

    Do you have confirmation from anyone that has used this particular HD?

    Western Digital My Passport Ultra External Hard drive.


    01-20-14 08:45 PM
  4. b1gbleu's Avatar
    WRONG THREAD. I went from pc to phone
    Attached Thumbnails [Help] Z30 USB Host Mode-img_20140120_223124.jpg  
    Last edited by b1gbleu; 01-20-14 at 09:58 PM.
    01-20-14 09:34 PM
  5. TheStoryUp's Avatar
    OK I finally had some time to figure this out.

    WD My Passport external hard drive has a small (read only) partition of basically vendor bloatware I guess you could call it. Some stupid drive utility software and other useless stuff. Anyway when you connect your passport to windows you have to install this software to be able to use the drive. It also creates a virtual cd/dvd drive for some reason.

    Now I tried to format FAT using windows and it worked, but it doesn't recognize the (read only) partition and the bloatware is still there after. From reading online I found that most formatting tools will not work for these drives. I ended up downloading/ installing a program called SwissKnife and using that to format the drive.

    I did a full format first which took about 1-2hrs, once it was done it still didn't work for OTG. I had to delete one of the partitions and quick format again. It worked after that.

    So I can confirm that a Western Digital My Passport Ultra 1TB external hard drive can be used for a USB OTG device for the Z30. Not that I had any doubt :/

    Here's an link where I found some answers.


    02-02-14 05:06 PM

Similar Threads

  1. Giving up my Z30
    By Angus Wong 1 in forum BlackBerry Z30
    Replies: 47
    Last Post: 01-26-14, 01:18 PM
  2. Battery life on 1925 on Z30
    By pgg101 in forum BlackBerry 10 OS
    Replies: 23
    Last Post: 01-26-14, 11:36 AM
  3. Need help - No Blackberry Data on BBM
    By boxxer1371 in forum BlackBerry Q10
    Replies: 8
    Last Post: 01-21-14, 08:26 PM
  4. Ending a call dialed by mistake......please help
    By kareem badr in forum BlackBerry Z10
    Replies: 4
    Last Post: 01-21-14, 11:56 AM
  5. Stock firmware / radio # for Verizon Z30?
    By geekaren in forum BlackBerry Z30
    Replies: 2
    Last Post: 01-20-14, 04:33 PM