1. laserx's Avatar
    I'm on a ship cruising and suddenly my Z30 will not charge. It shows the lighting bolt, but it is not charging. I have tried hard boots, but still no go. The charger is fine my wife's Q10 charges fine. I'm on the latest Telus released software. I have turned the phone off, it. Was at 20%, when I first noticed the problem, and while trying to get it going it has dropped to 10%. What can I do, help, I feel cut off from the world .
    08-31-14 05:10 PM
  2. jaydee5799's Avatar
    Try another outlet? It makes no sense why it won't charge. Reboot and try it again.
    08-31-14 05:16 PM
  3. laserx's Avatar
    I just arrived home to Toronto and hoped someone else had experienced this weird situation. It makes no sense at all. The same charger had no problem charging my wife's Q10 or my Playbook. As I said, when plugged into the charger the battery on the screen shows the lightning bolt, meaning it thinks it's charging. But as I said, it was not charging but losing charge. I've tried, soft boot holding power button and touching restart. I did the volume up and down with the power button, both things more that twice and still losing power.
    Could it be the battery? What will happen once I'm out of power? If I tried to reload the software and it runs out of power before it finishes, what them? Looks like I'll have to make a few calls tomorrow to our Telus rep and to Blackberry support. I'm afraid to let it totally run out of power.
    09-01-14 09:21 PM
  4. herbersh's Avatar
    Only thing I can think to do is to blow out the USB port. Also try a different charger.


    Posted via CB10
    09-01-14 09:32 PM
  5. stefanbechen's Avatar
    If you still have guarantee on the Zed then I would see the dealer. Sounds like the loading electronic went south.
    09-01-14 09:38 PM
  6. blackburberry's Avatar
    A likely scenario is that you have pocket lint or dust in the usb port. Try getting a closeup view of the port with a magnifying glass or...the battery might be toast.
    09-01-14 10:00 PM
  7. laserx's Avatar
    This is a very strange one indeed. The phone is totally dead now, when I attach it to my computer I get a half yellow and half red light blinking on and off, can't boot any longer. I just got off the phone with Telus and they told me to return it and they will give me a loner. They said it would take about two weeks to get it back. Just wish I could have tried another battery, but with this being a non removable battery, I can't try this out. I'll let you all know how things turned out.
    09-02-14 10:41 AM
  8. laserx's Avatar
    He's my update. I called Telus this morning as was told to go to Woodbine Mall to a Telus store there and drop off my broken Z30 and pick up a loner. It's a 30 minute drive from my office in Brampton, so off I went. The store closed last year and does not exist!! I drove back to the office none too pleased and called back. They said sorry about that now go to the store on 980 Albion Rd, Etobicoke. I said please make sure the store is open and that they have a loner. I was put on hold for 5 minutes, he came back and said it is all set up. So off I went, it took about 35 minutes but only one person working in the store so I had to wait about 20 minutes. The girl then told me how my warranty worked and then went to get my their loaner Z10. She couldn't find it? She made a couple of calls and routed about the messy store for about 10 minutes and made another phone call, but could not find the loaner, so after 40 minutes of waiting I left with my broken phone. Now I'm a little pissed, I get back to the office and call again and talk to customer loyalty. I was very civil and told him my story and asked him what he could do to convince me to keep my corporate account with Telus? ( I have about 40 phones with them) He actually laughed on the phone at my wasting time driving to stores. Well all he did was to keep insisting that I had to go to another store and I kept saying I have no more time to waste driving around and that I need them to send me a loner and a RMA. He insisted that they had no loaners and that I had to go to the company I subscribe to Telus with? I explained I'm a corporate account directly with Telus, he still insisted that I had to go to a mall to a Telus store. I in turn insisted that I could not waste more time on this and asked for a Manager, he refused to pass me to a manager and said if I would not go to another store then I was out of luck and he hung up on me!!
    I then called our Telus Rep to ask him how much top cancel our contact right now, but I got voice mail and left him a detailed message. I then called back the normal customer service number and told my story to another person again saying I'm not interested in driving around any more and that I'd rather go without a phone than waste any more time. Again on hold, while she checked things out, I could see another call trying to come in but I ignored it as I didn't want to lose my customer service agent. She came back on, and told me they are sending me a Z30 loaner and RMA for my phone to be returned to be fixed under warranty and that it would take 3 days at the most to arrive. I then checked my voice mail and it was from the Customer Loyalty agents Manager? The same manager he refused to let me talk to I guess. Her message on my work phone number was that she had tried to call my cell 3 times but it went straight to voice mail, DUH!!!! my cell phone is not working that is why I'm calling them!!! She went on to say, since I'm not answering my cell phone, she will try to find the time to call me again tomorrow!! In the mean time my Telus Corporate rep has returned my call, but will be in meetings until 3, so I should be hearing from him any minute. What a complete fail on the part of Telus. I'm going to get my phone fixed under warranty and start the wheels in motion to move on to another carrier, any suggestions on who I should look at, I've been with Telus for 17 years going back to the Mike days. Feels very uncomfortable not having a cell phone...don't like this feeling one little bit.
    09-02-14 03:06 PM
  9. anon(870071)'s Avatar
    Rogers wireless hands up. The best network and for corporate / business accounts, you definitely would not have gotten this type of runaround.

    Posted by CB10 / STA100-5 10.2.1.2977
    09-02-14 10:31 PM
  10. laserx's Avatar
    A quick update, I finally talked to my Telus Corporate Rep and everything changed very quickly. I'm to get my loaner today, we have received a $200.00 credit to our monthly bill as a "sorry for screwing with you" and he's going to get me a Passport the second they have them at Telus. I've decided to stay with Telus and to update all our old BB7 devices to BB10. We're meeting next week to go over the details. I'll post one last time when I get my phone back. I hope they tell me what the problem was and I hope they don't have to wipe it out,my last back up was Aug.8th.
    09-03-14 02:16 PM
  11. prue035's Avatar
    Just plug into the USB of a computer and don't touch it for 2 hours...let it charge slowly. This should fix it.

    Posted via CB10
    09-03-14 03:40 PM
  12. jayodin10's Avatar
    Laserx- did it get sorted? I hope you are back on the Z30 now?

    Published by an awesome Z30! Oohya!
    09-07-14 10:07 AM
  13. laserx's Avatar
    Just got an email from Telus, my wonderful Z30 is on its way home to daddy :-) I had Rogers in today to get a quote on taking over our account. Rogers has come in showing they want our account, they are 20% lower on the monthly rate, with pretty much the same features, the only thing is the data is only 3 gig a phone vs. Telus 6 gig a phone, but I'm sure I can get that taken care of. They are also offering everyone a free upgrade to any Blackberry phone we want, the user can choose from Z10, Z30, Q10, Q5. So it looks like a happy ending.
    09-11-14 04:52 PM
  14. GLTruesdale's Avatar
    Get it replaced for 60 bucks. The USB port that is.

    G's Z30
    09-11-14 05:04 PM
  15. blackburberry's Avatar
    @OP

    Since you state that you manage a corporate account that covers over 40 phones, going forward you should commission a couple of inactive spares for your staff and yourself for just this type of scenario. Then all it takes is a sim swap.
    09-11-14 07:28 PM
  16. laserx's Avatar
    Got another email, it says "Case xxxxx Unit replaced with new IMEI (then the new number)? I'm assuming they are sending a new phone or perhaps they've replaced the Motherboard? My phone was unlocked as I travel a lot, I've emailed my account manager, but he's away until Monday. I've asked him to get me the unlock code for the new IMEI....the fun just never ends :-)
    09-12-14 01:41 PM

Similar Threads

  1. Mobile Hotspot help
    By jonny01blaze in forum BlackBerry Z10
    Replies: 12
    Last Post: 09-01-14, 09:55 AM
  2. Replies: 5
    Last Post: 08-31-14, 08:28 PM
  3. Please Help Me With This Bag
    By YunusMalik in forum Rehab & Off-Topic Lounge
    Replies: 6
    Last Post: 08-31-14, 06:01 PM
  4. Z30 Screen Protector UK
    By piknmix in forum BlackBerry Z30
    Replies: 10
    Last Post: 08-31-14, 05:34 PM
  5. Verizon dropped the Z30...?
    By BB fan forever in forum General BlackBerry Discussion
    Replies: 2
    Last Post: 08-31-14, 03:59 PM
LINK TO POST COPIED TO CLIPBOARD