1. Luciano GC's Avatar
    Hi Everyone,

    I have an issue with my BlackBerry Z30 STA100-5 (Factory Unlocked). I currently have 10.3.3.3216 OS version installed (10.3.3.2137 software version).

    Well, I realized that, since I've installed this latest OS update, when I plug my headphones to listening to FM Radio (or music) I can't hear nothing, it doesn't reproduced any sound. I tried with different headphones but I couldn't solve it. It happened again.

    Besides, I tried restarting the device (also doing a "hard-reset") and nothing, I get the same issue.

    Did anyone have this kind of issue?. How can I fix it ?...I don't know what to do to listening FM Radio again!...

    Thanks in advance!
    Regards from Buenos Aires!
    09-06-18 02:02 PM
  2. Bla1ze's Avatar
    Do the headphones work for music on your device or other audio?
    09-06-18 02:22 PM
  3. Luciano GC's Avatar
    Do the headphones work for music on your device or other audio?
    The headphones (JBL, I bought them two months ago) don't work neither for music or other kind of audio.

    I tried them in other devices (Blu Studio C5 +5 LTE, Motorola Moto E second generation, Asus N53SM notebook) and they work very well on them!.


    What can I do?...
    09-06-18 03:00 PM
  4. Niallac's Avatar
    It's a huge coincidence that your headphone jack socket should get contaminated just as you update your OS... but let's take the least disruptive option first:

    Clean out the headphone jack socket. Use a vacuum cleaner to suck out any dust/lint etc, then use a pipe-cleaner or a cotton bud dipped in isopropyl alcohol or electrical contact cleaner to clean the contacts within the socket. Don't worry too much about doing this, the contacts in the socket are quite robust, it would be hard to do more damage here, unless you were to put something hard into the socket, or introduce more contamination (eg lint from the cotton bud).

    If that fails to resolve the problem, and I'd try some more headphones in it first, then you are going to have to try an autoloader to reload the OS. This will wipe all of your data. Don't restore from backup, at least not until after you have tested the socket again.

    If this fails, you will need to consider replacing the socket (relatively straightforward, but time-consuming), or the phone. Any good mobile repair place should be able to do this, expect to pay £50 or so, though, plus parts.

    If this fails... good luck finding a decent replacement Z30...

    Posted via CB10
    09-07-18 08:09 AM
  5. EFats's Avatar
    I think I have similar problem with my Z10. It only works with really basic headphones. Look for the kind with only 3 segments on the connector. i.e. it cannot have microphone or even mute/pause or other control on it.
    I think it is physical problem with the socket inside.
    09-11-18 06:34 PM
  6. vtecberry's Avatar
    Try cleaning with a close pin sharp point I pulled out lint that was stuck. Also use the bbve program to test the headphone jack


    Posted via CB10
    09-12-18 06:20 PM

Similar Threads

  1. Replies: 65
    Last Post: 10-05-18, 09:26 PM
  2. Blackberry Priv Not Loading media
    By jonpetermatt in forum BlackBerry Priv
    Replies: 2
    Last Post: 09-07-18, 03:30 AM
  3. Replies: 1
    Last Post: 09-06-18, 02:31 PM
  4. BlackBerry launcher
    By Narcissus_N in forum BlackBerry DTEK50
    Replies: 3
    Last Post: 09-06-18, 01:48 PM
  5. BlackBerry Notes «» Cloud / Outlook Sync?
    By RK_BB in forum BlackBerry HUB+ Suite
    Replies: 9
    Last Post: 09-06-18, 09:31 AM
LINK TO POST COPIED TO CLIPBOARD