1. iz_26's Avatar
    I'm having an issue when trying to move files from my device to my media card. I try to move some pictures from my "Photos" folder on the device storage to the "Photos" folder on the media card, but when I try to do so, I get the message: "Files Can't Be Moved. Invalid Argument." I moved pictures and documents from my device's "camera" and "documents" folder to the media card's "camera" and "books" folder (decided to put in books since they're actually books) and that worked fine with no problems. So has anyone else had this issue and received this message? Any suggestions of solutions?

    Thanks in advance

    Posted via CB10
    11-20-14 11:29 PM
  2. Bla1ze's Avatar
    Have you tried a simple reboot? Often times, the system will keep files in memory and think they're in use thus not allowing you to control them. A reboot fixes it. Also happens if there's apps that are using the files you're trying to move. It's a rare thing but its been known to happen.
    11-21-14 12:55 AM
  3. iz_26's Avatar
    Have you tried a simple reboot? Often times, the system will keep files in memory and think they're in use thus not allowing you to control them. A reboot fixes it. Also happens if there's apps that are using the files you're trying to move. It's a rare thing but its been known to happen.
    Yeah I did try rebooting. But perhaps I'll double check and see if any apps may be using those files somehow (maybe an android app running in the background or something).

    Thanks!

    Posted via CB10
    11-21-14 01:31 AM
  4. iz_26's Avatar
    Well that didn't work.. I will say that I'm running OS 10.3.1.1151 and using a 64 gb SanDisk memory card. Just in case that information may help.

    Posted via CB10
    11-21-14 01:35 AM
  5. iz_26's Avatar
    So now I'm getting an issue with trying to take pictures, and I think that issue and this one are related. I have my camera set to save pictures to my media card. I was able to take a few pictures just fine last night, but this morning when I tried, I got the message "The picture couldn't be saved". So I switched the settings to save pictures to the device memory instead, and it allowed me to take one.

    Just some background info... I took this media card out of my Z10 and put it in the Z30. With the Z10 it worked fine with no problems. So I think what I'll need to do is backup the files on the media card and then format it in the Z30. Then take out the memory card, reboot device, and then reinsert the memory card.

    I found that helpful tip on this forum:
    http://forums.crackberry.com/ask-que...folder-957729/

    Just decided to reiterate that suggestion here just in case someone else has a similar issue. I'll be posting the results of this method later to see if it helps.
    Chris Chin likes this.
    11-21-14 09:48 AM
  6. oakvillerelopro's Avatar
    I have similar issues. Looking for a working solution

    Posted via my Z30 Droidberry.
    12-01-14 09:23 PM
  7. iz_26's Avatar
    I have similar issues. Looking for a working solution

    Posted via my Z30 Droidberry.
    I'm glad you posted this because I had forgot to come back and post my results. But I would suggest following the steps in my last post. Back the files up on the media card and then format it on the Z30 itself or connect it to your mac/pc and format as exfat. I initially formatted it in the Z30 directly but was having issues with my mac reading the media card, so I formatted with my mac as exfat and it worked fine. Still working smoothly so far. Hopefully that will work for you as well!

    Posted via CB10
    12-02-14 03:42 PM
  8. Originalloverman's Avatar
    Your media card is probably encrypted decrypted it a d try and see or just reformat it.

    Posted via the CrackBerry App for Android
    12-04-14 02:39 PM
  9. apizkamal's Avatar
    I experienced this once, then my sd card corrupted..I lost all my precious data inside. I tried to copy from sd card to phone memory, but "Invalid Arguments" appear. When I put the sd card to card reader, all the files are there but I can't opened it. After several attempts to copy the contents, it went corrupted. The only solution is to format the card.

    Flying full colours with my ? Z30
    12-04-14 09:28 PM

Similar Threads

  1. BES express setup questions
    By Doug_M in forum BlackBerry Administrators
    Replies: 2
    Last Post: 11-23-14, 11:23 AM
  2. Why can I no longer delete msgs directly from my hub?
    By oimachi in forum BlackBerry Q10
    Replies: 3
    Last Post: 11-21-14, 07:51 AM
  3. Replies: 1
    Last Post: 11-20-14, 10:59 PM
  4. Deleted android files in misc directory
    By tyler_JC in forum Ask a Question
    Replies: 1
    Last Post: 11-20-14, 06:12 PM
  5. BES express setup questions
    By Doug_M in forum BlackBerry Bold 9930/9900
    Replies: 0
    Last Post: 11-20-14, 09:54 AM
LINK TO POST COPIED TO CLIPBOARD