1. Senna127's Avatar
    Picked up my Z30 last Monday. Since I pay for Rogers TechXpert I figured I'd call them to guide me through the setup and transfer of data from my 9810. Everything went well and was transferred over except my contacts. I setup both my personal and business Gmail accounts and can send and receive emails which are automatically synced to my Gmail account. When I log in to Gmail I can see my sent emails from my phone in my sent items folder so I know that works.

    Here's where the problem is, none of my contacts were transferred over even though BB Link menu said they were. I've been on the phone to Rogers with three different TechXperts for 3-4 hours each of the last three nights but none have been able to figure it out. My contacts used to sync instantly between my 9810 and Gmail.

    They've tried transferring them directly, saving them to Outlook and transferring them and syncing them with Gmail but nothing has worked. When I go to contacts on the Z30 the screen opens and it reads "Contacts" Start adding contacts to your... Add Contact"

    Even when I add a contact to the phone and press save, it goes back to the "Add Contact" screen. If I search for the contact names I entered they're nowhere to be found.

    I've spent 10 hours on the phone trying to resolve this. Anyone have any ideas? This is taking way to long and it's becoming a real pain!

    Software Release 10.2.0.415
    OS Version 10.2.0.1767
    Build ID 606567
    11-08-13 12:23 AM
  2. redchilli88's Avatar
    contacts on os 9810 are residents contacts- contacts on your Z10 are active sync contacts- that is why they did not get transferred.
    you need to check your settings. you have contacts on your computer? do you have BBlink installed? 1.2? facebook? twitter? all these must be turned off- where are you contacts currently ? I mean other than on your 9810?
    11-08-13 05:21 AM
  3. Senna127's Avatar
    redchilli88 - All my contacts are located in both Outlook (on my PC) and in my Gmail contacts. The latest BB Link is installed on my computer. I have not setup Facebook and Twitter is not installed.

    Regardless, shouldn't I be able to open contacts on my Z30 and enter them manually? What is preventing them from being saved? I wouldn't think I have to turn on a setting that would allow me to manually add contacts!

    The 3 Rogers TechXperts I've talked to are at a loss. They told me they've helped hundreds of people with Z10 and Z30's transfer contacts, notes, calendars etc. from many different types of BB's but never had a problem like this before.
    11-08-13 10:23 AM
  4. Senna127's Avatar
    After another conversation with Rogers they have no solution to the problem so they told me to return the phone and get a new one. After another 90 minutes in the store where I picked it up they determined it was DOA and will be shipping me a new as no stores have stock. Problem is Rogers is also out of stock so they have no idea when my new one will arrive.

    It makes sense that the phone is defective, why else wouldn't you be able to add contacts. Although annoying, it's not the end of the world and I'll continue to use this one until my new one arrives.
    11-13-13 08:41 AM
  5. Senna127's Avatar
    Anyone else have this problem?
    11-16-13 08:32 PM
  6. mayankbms's Avatar
    I had the issue of contacts not being added manually after importing contacts from 9320. Dud a security wipe and transferred the contacts via blue tooth and could then add contact manually. Though security wipe took more than an hour.

    Posted via CB10
    11-17-13 06:01 AM
  7. Senna127's Avatar
    I had the issue of contacts not being added manually after importing contacts from 9320. Dud a security wipe and transferred the contacts via blue tooth and could then add contact manually. Though security wipe took more than an hour.

    Posted via CB10
    Tried all that with no luck. Rogers is sending me a new Z30.
    11-18-13 08:00 PM
  8. freeyo's Avatar
    If your contacts are in Gmail. Then when you add Gmail in mail,callender,contacts it should sync after a few minutes. But if you put your email account in advanced Gmail the calendar and contacts aren't added. Check to see if it was added in advanced. If so delete and add under email,callender,contacts in z30.

    Posted via CB10
    11-21-13 01:21 AM
  9. Gfunk43's Avatar
    Senna 127 - I just picked up my Z30 2 days ago. I'm having the exact same problem. I had the 9900 and did everything I was supposed to do in Blackberry Link to transfer all my information to the Z30. Everything else looked like they came through except contacts. I've tried syncing them through Blackberry Link again and through my Media Card and still nothing. When I add a contact manually, it did the same thing you mentioned and went back to the Add Contact screen.

    The one thing I noticed is that the text messages that got imported show the contact information the same as how I had it on my 9900, but doesn't show up at all on my contact list. When I'm still in the text message and try to add the contact by clicking on the name then the "new" icon, it completes the phone number field but not the First or Last Name fields. After inputting the name and clicking save it goes back to the text message. I go back to Contacts from the Home Screen and still see "Add Contacts".

    I'm going to talk to Rogers and see if they figured out the problem since you posted this... Have you got your new Z30 yet? Any problems?
    11-23-13 03:19 AM
  10. Senna127's Avatar
    Gfunk43: My new Z30 was delivered this afternoon. I'm going to call Rogers TechXperts and have them talk me through the setup. That way if there's any problem I can say I did everything according to Rogers. I suppose the only difference this time is that I'll be going from a Z30 to Z30 with BB Link for notes and passwords and hopefully contacts will transfer over from Gmail. We'll see tonight.

    If your contacts are in Gmail. Then when you add Gmail in mail,callender,contacts it should sync after a few minutes. But if you put your email account in advanced Gmail the calendar and contacts aren't added. Check to see if it was added in advanced. If so delete and add under email,callender,contacts in z30.

    Posted via CB10
    The last thing to be added to my Z30 was my email addresses. Never did sync my contacts or calender.
    Last edited by Senna127; 11-25-13 at 11:05 PM.
    11-25-13 04:22 PM
  11. sorinv's Avatar
    I have the same problem. It is not just transferring contacts from Z10 to Z 30, but I cannot even add new contacts or modify existing ones carried over from BBM and skype.
    I tried loading them with the simcard, I tried the Contacts app from the BlackBerry store app and saved the contacts as a file and still was unable to load them.
    Turning the phone on and off does not work either.

    I am sure it is a switch in the setting that must be turned on, because at some point, one, day ago, I was able to modify a contact bu I can no longer do it.
    Seems to be a file or directory problem.
    I had a similar issue with the flash player in the browser which was not turned on by default.

    I have no clue how to fix the contacts after two days of trying...

    Everything else works very well and better than Z10.


    Posted via CB10
    11-29-13 10:24 AM
  12. sorinv's Avatar
    This is NOT a hardware problem (except perhaps a simcard problem). It is a software problem.
    I removed Skype and managed to import the old contacts file using the Contacts ImEx app from the BB store. However, that still does not allow me to create new contacts or to modify existing ones. Also, when I try to save them to the simcard on Z30, the contacts are not saved.
    The new OS system upgrade 2.1.429 this afternoon from Rogers did not fix this.

    Clearly, you should not install skype before you load your contacts...but the problem is not fully solved.

    The email accounts are not the cause. I deleted the,m and still have the same problem.

    Returning your Z30 is not going to help. It's not the hardware...
    11-29-13 08:21 PM
  13. Senna127's Avatar
    I received my replacement Z30 which I later found out was a refurb, not a new one. More on that later. Got a Rogers TechXpert on the phone and went through the steps to transfer my information to the new phone. I was able to add and sync email and this time I was able to both manually enter new contacts and sync all my contacts with Gmail.

    Here's where a new problem developed. Not only did all my contact transfer over, I got duplicates from my Facebook account. They had me go to contacts, swipe down from the top, select settings and under "Show account in Contact List" make sure Facebook was set to Off. This setting was switched to On so they had me select Off and we deleted all the contacts and started over.

    What we found was that once the phone was powered down and back on, the Facebook setting switched itself back to On. According to Rogers this is not supposed to happen. (My first phone does not switch this setting back to On after the phone is rebooted). We did a security wipe and started from scratch but kept Facebook defaults to On an I keep getting duplicate contacts.

    I figured I'd delete the duplicates and get on with things. However, the duplicates were identical in every respect so I couldn't tell which one was synced to my Gmail. Delete the wrong one and the contact is gone from my Gmail.

    According to Rogers this should not be happening and the replacement refurb phone I received is also defective. Rogers has instructed me to return this latest phone and they will put in a request to ship me another (brand new Z30) this week.

    I'm a little pissed that I paid almost $200 for a new phone on a two year contract, the first one was deemed defective and was to be replaced after only 1 week of use and they have the nerve to send me a refurb as a replacement?

    So now I'm back to my first Z30 with no contacts until my 3rd. one arrives.

    I'll let you know what happens.
    12-03-13 09:02 AM
  14. trbowser05's Avatar
    Same problem with the Z30 I just bought for my girlfriend. Pretty annoying. But yeah her contacts still show up in texts and emails, just not in the app. So its like they are there, but not. Has anyone called BlackBerry tech support regarding this? I plan on doing that and I'll let ya know what they say.
    12-03-13 12:13 PM
  15. Senna127's Avatar
    Same problem with the Z30 I just bought for my girlfriend. Pretty annoying. But yeah her contacts still show up in texts and emails, just not in the app. So its like they are there, but not. Has anyone called BlackBerry tech support regarding this? I plan on doing that and I'll let ya know what they say.
    Contacts don't show up anywhere on my first Z30. I'd be interested to hear what Blackberry tech support says but for now I'm waiting for my 3rd. phone to arrive.
    12-04-13 09:16 AM
  16. Senna127's Avatar
    3rd. Z30 arrived, brand new replacement this time. I got Rogers TechXperts on the line and we started the process. Installed BB Link update, installed device update 10.2.0.429, added personal, business email accounts, Facebook, downloaded backed up passwords, notes and all my Gmail contacts came over as well.

    I did start getting duplicate contacts but I went to "Show account in Contact List" switched Facebook to "Off" and the duplicates started disappearing so I was left with the same number of contacts in Gmail and on the device. When I rebooted the device, that setting remained off unlike the last one which would switch to on and start duplicating contacts. I was feeling pretty good about this one!

    My 3rd. Z30 appeared to be working perfectly. All that was left to do was a one more reset and we're off to the races. Well, not so fast. When I did the reset, and during the boot process it got stuck in a loop. The word BlackBerry would illuminate then go out followed by the LED flashing red once. It was stuck in this loop. Over the next hour we tried everything but couldn't get it to boot up.

    So, I shipped my 3rd. Z30 back and am now awaiting my 4th. This has to be some kind of a record!
    12-08-13 09:51 AM
  17. scrapmetal58's Avatar
    Good lord. Clearly those Rogers guys don't know what they are doing. They only know the basics really. You're better off reading the forums. Why are you always restarting your phone? Unless it freezes or tells you it needs to restart, you really don't need to restart it. If a problem happens and a normal restart (hold down power button until the options appear)do a hard reset: hold down both volume up and down buttons until the blue loading squircle shows. If it gets stuck in a restart loop, try the hard reset or plug it into BlackBerry Link and reload the software.

    Trust me, it's not just BlackBerry that has these problems. All of my Apple iPhones had hardware issues (not just software).

    For the duplicates, it will Link the contacts if they have the same name. It will take a long time (at least a day). Any that it does not link, you can link manually. You could have turned off the Gmail contacts in the Contacts settings and deleted the Facebook ones, but they are needed to properly use the Facebook app.

    It seems that you are able to back up, and sync your phone so that's good. It seems like it connects to your computer.

    Battery life will suck for the first few days, that's normal. My contacts (551 of them) took about a day to link. If you have more than that, it'll be even longer. You are definitely having problems with the phone, but Rogers is making it much worse than it is.

    I hope everything works out for you!

    Posted via CB10
    12-10-13 04:03 PM
  18. Senna127's Avatar
    Good lord. Clearly those Rogers guys don't know what they are doing. They only know the basics really. You're better off reading the forums.
    Actually, the Rogers TechXperts know a great deal about the Z10/Z30 phones, I was surprised. They also have a huge database with which they can draw from for fixing problems as they keep a record of each customer's problems and solutions. My first phone would not sync with Gmail nor could I enter numbers manually. I am still using this phone but it is defective. Believe me, I read all the forums and tried everything but the contacts problem can't be fixed which is why they sent me a new one. Well actually the second one turned out to be a refurb.

    Why are you always restarting your phone? Unless it freezes or tells you it needs to restart, you really don't need to restart it. If a problem happens and a normal restart (hold down power button until the options appear) do a hard reset: hold down both volume up and down buttons until the blue loading squircle shows. If it gets stuck in a restart loop, try the hard reset or plug it into BlackBerry Link and reload the software.
    The reason they had me turn off the phone after everything was loaded in was to make sure everything still worked properly upon restart. As it turned out, my 3rd. Z30 wouldn't reboot. We tried everything you suggested but the blue loading squircle wouldn't appear. It got stuck in a restart loop, we tried the hard reset many times and plugged it into BlackBerry Link but it wouldn't recognize the device so we couldn't reload the software. We tried everything over and over but nothing worked so back it went.

    Trust me, it's not just BlackBerry that has these problems. All of my Apple iPhones had hardware issues (not just software).

    For the duplicates, it will Link the contacts if they have the same name. It will take a long time (at least a day). Any that it does not link, you can link manually. You could have turned off the Gmail contacts in the Contacts settings and deleted the Facebook ones, but they are needed to properly use the Facebook app.
    My 2nd. phone would allow me to enter contacts but when I synced with Gmail it created duplicates from Facebook. I even turned off Facebook and Gmail in Contact settings but when the phone was restarted it would switch them both back on which it's not supposed to do. (These settings remained off when I rebooted my 2nd. & 3rd. devices which is the way it's supposed to work.) I would end up with 1,200 contacts instead of the 515 Gmail contacts. I know this wasn't right/working properly because my contacts and calender synced perfectly on my 3rd. Z30. In fact everything was working perfectly on this one. It didn't have the issues the first two had and since we hadn't done anything differently on any of the 3 phones it must have been that they were defective. Nothing to do with the TechXperts not knowing what to do. As I mentioned the 3rd. one got stuck in the reboot loop which is why I now have my 4th. Z30 which I will setup in the next two days.

    It seems that you are able to back up, and sync your phone so that's good. It seems like it connects to your computer.
    Well sort of...

    1st. Z30: Wouldn't sync or allow manual entry of contacts
    2nd. Z30: No avoiding duplicate contacts
    3rd. Z30: Worked perfectly before getting stuck in reboot loop
    4th. Z30: We shall see!

    Battery life will suck for the first few days, that's normal. My contacts (551 of them) took about a day to link. If you have more than that, it'll be even longer. You are definitely having problems with the phone, but Rogers is making it much worse than it is.

    I hope everything works out for you!

    Posted via CB10
    Battery life on my 1st. one has been great. Never got a chance to use the 2nd. or 3rd. ones as they were returned the day after I received them.

    My contacts took no time at all to load up on # 2 & # 3. Rogers has been great, the problems have been with the devices. How else can you explain doing the exact same thing on 3 different devices and come up with 3 completely different problems?

    Problems for which nobody on any forum I've seen has had an answer to!
    12-11-13 01:06 AM
  19. Senna127's Avatar
    I received Z30 #4. I called Roger TechXpets last night (or early this morning I should say), backed up Z30 #1 and transferred everything to my new device. Well, I happy to report that this one works perfectly. We didn't do anything differently than we did with the first three but this one does everything it's supposed to.

    So my first three Z30's were simply defective after all.
    12-13-13 10:57 AM
  20. lgcooke's Avatar
    Just out of curiosity, were you able to compare versions of firmware that was loaded onto each of the 4 phones, and if so, were they the same?
    I'm having the exact same problem as your original one: Contacts do not synchronize. My setup is more simplistic as I don't have facebook or other social media accounts (except BBM), and all of my addresses should port over from Outlook. The calendar syncs fine but not the contacts. Here is one interesting wrinkle: I can manually create a contact on the phone, but like yours, doesn't appear in the contact list, which remains blank. Upon trying to synchronize the device however, the manually create contact will appear in Outlook. Back to my original suspicion, this is likely a bug that was somehow fixed in a later release of firmware, thus my question.
    01-22-14 06:28 AM
  21. chairey's Avatar
    I just purchased a Z30 and having same issue. I set up gmail account ...emails and calendar working great ...contacts not so ...but with a twist ...it is all on the Z30 end. When I go to my gmail account the new entry is sync'd with gmail contacts but I can't see it on the my Z30 ...as you said

    "When I go to contacts on the Z30 the screen opens and it reads "Contacts" Start adding contacts to your contact... when I press Add Contact" ...it goes back to the "Add Contact" screen. If I search for the contact names I entered they're nowhere to be found." And my Contacts app indicates that I have no contacts.

    But as I indicated above, I did find my new entry in my on-line google account contacts ...but it is not on my Z30. So my manual contact entry sync'd with my Google contacts (somehow in the background) but my Z30 Contacts app indicates that I have no contacts.

    Likewise I have BBM contacts under the BBM app icon (that I can see) ...but when I go to the Contacts app and look under BBM contacts it indicates that I do not have any BBM contacts.
    Last edited by chairey; 03-27-14 at 11:44 PM.
    03-27-14 11:08 PM
  22. DoctorNeutron's Avatar
    Interesting tip on Skype. When I activated my Linkedin account, I lost a huge number of Contacts. Don't care for BB Link. Don't do social networking like FB or Twitter. Do use MS Outlook. Do use ContactX app. Ripped out all accounts. Added back 1 Yahoo email account PLUS: did not activate associated Contact or Calendar channels. Industry wide program of dynamic syncing of Contacts and Calendar items = FAIL.
    03-28-14 08:05 AM
  23. chairey's Avatar
    Consulted Roger's tech support, they suggested doing a factory restore with BB Link, after backing up first ...I had nothing to back-up as Z30 was brand new, so I proceeded directly to factory restore.
    Voila!! Problem solved ...contacts, everything working as they are suppose to.
    03-30-14 11:19 AM

Similar Threads

  1. How to Send a saved PDF document to my Q10
    By VancouverPrince in forum BlackBerry Q10
    Replies: 3
    Last Post: 11-10-13, 10:00 AM
  2. If the z30 had a 4.9" screen and 300ppi
    By playbookster in forum BlackBerry Z30
    Replies: 28
    Last Post: 11-08-13, 12:31 PM
  3. Here a hard one!!! (Broken screen/transfering contacts)
    By jpar247 in forum BlackBerry Z10
    Replies: 7
    Last Post: 11-08-13, 12:58 AM
  4. Can't Download Apps in Blackberry Z30
    By Amir Khurshid in forum BlackBerry Z30
    Replies: 1
    Last Post: 11-07-13, 11:56 PM
  5. Visual Theme Stuck on Light
    By Berinry in forum BlackBerry Q10
    Replies: 2
    Last Post: 11-07-13, 10:25 PM
LINK TO POST COPIED TO CLIPBOARD