1. dlmilea's Avatar
    Hi,

    I have installed and marked trusted my self-sign SSL cert. Also my intermediary cert.

    My SSL server returns the full certificate chain to the client.

    But still when browsing there is a big red cross in the URL bar and I have to use the accept certificate exception to get the page to load.

    When viewing the site info in the browser it says the top level certificate is not trusted.

    I'm sure all the certificates match so my thought is that when I close the browser from the home screen that the browser might not actually exit and or a phone restart maybe needed to get it to work?

    Am trying to see how reliable my new Z30 is by not rebooting it.

    Can anyone confirm if the procedure I am following should be all that is required?

    Thanks

    Darryl

    Posted via CB10
    12-23-13 06:12 AM
  2. rthonpm's Avatar
    Isn't this just a standard issue with self-signed certificates? I've seen this issue with my domain self signed certs and just chalked it up to them not coming from a root signing authority. Overall, since you've pushed the certs to your device, they should just work.

    Is it possible that the certs have expired?
    12-23-13 08:23 AM
  3. dlmilea's Avatar
    Thanks for you reply.

    No the certs expire in 2022 (10 year validity), the server website setup has been in use for over 18 months and tested across multiple platforms (desktop windows & Linux, also other handsets, Nokia e6-00, n900).

    In bb10 browser site info it has full 3 cert trust chain and top one it knows is a root certificate.

    The only thing wrong is the discrepancy between them all shown as not trusted inside browser compared to clearly having the trusted flag set on the root certificate in the security/certificate settings. The trusted flag is only available on the root cert not my intermediate or subordinate (leaf) certificate.

    Posted via CB10
    12-23-13 02:09 PM

Similar Threads

  1. AD user was "Print Operator" -> No ActiveSync with BES10.
    By TurboArriba in forum BlackBerry Secure UEM & Productivity Suites
    Replies: 5
    Last Post: 01-27-14, 10:05 AM
  2. Anybody still suffering from text issues on Z10 with 10.2?
    By mathking606 in forum General BlackBerry News, Discussion & Rumors
    Replies: 28
    Last Post: 01-14-14, 03:29 PM
  3. Games with OBB files on 10.2.1.1259
    By omar ayman in forum More for your BlackBerry 10 Phone!
    Replies: 31
    Last Post: 12-30-13, 10:59 AM
  4. Q10 Charging Issues with 1259
    By kfehling in forum BlackBerry 10 OS
    Replies: 7
    Last Post: 12-23-13, 04:39 PM
  5. Find the perfect color combination on the go with cooler for BlackBerry 10
    By CrackBerry News in forum CrackBerry.com News Discussion & Contests
    Replies: 0
    Last Post: 12-22-13, 06:50 PM
LINK TO POST COPIED TO CLIPBOARD