09-20-17 03:37 AM
26 12
tools
  1. Biggy41's Avatar
    Hi there

    Got myself a brand new blackberry z30(STA100-2) last week, once I got it out of the box I had to update it to the latest OS. So I go through with the update and after some time I notice an annoying lag. The phone runs ok, but I expected my device to be smooth. The lag is everywhere, in the menu; in the browser; in the hub...native apps etc. I did a wipe and nothing changed, don`t know what else to do.
    What can cause this problem?
    Is it the phone?
    Is it the latest os (10.3.2.2427)?- I didn't try the OS witch the phone came with, so I can`t say if that OS was running ok or not.
    Has anyone else had this problem?

    I don`t have other problems, everything works good, just this lag that is present everywhere and it`s really annoying me.
    Please help me
    09-18-15 12:54 PM
  2. paulwallace1234's Avatar
    10.3 does that, usually sorted after a reboot for a few days

    Posted via CB10 v....not telling
    anon(8908445) likes this.
    09-18-15 12:56 PM
  3. Biggy41's Avatar
    it`s been 8 day now, how long should I wait? I want to know if I can fix this. I have a friend with a z10 and his phone is running smooth with the latest os.
    09-18-15 01:11 PM
  4. paulwallace1234's Avatar
    Maybe you should run a Autoloader, and start it from scratch

    Posted via CB10 v....not telling
    09-18-15 01:25 PM
  5. dreamz_gaurav's Avatar
    2427 is known to be a very smoothly running OS, at least for my Z30. The lag shouldn't be there.

    Z30 / STA100-2 /10.3.2.2639
    bh7171 likes this.
    09-18-15 01:26 PM
  6. Technarch's Avatar
    Try a hard reboot by holding volume up and down. It will take a screenshot then reboot. See how it is after.
    If still doing it pop into device manager and look at cpu and see if you have any runaway processes.

    Posted via CB10
    09-18-15 01:41 PM
  7. ronpfid's Avatar
    I have no lag on my z30 with 10.3.2
    09-18-15 01:42 PM
  8. Biggy41's Avatar
    Thanks guys for the answers, I will try the hard reebot.
    09-18-15 01:46 PM
  9. Tessoro Desoto's Avatar
    Try a downgrade using autoloaders. Im on 10.3.2.440 and it is fairly smooth. I didnt want to upgrade any further to avoid lag.
    09-19-15 07:24 PM
  10. Biggy41's Avatar
    The hard reset didn't work, runs the same. I will try tot downgrade but I can`t find a good link to download 10.3.2.440. Do you have one?
    09-20-15 05:38 AM
  11. lukatrifunovict's Avatar
    I have same issues! I like Z30, but the recent updates ruin the device more and more. When scrolling through apps, I can notice lag on something that is very simple to render! And when I exit Hub and go back to the apps, I can notice lag there too! Browser has its issues too. When changing tabs, very laggy animation van be seen, also after watching videos on Browser, the whole website slows down, and scrolling is very laggy and annoying.

    I still have faith in BlackBerry, I'm pretty they can fix this in future updates, but I really wonder how and why they couldn't notice lag, are they testing only on the newest devices, like Passport? Also, I find it sad that we can't downgrade from 10.3.2 to lower. If I worked for BlackBerry, I would suggest that if we enter BlackBerry ID, we should be able to downgrade, but because of anti theft feature, it doesn't allow to downgrade.

    Black, BlackBerry Z30/ 10.3.2.2639
    09-20-15 05:47 AM
  12. baspeed's Avatar
    I have no lag on my z30 with 10.3.2
    Yes you do you just don't know it. Can't have a major update on a two-year old phone and have it run faster. If you have no lag compared to 10.2 them you need to call BlackBerry tell them so they can share your secrets with us.

    Posted via CB10
    09-20-15 06:54 AM
  13. tryfe's Avatar
    I get typing lag on Z30STA100-5/10.3.2.2639 at times.
    kbz1960 likes this.
    09-20-15 06:55 AM
  14. wojt7's Avatar
    The hard reset didn't work, runs the same. I will try tot downgrade but I can`t find a good link to download 10.3.2.440. Do you have one?
    Don't downgrade. It's pointless. You probbly can't downgrade that low anyway. Just run autoloader with the latest software release. Your lag will be gone.
    09-20-15 09:04 AM
  15. baspeed's Avatar
    Don't downgrade. It's pointless. You probbly can't downgrade that low anyway. Just run autoloader with the latest software release. Your lag will be gone.
    Still gonna be lag compared to 10.2.1 my friend.

    Posted via CB10
    09-20-15 09:47 AM
  16. mksingh's Avatar
    Lags are prominent when you open the apps and especially when you type the contact, it take time for the contacts to appear. This is evident after update.

    Posted via CB10
    09-20-15 10:02 AM
  17. bh7171's Avatar
    Not sure where this "lag" issue/comments are coming from. The latest 10.3.2 update runs much better on the Z30. I wonder how those experiencing this issue updated. Was it Link or OTA? Was it the official release? Both my Z30 and Passport are operating exceptional.

    Z30 wickedness
    halfbaked80 likes this.
    09-20-15 09:17 PM
  18. IanThomas's Avatar
    D/L ota.
    I performed several hard resets (volume buttons) over the first couple of days.
    No lag at all.
    Flickering when the screen turns off reduced but not eliminated.
    Very happy with this update.

    Sent from my Z30
    09-20-15 10:56 PM
  19. Biggy41's Avatar
    So out of the box I updated my phone with the official update that the phone asks you to do, no autoloaders or stuff like that. My phone came with the old Os (the one with the boxes around the icons in the menu), also I had to update because I couldn't download any apps from BB world without updating. I believe that your phone runs great and I wish mine was running smooth as well, but what can I do?
    So I am going to send the phone back and hope that they can fix it, if not I will ask for another z30 or for my money back. I don`t want to keep the phone in this condition, I love it don`t get me wrong but it`s frustrating if it runs like this.

    Thanks again for all the guys that answered my post, appreciate it
    09-21-15 11:51 AM
  20. Biggy41's Avatar
    Forgot to mention that I only have a few apps, only native ones from bb world like skype, viber, whatsapp, facebook, evernote etc.(no android apps) Also I only have 2 email accounts set up and no pictures or music on the phone. Had an old z10 (same os) and it ran much better than the z30.
    09-21-15 12:00 PM
  21. Technarch's Avatar
    Make or download an autoloader. 10.3.2.2639 is the newest version. The carrier may have pushed something older. It will clean format your device and you will set up as new.


    Posted via CB10
    09-21-15 04:25 PM
  22. bh7171's Avatar
    Forgot to mention that I only have a few apps, only native ones from bb world like skype, viber, whatsapp, facebook, evernote etc.(no android apps) Also I only have 2 email accounts set up and no pictures or music on the phone. Had an old z10 (same os) and it ran much better than the z30.
    Something is unfortunately wrong with the device you received. I have 5 work emails, get over 400 emails daily, FaceBook, Twitter and LinkedIn, a few Android apps, and am a heavy user with my Z30 in running my business. (I also have a Z10) I can assure you that a properly operating Z30 does not have lag on the latest build and is faster than the Z10. I really hope you can either wipe and load a fresh install or get a new device because to this day the Z30 is STILL one hell of an all touch device! Best wishes in getting things fixed.

    The White Knight-BlackBerry Passport
    halfbaked80 likes this.
    09-22-15 09:55 AM
  23. Biggy41's Avatar
    Thanks for the message bh, yeah I know I love the z30 and I know it should run smooth, I will send it back to the store. I have 30 days to return it and get my money back. Gonna buy another z30 from another store
    09-22-15 04:10 PM
  24. wojt7's Avatar
    Hey. If for some reason you won't be able to return it let me know. I'll be interested in buying this unused phone from you. In 10 minutes of my time I would have perfectly running fresh from factory-like phone.
    09-22-15 05:36 PM
  25. kbz1960's Avatar
    How much is this lag? 1 second? 10 seconds? If it isn't that long I think it's normal, nothing is instant on mine.
    09-22-15 05:56 PM
26 12

Similar Threads

  1. What's wrong with this country?
    By muindor in forum Rehab & Off-Topic Lounge
    Replies: 78
    Last Post: 11-26-15, 06:54 AM
  2. Need help with DIY Passport Screen Repair
    By SmileDahling in forum BlackBerry Passport
    Replies: 14
    Last Post: 11-02-15, 09:17 PM
  3. You can't erase voicemail notifications from BlackBerry Hub
    By ManuelRodriguez in forum BlackBerry Q10
    Replies: 8
    Last Post: 09-25-15, 10:02 AM
  4. BlackBerry App Roundup for September 18, 2015
    By CrackBerry News in forum CrackBerry.com News Discussion & Contests
    Replies: 1
    Last Post: 09-18-15, 10:09 PM
  5. BlackBerry's Android powered Venice caught in hands-on video
    By CrackBerry News in forum CrackBerry.com News Discussion & Contests
    Replies: 1
    Last Post: 09-18-15, 10:09 PM
LINK TO POST COPIED TO CLIPBOARD