1. Bethany Moore's Avatar
    So frustrating I've tried everything. I finally got link to install on my computer. I'm running Blackberry Link 1.2.2.13 and my Z30 is Running 10.2.0.1803.

    HELP!
    12-10-13 12:11 PM
  2. just_luc's Avatar
    Have you tried a different USB cable? and a different port?
    12-10-13 12:31 PM
  3. derekmadge's Avatar
    You don't give many details and I'm running a Z10, but here are my suggestions:

    If there is no communication, try rebooting computer and Blackberry. If using a USB cable (assuming it is good) try a different USB port on the computer.

    It isn't always obvious but you may have to sign into your BB link.
    Good luck!
    12-10-13 12:34 PM
  4. LP_Rigg's Avatar
    You may want to go into device manager (assuming you are on a pc) and uninstall the device drivers for: Blackberry Device under network adapters and also Blacberry device under rimusbbb.

    Then unplug you device from the computer, re-attach to the computer and it will reinstall the appropriate drivers. I have had to do this fix a couple times when upgrading link.
    12-10-13 12:38 PM
  5. fragment137's Avatar
    What version of OS is on your computer? i've had nothing but problems with Link and Windows 8 Pro.

    On my work computer (Windows 7 Enterprise) I have 0 issues. works great.
    12-10-13 12:45 PM
  6. just_luc's Avatar
    Conversely I had no problems with link when I was on 8 Pro and now have no issues on 8.1 Pro..

    Posted via CB10
    12-10-13 12:51 PM
  7. fragment137's Avatar
    Conversely I had no problems with link when I was on 8 Pro and now have no issues on 8.1 Pro..

    Posted via CB10
    That is very interesting. I tried multiple USB ports on my motherboard and confirmed almost no activity between Link and my phone... I wonder... did you happen to do a seamless upgrade from Windows 7 to 8 or did you do a fresh install / buy a machine with 8 pre-installed?
    12-10-13 02:08 PM
  8. kacy10's Avatar
    If your computer doesn't automatically detect your BlackBerry device, try the following:
    Check the USB cable and points of connection.
    Tap Settings > Storage and Access. Depending on the operating system on your computer, change USB Connections to Connect to Windows or Connect to Mac.
    Consider updating or installing device drivers on your computer. The drivers you need are automatically installed when you download BlackBerry Link. To download BlackBerry Link, on your computer, visit www.blackberry.com/BlackBerryLink and select the Windows or Mac option.

    Posted via CB10
    12-10-13 02:12 PM
  9. just_luc's Avatar
    My desktop was a fresh install of windows 8, but did not come with. My laptop was an upgrade from windows 7 to windows 8 and now to 8.1. Both are fine.

    Posted via CB10
    12-10-13 02:33 PM
  10. mapsonburt's Avatar
    I'd been having similar intermittent problems and finally figured out it was an AT&T client we use to VPN in to work... when that wasn't running, Link would work just fine but when that started up, it changed my IP addresses so Link no longer thought it was on the same network. Make sure nothing else is running and your USB connection (in the device) is set for Windows/Mac as appropriate (automatic sometimes doesn't work). Good luck1
    12-10-13 05:06 PM

Similar Threads

  1. Can't Download Movies Directly to Media Card?
    By Lawmen23 in forum BlackBerry 10 OS
    Replies: 16
    Last Post: 12-10-13, 05:59 PM
  2. Blackberry Z30 feels more exclusive the iphone 5S
    By whatsever in forum BlackBerry Z30
    Replies: 8
    Last Post: 12-10-13, 02:58 PM
  3. Blackberry Z30 user added.
    By whatsever in forum BlackBerry Z30
    Replies: 2
    Last Post: 12-10-13, 02:06 PM
  4. Can I get a Non Authorized Software Update for my 9320?
    By Tashveer Romeo in forum BlackBerry Curve Series
    Replies: 1
    Last Post: 12-10-13, 12:14 PM
  5. Verizon upgrades me from Z10 to Z30 no charge!
    By BKillar in forum BlackBerry Z10
    Replies: 2
    Last Post: 12-10-13, 11:46 AM
LINK TO POST COPIED TO CLIPBOARD