1. keith1000's Avatar
    Hi all. As of lately I've been experiencing abnormal battery drain. It's been averaging around 8 hours or less with moderate use. Also freezing a lot. Come to think about it, it kind of started around the time I blitzed the latest leak. Anyway back to the topic, I've had some heavy system drain before but lately it's high standby drain. Is this common?
    Keith
    Battery drain-img_20151216_122206.png

    Posted via CB10
    12-16-15 11:31 AM
  2. Carl Estes's Avatar
    I think you answered your own question.
    Some are targeted to various model variations...
    Leaks are notorious for many issues...
    Stick with official releases, and your issue will go away....
    12-16-15 11:45 AM
  3. Rustybronco's Avatar
    Almost everytime I've ran into excessive battery drain on my Z10, it's been caused by an errant program and almost always it was an Android app that caused it. Did you happen to add any apps around the same time you updated your OS? I would look at those first.
    12-16-15 11:52 AM
  4. keith1000's Avatar
    Almost everytime I've ran into excessive battery drain on my Z10, it's been caused by an errant program and almost always it was an Android app that caused it. Did you happen to add any apps around the same time you updated your OS? I would look at those first.
    Actually I have downloaded a couple "ANDROID " app. The background app that was reviewed a week or so ago, and a Timesheet (hour tracking) app. And Amazon spotify .
    Keith

    Posted via CB10
    12-16-15 04:23 PM
  5. FF22's Avatar
    I presume you have rebooted? Mine has had a long running battery drain from SYSTEM. I've done about 3 or 4 updates and it remains a battery consumer. I also have tended to use Blitz rather than a complete Autoloader experience. I might go that route.

    Try a restart:

    Press and HOLD both Vol Up/Down buttons. Keep holding while the screen goes fully black (ignore the screenshot), keep holding through the Black/White logo and when the Colored Logo shows up, release those buttons.

    If you have a Z10: If you have the STL100-1 variant the volume button reset method doesn't work. In that case, Press and HOLD the Power On Button until you see the LOGO as above
    12-16-15 05:10 PM

Similar Threads

  1. Replies: 52
    Last Post: 01-05-16, 10:41 AM
  2. Replies: 4
    Last Post: 12-19-15, 05:34 PM
  3. Bigger better battery what's your solution?
    By ChicaneBT in forum BlackBerry Z10
    Replies: 6
    Last Post: 12-19-15, 05:12 PM
  4. Battery tips
    By ALLYSON1989 in forum BlackBerry Priv
    Replies: 0
    Last Post: 12-15-15, 09:47 PM
  5. good battery life...finally
    By randomroyalty in forum BlackBerry Priv
    Replies: 1
    Last Post: 12-15-15, 09:11 PM
LINK TO POST COPIED TO CLIPBOARD