1. byex's Avatar
    Just wondering if anyone else is noticing their z30 getting laggy and unresponsive at times.

    I've had the z30 now for 2 weeks and the first week it was smooth and fast. Coming out of the second week I'm noticing it's lagging at times and unresponsive. Reminds me of my playbook. Apps make that slight hesitation before opening, switching from hub to home screen hesitates, keyboard hesitates. I'm not running any leaks just the latest official OS.

    I did load more apps in the second week of having the phone but 90% of the time I don't use them. I figure the increase in apps is slowing it down. I noticed on playbook with android ported apps, it slowed the playbook down. I may have downloaded a couple ported apps for z30, wondering if that's the issue.

    It's time to make a call to my corporate rep and get another z30.
    12-10-13 08:33 AM
  2. igotberryfever's Avatar
    Not at all. Fast as hell.

    Posted via CB10
    12-10-13 08:54 AM
  3. LWKING's Avatar
    Interesting...

    I expected you to have lag with messages. That can be fixed by deleting threads every once and awhile since your phone stores every message.

    This is news to me though

    Posted with my Q10!
    12-10-13 08:56 AM
  4. GiantSchnauzer's Avatar
    Running the latest leak I find that apps take longer to load, buts that's something I can deal with due to the other benefits.

    Z30, and yes, it's a bit on the heavy side..., but the Carbonate case is Killer!
    12-10-13 08:56 AM
  5. saint613's Avatar
    Just wondering if anyone else is noticing their z30 getting laggy and unresponsive at times.

    I've had the z30 now for 2 weeks and the first week it was smooth and fast. Coming out of the second week I'm noticing it's lagging at times and unresponsive. Reminds me of my playbook. Apps make that slight hesitation before opening, switching from hub to home screen hesitates, keyboard hesitates. I'm not running any leaks just the latest official OS.

    I did load more apps in the second week of having the phone but 90% of the time I don't use them. I figure the increase in apps is slowing it down. I noticed on playbook with android ported apps, it slowed the playbook down. I may have downloaded a couple ported apps for z30, wondering if that's the issue.

    It's time to make a call to my corporate rep and get another z30.
    I found this issue after installing multiple apps and no reboot. Before everyone jumps on me I know that a reboot should not be required, but it doesn't hurt and in my situation it cleared up the issue. It's just a carry over from my computer habits.

    Posted via CB10
    TrueKulcha likes this.
    12-10-13 09:07 AM
  6. anon(6038817)'s Avatar
    Nearly 2 weeks in and no noticeable lag for me. I have done a reboot within the last week, though.

    Posted via CB10
    12-10-13 09:10 AM
  7. xhead75's Avatar
    Nope fast as usual with 10.2.0.1803. Try finding the culprit with the device monitor: Settings>>App Manager>>Device Monitor.

    Here's what I have going on with only CB10 running actively:

    Anyone notice their Z30 lagging-img_00000079.png

    Z30 FTW - Posted via CB10
    12-10-13 09:12 AM
  8. wincyUt's Avatar
    Nope. My Z30 is still running smoothly as silk. And I have had mine since October 15.

    Simply enjoying my Z30 - - - - Channel # C000E218D
    12-10-13 09:17 AM
  9. Berry-cracked-up's Avatar
    I've had my Z30 for some time now, and I have not experienced anything like you described. It's been very very smooth, fast and flawless so far. I'm very very happy with it. I'm running the latest official OS (10.2.0.429) and I have 4 pages of apps, including Android apps, as well as sideloaded apps. I have noticed that some android apps continue to have services running in the background, even though they have been closed. The only issue I've had with that is the battery draining quicker then normal. I do have the TaskManager app, which allows me to see what is running, and I can kill the process if it is something that shouldn't be. You may want to download that free app and see if you have anything running that may be causing the issues you are seeing.
    12-10-13 09:26 AM
  10. byex's Avatar
    Well I did a reboot. Never rebooted the device in over a week and voila, it's running smoother.

    No hesitation and no lag
    saint613 and anon(6038817) like this.
    12-10-13 10:29 AM
  11. byex's Avatar
    And that task manager app is pretty good. Shows apps running that do not show up in native app monitor. They're mostly ported android apps. Killed them all and freed up almost 200 mb of memory.
    xhead75 likes this.
    12-10-13 12:25 PM
  12. blackburberry's Avatar
    Just wondering if anyone else is noticing their z30 getting laggy and unresponsive at times.
    Ah, I was about to post the question as well. I was in a carrier store yesterday contemplating the purchase but the rep couldn't get the demo phone to respond to much. It was a live phone, not in demo mode - and swiping, killing apps etc..just did not want to work without a fight. We both tried the phone many times. We did restart the phone twice.

    Honestly if I were an average interested customer I would not have purchased the phone.

    As it happens I am a CB member so I thought to come here to investigate this issue, then make the purchase.
    12-10-13 12:31 PM
  13. bblove4eva's Avatar
    Mine did freeze a couple of times. Im running the official OS and havent sideloaded any apps

    Posted via CB10
    12-10-13 03:18 PM

Similar Threads

  1. Request a native BlackBerry SnapChat in their Website
    By mossa210 in forum BlackBerry 10 Apps
    Replies: 11
    Last Post: 12-24-13, 10:20 AM
  2. Where is my Z30???
    By Taede in forum BlackBerry Z30
    Replies: 13
    Last Post: 12-12-13, 05:58 AM
  3. **Z30 Saving Message(s)/
    By 512high in forum BlackBerry Z30
    Replies: 9
    Last Post: 12-11-13, 08:51 AM
  4. Why Viber drop their app for bb10?
    By perking in forum More for your BlackBerry 10 Phone!
    Replies: 1
    Last Post: 12-10-13, 04:57 AM
  5. Whats the largest microsd card I could put in the z30
    By tommynap01 in forum BlackBerry Z30
    Replies: 5
    Last Post: 12-10-13, 01:46 AM
LINK TO POST COPIED TO CLIPBOARD