1. kthhrrsn's Avatar
    Are there any US Z30 owners out there? If so, would you mind answering a few questions? I'm in the market & would appreciate some feedback:

    - Where did you buy it (and for how much)?
    - Which carrier are you using it on (I use AT&T)?
    - What version is it (i.e. STA 100-1)?
    - How is it working for you? Are you able to get LTE signals most of the time?

    Thanks a million!
    11-01-13 06:20 PM
  2. lawguyman's Avatar
    STA100-5 is the one you want for AT&T and T-Mobile in the U.S.
    kthhrrsn likes this.
    11-01-13 07:00 PM
  3. cjsabo's Avatar
    Do you know where to find Z30 100-5 I have Z10 100-3 unlocked on AT&T can't find 100-3 or 100-5

    Posted via CB10
    11-01-13 07:04 PM
  4. Aguilucho's Avatar
    Cjsabo. You can order it from GSMNATION for $599.99.

    Posted via CB10
    kthhrrsn likes this.
    11-01-13 10:34 PM
  5. jupiter8's Avatar
    STA100-5 is the one you want for AT&T and T-Mobile in the U.S.
    Be careful. The -5 is without question the one for T-Mobile, but I'm hearing people say the -5 does not get LTE on AT&T.
    kthhrrsn likes this.
    11-01-13 10:43 PM
  6. kthhrrsn's Avatar
    STA100-5 is the one you want for AT&T and T-Mobile in the U.S.
    Thanks lawguyman! I'll look into that one.

    Keith H. Posted using CB10.
    11-01-13 10:53 PM
  7. kthhrrsn's Avatar
    Be careful. The -5 is without question the one for T-Mobile, but I'm hearing people say the -5 does not get LTE on AT&T.
    Okay, thanks! I'll continue to do research. I appreciate the warning.


    Keith H. Posted using CB10.
    11-01-13 10:54 PM
  8. jupiter8's Avatar
    Okay, thanks! I'll continue to do research. I appreciate the warning.


    Keith H. Posted using CB10.
    Check raino's thread on network compatibility: http://forums.crackberry.com/blackbe...encies-850736/
    11-01-13 11:12 PM
  9. missing_K-W's Avatar
    Amazon is selling an unlocked z30 in the us now

    Posted via CB10
    kthhrrsn likes this.
    11-02-13 05:09 AM
  10. lawguyman's Avatar
    Be careful. The -5 is without question the one for T-Mobile, but I'm hearing people say the -5 does not get LTE on AT&T.
    You may be right.

    I just did a Manual Network Scan from my Z30 and all I see for AT&T is 4G and GSM, not LTE. AT&T coverage in my area is spotty so I'll try again at different places to see if I can see any AT&T LTE networks.
    11-03-13 06:21 AM
  11. igotberryfever's Avatar
    I have 100-2 I don't get LTE but I get 4g and its super fast. I live in PA on AT&T

    Posted via CB10
    11-03-13 07:07 AM
  12. jrohland's Avatar
    I have the STA100-5 on AT&T. I can confirm in and around the Washington, DC area I do NOT get LTE. I ran speedtest.net and have found the 4G speeds are comparable to my Z10 on LTE. In real world use, I don't notice any difference in wireless data usage. On balance, I feel the Z30 is so much better for me that I'm willing to forgo LTE until the proper model is available.
    11-03-13 07:33 AM
  13. dcwbearsaint's Avatar
    You will need -1 to work on ATT LTE. The problem is finding one.

    Posted via CB10
    11-03-13 10:08 AM
  14. igotberryfever's Avatar
    I was told a 3. But I am thinking that you are right it's the 1 model. Sucks they can't just have a gsm model with all the radio files

    Posted via CB10
    11-03-13 10:16 AM
  15. anon5897078's Avatar
    You are right, its very confusing which model you need
    11-03-13 10:55 AM
  16. Miketrader1710's Avatar
    I used to have AT&T before and everything worked fine with Z10 STL100-3. I moved to AIO and it works great too, I have LTE on both carriers. I called AIO to know what bands they have for LTE, they told me 850 and 1900. AIO and AT&T use the same signal I guess.
    11-03-13 01:02 PM
  17. Miketrader1710's Avatar
    I called today, in order to get LTE from AT&T and AIO we need a model supporting LTE 700
    11-03-13 02:55 PM
  18. nismorg's Avatar
    so if its LTE 700, that means its a STL100-3 . Isn't that the same model as the Rogers?
    11-03-13 10:44 PM
  19. bighap's Avatar
    - Where did you buy it (and for how much)? Can't tell you
    - Which carrier are you using it on (I use AT&T)? Verizon
    - What version is it (i.e. STA 100-1)? STA100-3
    - How is it working for you? Are you able to get LTE signals most of the time? Amazing and all of the time
    kthhrrsn likes this.
    11-04-13 12:44 AM
  20. szlevi's Avatar
    For larger cities (I'm in NYC) the basic issue is the lack of WiFi Calling on BYOD handsets - in-house reception usually suck if you are in older/bigger/thicker buildings and as long as the carrier refuses to carry it there's not much one can do...
    11-04-13 01:25 PM
  21. jupiter8's Avatar
    - Where did you buy it (and for how much)? A fellow forum member shipped it to me.
    - Which carrier are you using it on (I use AT&T)? T-Mobile
    - What version is it (i.e. STA 100-1)? STA100-5 from Telus
    - How is it working for you? Are you able to get LTE signals most of the time? I've used LTE extensively, the phone works perfectly, all bands.


    Any U.S. Z30 owners out there?-screen-131104-204915.png
    11-04-13 11:48 PM
  22. anon5129477's Avatar
    - 5 does not do LTE on ATT. Tmobil yes / att NO
    11-05-13 06:05 AM

Similar Threads

  1. Devils Attorney - Z30 screen issues.
    By sgt_snacks-64 in forum BlackBerry 10 Games
    Replies: 5
    Last Post: 04-03-14, 05:48 AM
  2. Replies: 6
    Last Post: 11-06-13, 03:34 AM
  3. Z30 App Tester Wanted
    By textngo in forum BlackBerry Z30
    Replies: 16
    Last Post: 11-05-13, 01:03 PM
  4. Z30 doesn' t respond, no apps icons open
    By Z30Man in forum BlackBerry Z30
    Replies: 1
    Last Post: 11-04-13, 01:24 AM
  5. Any way to fix Contacts after leak install & restore?
    By sleepngbear in forum BlackBerry 10 OS
    Replies: 3
    Last Post: 11-03-13, 03:26 PM
LINK TO POST COPIED TO CLIPBOARD