1. ezapper2's Avatar
    Does anyone else experience limited connection on Wifi when using the Rogers Hitron Modem?

    It happens so frequent it eventually disables the Wifi profile and very annoying. I've replaced it 3 times with rogers and no luck.

    Notification
    10.2.1 Wifi on Rogers Hitron modem/router-img_20140208_202510.png

    Hitron Modem

    10.2.1 Wifi on Rogers Hitron modem/router-img_20140208_203014.jpg

    Rogers Deals and Discounts C0022C8F2
    02-08-14 07:31 PM
  2. goku_vegeta's Avatar
    These modems are garbage. You've got no idea how many of these returns I've processed. I'd highly recommend you swap out for the Cisco DPC 3825

    Posted via CB10
    ezapper2 likes this.
    02-08-14 07:46 PM
  3. tgillan's Avatar
    it could just be your Internet going out temporarily. I have this every once and a while. Same router, also with Rogers.

    When this happens on my phone it also happens on my PC and Surface.

    Posted via CB10
    02-08-14 08:27 PM
  4. Makaveli@Beta's Avatar
    I have one of these modems and they are known for having poor wifi.

    That is why mine is in bridge mode and I'm using a dlink router.

    As you can see replacing them will fix nothing. Either do as suggested above or get a better router.




    Posted via CB10
    02-08-14 09:14 PM
  5. ezapper2's Avatar
    I've had this problem ever since on 10.2.1.

    I've also tried all kinds of different routers from linksys to dlink to Asus. The one thing I can say is that I've always bought cheap routers.

    Tomorrow I think I will spend 200$ and buy a proper router.

    My good friend suggested this http://www.asus.com/us/Networking/RTAC68U/

    I'll keep you all posted how it goes

    Rogers Deals and Discounts C0022C8F2
    02-09-14 01:16 AM
  6. TrueKulcha's Avatar
    I've always had weak signal problems with these modems from day one. What I did and would strongly suggest is for you to just get a wireless router and piggy back on it. That combination works great for me. The Cisco Linksys E2500 is now fairly cheap and puts out a much stronger signal.


    Posted via CB10
    02-09-14 07:26 AM
  7. Brandon Nikel's Avatar
    I'm a service tech for rogers and yes the wifi is poor. Bridge it as mentioned above and buy a good router. Make sure it is simultaneous dual band. The 5ghz band is much better for streaming as there is very little interference on that band. I also noticed with my z30 the link speed is faster, 150MBps on 5ghz, only 72 on the 2.4 band. Hope this helps

    Posted via CB10
    ezapper2 likes this.
    02-09-14 10:54 AM
  8. Brandon Nikel's Avatar
    I forgot to mention that if you are on an old grandfathered Internet plan there has been issues, just call and ask for an in market plan. Speeds and bandwidth will likely increase too

    Posted via CB10
    TrueKulcha likes this.
    02-09-14 11:00 AM
  9. ezapper2's Avatar
    So I did buy the RT-AC68U as mentioned above.

    It's freaking amazing. They guys at Canada computers told me it was the top of the line home router.

    So far it's fast and very stable.

    Rogers Deals and Discounts C0022C8F2
    02-09-14 09:52 PM
  10. ezapper2's Avatar
    I'm a service tech for rogers and yes the wifi is poor. Bridge it as mentioned above and buy a good router. Make sure it is simultaneous dual band. The 5ghz band is much better for streaming as there is very little interference on that band. I also noticed with my z30 the link speed is faster, 150MBps on 5ghz, only 72 on the 2.4 band. Hope this helps

    Posted via CB10
    Question, I have both enabled but I seem to always connect to the 2.4 as my speeds are only 72. Is there any reason why it doesn't choose the 5Ghz automatically? Should I set the 5 Ghz to a different ssid? Or what if I disable 2.4ghz altogether, is that bad?

    Rogers Deals and Discounts C0022C8F2
    02-09-14 09:56 PM
  11. Brandon Nikel's Avatar
    72mbps is the limit on your phones antenna on 2.4ghz. I would run both 2.4ghz and 5. You have to manually connect to the 5, it may go back to 2.4 if the phone sees it as a stronger connection. If you want 5 only, forget the 2.4 on the phone

    Posted via CB10
    ezapper2 likes this.
    02-10-14 08:24 AM
  12. DOCTOREVIL8's Avatar
    Does anyone else experience limited connection on Wifi when using the Rogers Hitron Modem?

    It happens so frequent it eventually disables the Wifi profile and very annoying. I've replaced it 3 times with rogers and no luck.

    Notification
    Click image for larger version. 

Name:	IMG_20140208_202510.png 
Views:	462 
Size:	51.3 KB 
ID:	246222

    Hitron Modem

    Click image for larger version. 

Name:	IMG_20140208_203014.jpg 
Views:	464 
Size:	69.3 KB 
ID:	246223

    Rogers Deals and Discounts C0022C8F2
    Yup. I got the same thing and get that message from time to time. Not all that often but it does happen. A while back I called Rogers and had them program the modem for BRIDGED mode. This makes it nothing more than a dumb modem with no settings. Then I use my own wireless. That was necessary to get back to some level of respectable Internet service. Was a nightmare for a couple of months until I did that.

    Posted via CB10
    ezapper2 likes this.
    02-10-14 08:28 AM
  13. dhs1000's Avatar
    I am on t-mobile and have the latest OS update. I was notified

    DHS
    02-10-14 08:32 AM
  14. Felipe M's Avatar
    Ditto. I'm doing the same thing (bridge mode to Dlink wireless router) and haven't had any issues at home.
    02-10-14 12:52 PM
  15. Double_J75's Avatar
    I have a different Rogers modem, and had that all the time. I got a ac router and bridged my modem. It still happens but very seldom. My phone automatically connects to 2.4 and not the 5ghz.

    Posted via CB10
    02-10-14 04:52 PM

Similar Threads

  1. FINALLY Getting A Q10 On Monday!
    By nerdydaddyo in forum BlackBerry Q10
    Replies: 55
    Last Post: 02-14-14, 10:38 AM
  2. 10.2.1 fails to download
    By madtad1 in forum BlackBerry 10 OS
    Replies: 2
    Last Post: 02-09-14, 01:26 PM
  3. Whine Error on sign in
    By tottenhamhotspurfan in forum BlackBerry 10 Apps
    Replies: 4
    Last Post: 02-09-14, 01:46 AM
  4. Android app integration to 10.2.1
    By 2Peks1Bird in forum BlackBerry 10 OS
    Replies: 1
    Last Post: 02-08-14, 10:13 PM
LINK TO POST COPIED TO CLIPBOARD