1. Jazzy_starz's Avatar
    HELP ME PLEASE!! I just downloaded and installed 10.2 on my Z10 (vodafone uk) and it started up and was very slow, my music app was deleted and none of my apps would open... I turned it off to start it up again and now it won't do anything. All i have is a black screen and a blinking LED. Battery pulls have no effect and neither does having the charger plugged in :'(
    10-24-13 09:54 AM
  2. Jazzy_starz's Avatar
    Now i think its bricked? The LED isn't even flashing anymore...
    10-24-13 09:55 AM
  3. scrannel's Avatar
    Have you tried removing the battery and then plugging the phone into your PC (still w/o battery)? Do you get any response from BBerry link?

    BTW, many of us believe battery pulls are not good. It's possible you interrupted the OS update by shutting the phone off and maybe worse by yanking the battery.
    10-24-13 10:14 AM
  4. blackswagg's Avatar
    I noticed at first the phone booted up, but if you wait a minute or so after the first boot the phone will finish updating. If you turned it off or started messing around with it during the hub prep...might be oart of the problem.
    10-24-13 10:54 AM
  5. blackswagg's Avatar
    Music and video app took for me a bit 5 minutes to re appear once I first started the phone after the update.
    10-24-13 10:55 AM
  6. Jazzy_starz's Avatar
    I've sent it back to be repaired. I hope it can be fixed... I think I might of caused the problem by being too impatient
    10-28-13 07:47 PM
  7. alukwesa's Avatar
    I have the same problem, my phone cant come on......come on guys help please!!!
    01-30-14 06:16 AM
  8. FF22's Avatar
    I have the same problem, my phone cant come on......come on guys help please!!!
    Okay, what did you do? What happened?

    Try plugging it in to the charger and leave it for a few hours. Try turning on by

    Try a restart:

    Press and HOLD both Vol Up/Down buttons. Keep holding while the screen goes fully black (igNORE THE SCREENSHOT), keep holding through the Black/White logo and when the Colored Logo shows up, release those buttons.

    If you have the STL100-1 variant the volume button reset method doesn't work. In that case, Press and HOLD the Power On Button until you see the LOGO as above

    Try reloading the OS. Either use the BB link software or find an Autoloader for that OS.
    01-30-14 09:57 AM
  9. Sujinko Cosombo's Avatar
    Can anything b done about it?
    07-24-14 06:02 PM
  10. FF22's Avatar
    Can anything b done about it?
    in order for anyone to help, we need to know what version of the phone you have (model stl100-1, 2, 3 or 4) and which OS you have? You can see this info on the phone if you start an email and then type

    myver (Spacebar)

    The phone will change that to the OS and model. Copy that either manually or some other way and post back.

    Also, what have you tried? What were you doing when it stopped work?
    07-24-14 07:53 PM

Similar Threads

  1. Replies: 1
    Last Post: 10-24-13, 01:48 PM
  2. Blackberry Z10 pairing to RAV4 Bluetooth
    By russd27 in forum BlackBerry 10 OS
    Replies: 1
    Last Post: 10-24-13, 01:23 PM
  3. 10.2 Lock screen timeout
    By mr_zed10 in forum BlackBerry 10 OS
    Replies: 4
    Last Post: 10-24-13, 10:21 AM
  4. Official 10.2, orange SOSH, france ?
    By jerome_daquin in forum BlackBerry 10 OS
    Replies: 1
    Last Post: 10-24-13, 09:51 AM
LINK TO POST COPIED TO CLIPBOARD