1. rjshahan's Avatar
    I have tried searching the forums to solve this with no luck.

    My Z10 froze on me while using the browser, the red light came on and stayed on and then the screen went off. i haven't been able to turn it on since then.

    I have tried pulling the battery, plugging it into the PC, charging it, etc...but it does absolutely nothing. The only response I am able to get out of the device is if I plug it into the PC/power source without the battery the red light comes on and stays on for about 20s and then goes off. If the battery is in, it doesn't do this.

    My next try is to try and load an OS onto it with the autoloader to see if I can erase and jumpstart it, but I am not too optimistic as BB Link cannot detect it to restore he factory OS either.

    Any suggestions as to what I can try next?
    11-29-13 05:44 PM
  2. JasonGallagher's Avatar
    This happened to my z10 a couple months ago. Tried everything you mentioned, nothing worked. Sent it back to the carrier (Rogers in Toronto) and got a replacement unit. Will never know what really killed it.

    Good luck

    Posted via CB10
    rjshahan likes this.
    11-29-13 05:52 PM
  3. rjshahan's Avatar
    Mine is a red Z10, I'm not sure who to send it back to. I guess I will try emailing the BBDev team.
    11-29-13 05:54 PM

Similar Threads

  1. Blackberry z10 not booting
    By samdan in forum BlackBerry Z10
    Replies: 27
    Last Post: 06-26-17, 06:42 PM
  2. Volume on 10.2.1 Leak
    By kaze_25 in forum BlackBerry Z10
    Replies: 6
    Last Post: 01-11-14, 01:35 PM
  3. Replies: 61
    Last Post: 12-21-13, 03:34 PM
  4. My Z10 Experience
    By AlfieBriggs in forum BlackBerry Z10
    Replies: 2
    Last Post: 11-30-13, 06:41 AM
  5. Z10 Unlocked on Sale
    By mkelley65 in forum BlackBerry Z10
    Replies: 4
    Last Post: 11-29-13, 04:19 PM
LINK TO POST COPIED TO CLIPBOARD