1. z10wontconnect's Avatar
    I'm not very techie and feel I made a mistake buying this BB Z10 phone. I want to sell it on but is this a failure of design or specific to my home WiFi? If I switch off mobile networks the phone connects WiFi no problem if networks on then says connected to WiFi but no webpage loads.

    Please note I have no microsim here in house so am simply setting it up using WiFi.

    My thinking is if there was a working sim it wouldn't be a problem? But then that seems to indicate that the phone is preferring to connect to data even when on WiFi?

    Anybody tell me what is going on?

    I'd like to sell it on without fear of some non tech person such as myself complaining.

    Thanks for any thoughts
    01-27-19 06:58 AM
  2. z10wontconnect's Avatar
    Further update. It now won't find WiFi at all. I'm at a loss with this phone to be honest.

    I have a feeling it's too bad should have bought an android
    01-27-19 04:02 PM
  3. bb10adopter111's Avatar
    Since you don't have a SIM card, you should leaved "Mobile Networks" turned off.

    I'm not sure what effect leaving Mobile Networks turned on without a SIM should have, but it's certain that you can't access those networks without a SIM, so I would leave it turned off.

    Posted with my trusty Z10
    01-27-19 05:13 PM
  4. bb10adopter111's Avatar
    Further update. It now won't find WiFi at all. I'm at a loss with this phone to be honest.

    I have a feeling it's too bad should have bought an android
    That sounds like a problem with the WiFi antenna, assuming WiFi is turned on.

    Posted with my trusty Z10
    01-27-19 05:14 PM
  5. brookie229's Avatar
    I'm not very techie and feel I made a mistake buying this BB Z10 phone. I want to sell it on but is this a failure of design or specific to my home WiFi? If I switch off mobile networks the phone connects WiFi no problem if networks on then says connected to WiFi but no webpage loads.

    Please note I have no microsim here in house so am simply setting it up using WiFi.

    My thinking is if there was a working sim it wouldn't be a problem? But then that seems to indicate that the phone is preferring to connect to data even when on WiFi?

    Anybody tell me what is going on?

    I'd like to sell it on without fear of some non tech person such as myself complaining.

    Thanks for any thoughts
    Not sure what OS you have on the device but as a last resort I would update it to the latest (and possibly last) OS using an autoloader. If you have an older OS on that Z10, you may find a radio improvement with a newer OS.
    01-27-19 05:30 PM
  6. z10wontconnect's Avatar
    SW Release 10.3.3.2137 I think latest?

    Regarding antennae I think I misinformed, it is finding WiFi networks but intermittent connections. More miss than hit.
    Funny thing I couldn't get connected all day. Then it connected. Then off again then I seen somewhere on here that if you turn off mobile networks it will work.
    I did that and it worked in fact thought it was sorted. But I thought how is that user friendly? I can't try to sell this on eBay or anywhere if the end user needs to switch off networks? So I tried switching mobile networks back on. It still worked???
    Great but...
    Then switched off phone and on again.

    As that is what people do...

    Then stopped working again. Too much work involved getting this thing to operate smoothly.

    It's says connected btw but limited or no connectivity

    FYI I have sent it twice to be tested here and on both times they have sent it back failed. Could not connect to WiFi.

    The guy who sold me reconditioned BBZ10 back in August thinks the tester don't know what they're at but neither do I then cos it's sucking bad at finding WiFi in here too.

    I tested out of box, bought and put away, only December, bought for my kid Christmas gift, and it wouldn't read sim. Got that replaced under limited warranty and this is the device he replaced it with.

    Seller argues it connects and shows pictures to prove it but I want/need a phone that connects in my home not his.

    When he sent this replacement I closed a well known transaction handlers case on original. Now I'm all ends up. Man It's the principle.

    When I buy tech I expect it works ...guys, Is this Z10 doomed?

    I have pictures of further diagnostics n stuff would that help?

    Thanks very much for your replies.
    01-27-19 08:47 PM
  7. brookie229's Avatar
    Yeah this device sounds as if it's hardware is damaged/worn out. It is, after all, more than 5 years old and who knows how it was treated in the past. Time to give up imo.
    01-27-19 10:08 PM
  8. z10wontconnect's Avatar
    agreed, many thanks for the replies all
    01-28-19 07:30 PM

Similar Threads

  1. Replies: 11
    Last Post: 02-17-19, 11:18 PM
  2. Replies: 1
    Last Post: 01-27-19, 02:03 PM
  3. Strange Language On My Q5 Calender
    By Merit Biee in forum BlackBerry 10 Apps
    Replies: 2
    Last Post: 01-27-19, 10:48 AM
  4. Z10 battery problem
    By scott Cunningham6 in forum BlackBerry Z10
    Replies: 3
    Last Post: 01-27-19, 10:13 AM
  5. Call history takes too long to appear
    By michael damian in forum Ask a Question
    Replies: 0
    Last Post: 01-26-19, 11:47 PM
LINK TO POST COPIED TO CLIPBOARD