1. Labba Labbala's Avatar
    Hi
    After tray again and again all possible ways to tweak the 10.3.1 the result are the same. It's really slow and leggy especially the phone dialog never got this sorted always from time of answering a call until getting to option menu take 3 second..

    Hub respond slow
    Search is... I just can't find the words besides, suck!
    And many more...

    Posted via CB10
    03-31-15 11:10 AM
  2. rarsen's Avatar
    Have no problem with mine.
    03-31-15 11:23 AM
  3. conite's Avatar
    Not my experience. All of my Z10s are running better than ever.

    Z30STA100-5/10.3.2.281
    03-31-15 11:27 AM
  4. bczeetouch's Avatar
    10.3.1.2708 works great for me. I would ignore the OP's advice.

    Posted via CB10
    03-31-15 01:41 PM
  5. alpsalps's Avatar
    You gotta wipe it. Try not using font size 8

    Posted via CB10
    03-31-15 01:47 PM
  6. joeldf's Avatar
    All 10.3.1 builds have run fine on my Z10.

    Were there a few issues here and there? Sure.

    But I never got any lagging. Still don't, and I'm on 2708 now.

    Posted via CB10
    03-31-15 02:25 PM
  7. Bishkin's Avatar
    Hi
    After tray again and again all possible ways to tweak the 10.3.1 the result are the same. It's really slow and leggy especially the phone dialog never got this sorted always from time of answering a call until getting to option menu take 3 second..

    Hub respond slow
    Search is... I just can't find the words besides, suck!
    And many more...

    Posted via CB10
    Time for you to nuke, wipe and reinstall everything on your phone.
    03-31-15 02:27 PM
  8. sajko11's Avatar
    It's funny when someone is experiencing issues and instead of asking question why they do, they post an 'advice' to all users. You are in 0.001% users experiencing this problem so no, your advice is invalid...

    Posted via CB10 with my Z10 (Z10STL100-2/10.3.1.2243)
    bungaboy and Thalestr like this.
    03-31-15 03:08 PM
  9. Net_Surfer's Avatar
    I have no complains about the operation at all. It is smooth and fast. My only issue is the Box, Dropbox and OneDrive. They are incredibly slow and only Box is accessible.
    03-31-15 03:11 PM
  10. iamsao's Avatar
    No complaints bout mine

    Posted via CB10
    03-31-15 04:39 PM
  11. ChicaneBT's Avatar
    It is indeed a shabby show. A lot of problems are reported here but 0 solutions offered by BB. People on the forum try to work out solutions but most problems are in the OS update itself and cannot be changed by users. You might wanna try out some of the new leaks or revert back to 10.2. This is how they treat their non business customers, keep this in mind next time you buy a device.
    03-31-15 04:39 PM
  12. bungaboy's Avatar
    It's funny when someone is experiencing issues and instead of asking question why they do, they post an 'advice' to all users. You are in 0.001% users experiencing this problem so no, your advice is invalid...

    Posted via CB10 with my Z10 (Z10STL100-2/10.3.1.2243)
    Sadly, not humorous funny.

    It's too bad these types are allowed to post bunk when, at the end of the day, it's usually pilot error.
    SteelGreek likes this.
    03-31-15 04:46 PM
  13. SteelGreek's Avatar
    Sadly, not humorous funny.

    It's too bad these types are allowed to post bunk when, at the end of the day, it's usually pilot error.
    Install and restore issues are the cause of most problems it seems. I agree.
    03-31-15 04:54 PM
  14. mikesz10's Avatar
    No problem here!

    Posted via CB10
    03-31-15 05:05 PM
  15. gruv4u's Avatar
    My joint is on point! No problems at all! Removed SIM and SD card. Performed security wipe then plugged it up to the PC and started the autoloader. About 20 minutes later I had a new BlackBerry Z10. Shut it off to put the SIM and SD card back in and set up all of my accounts (DID NOT use my back up to restore any information because I had come from 10.2.1).

    Suh-wee-tuh (sweet)!!!

    Z10 STL 100-3 with vitamin 10.3.1.1784
    03-31-15 05:19 PM
  16. Emboarg7's Avatar
    10.3.1 was what saved my z10, when it was on 10.2.1 it was much slower, buggy, and lacked features that I now have in 10.3.1 and I noticed a slight increase to its battery life
    03-31-15 05:27 PM
  17. Thalestr's Avatar
    Runs fine on my Z10. Just because you have issues doesn't mean everyone else is too.

    Posted via Q5
    03-31-15 05:28 PM
  18. Kristijonas's Avatar
    Never had problems... it always keeps amazing me how different same os can end up on different devices

    Putin Huylo. Slava Ukraini, freedom to Ukraine!
    03-31-15 05:34 PM
  19. Bla1ze's Avatar
    This is terrible advice.
    03-31-15 06:02 PM

Similar Threads

  1. Replies: 7
    Last Post: 04-05-15, 01:41 AM
  2. Solution to Call Lag
    By mistercanadaman in forum BlackBerry Z30
    Replies: 9
    Last Post: 04-01-15, 09:42 PM
  3. BlackBerry needs a high-end replacement for the Z10
    By jly.public in forum BlackBerry Z10
    Replies: 16
    Last Post: 04-01-15, 09:00 PM
  4. How do I swap the location of the Word Prediction on my Q10?
    By CatchTwentyTwo in forum BlackBerry Q10
    Replies: 7
    Last Post: 04-01-15, 12:44 AM
  5. Can u get snapchat on blackberry 10
    By richmaz3333 in forum Ask a Question
    Replies: 3
    Last Post: 03-31-15, 08:53 AM
LINK TO POST COPIED TO CLIPBOARD