1. Muzz The Great's Avatar
    Having experienced the the camera issues on my phone (Camera can't open) since upgrading to 10.2, I decided to downgrade my OS to 10.1 to see if it fixed the problem.

    Before downgrading, I tried to load several different camera bars, but nothing seemed to work.

    This morning I loaded 10.1.0.4651 which I found on these forums and happy to note that my camera is working. I think I will leave it on this OS for a while to confirm that the camera does work and then attempt to upgrade to 10.2 again and see if that fixes the problem.

    I will keep you posted if I have any success with this.

    I have seen that my carrier is on 10.2.1.2102 currently and I am in the process of downloading 10.2.1.2674. Does anyone know if this will work fine or should I stick with the original carrier version? (The 2674 is for Z10 STL100-1).

    Thanks and keep you posted if I have any luck!
    04-08-14 04:48 AM
  2. Fajar Anugrah's Avatar
    Same issue. But then i just restarted my phone and it's working again. Magic.

    Z10 STL100-1 running 10.2.1.2120
    04-08-14 04:51 AM
  3. Muzz The Great's Avatar
    Ok so I have been fiddling with everything and updated my OS to 10.2.1.2674. What I have discovered is:
    The camera works on start up, but as soon as you open an android side loaded app, the camera stops working. so restart the phone and the camera works again. So obviously this means that if you have android apps, the camera won't work. Any one have any ideas or can confirm this?
    So now the question is, how do you have the camera working and have sideloaded apps? This was never a problem on OS 10.1, so something new is causing this conflict.
    04-11-14 03:18 AM
  4. FF22's Avatar
    One of the Instragram apps has been implicated but since I don't use Instragram I'm not sure which one it is.
    04-11-14 11:41 AM
  5. naji55's Avatar
    Its possible that ur flashlight app is opened, or an android application that is in use the camera, u can download a task manger from Snap, and check what apps are opened, no problems here using 10.2.1 stl100

    Using BB Z10 10.2.1
    04-11-14 01:12 PM
  6. badiyee's Avatar
    I'm a stl100-1 user and I don't get the same symptoms as you have described. However I did had a torchlight app, and when it was on the camera would refuse to run.

    turning that off allowed the camera to work.

    Posted via CB on BB10
    04-12-14 09:23 AM
  7. ob1tomi's Avatar
    i bought my stl100-1 on amazon.com it came with 10.0.10 release 489 out of the box. camera worked beautifully with every upgrade that i did. when i upgraded to 10.2 the camera cannot open issue crept up. since then i have never been able to use my camera.
    i have downgraded to 10.0.10.648 and did numerous security wipes, numerous restarts and nothing has helped. i have tried many other Os's 10.1.0.1485, 10.2.0.1047, 10.2.0.1791 and no luck.

    im looking for 10.2.0.1521 but keep getting dead links for downloading.

    im out of ideas.........i can see that blackberry is aware of the problem but has not come up with a permanent solution
    KB35371-After updating the device software from version 10.1 to version 10.2.0 on the BlackBerry Z10 smartphone, "Camera cannot be initiated" error message is displayed when opening the Camera app

    HELP HELP HELP
    06-09-14 03:34 AM
  8. ob1tomi's Avatar
    i bought a T4 screwdriver disassembled the phone and found that my camera was not connected properly. i reconnected it reassembled the phone and voila, camera worked like a charm
    02-05-15 01:17 AM

Similar Threads

  1. Why BBM voice and video can't function?
    By prasetyodanny in forum General BBM Chat
    Replies: 6
    Last Post: 05-21-14, 12:34 PM
  2. Z10 sell through number in India after price drop?
    By pranavvk in forum BlackBerry Z10
    Replies: 6
    Last Post: 04-15-14, 02:07 AM
  3. Has anyone noticed that Toshiba is also has Z10 and Z30?
    By zuraizul in forum BlackBerry 10 OS
    Replies: 4
    Last Post: 04-08-14, 11:13 PM
  4. Unlock gesture and Hub peek
    By mexicangangboss in forum BlackBerry 10 OS
    Replies: 8
    Last Post: 04-08-14, 02:38 PM
  5. Replies: 7
    Last Post: 04-08-14, 06:03 AM
LINK TO POST COPIED TO CLIPBOARD