1. greenberry666's Avatar
    Help! My Z10 has no sound. No notifications, no keyboard sounds. Nothing.

    I've been running the 10.2.1.1925 leak successfully for about a few weeks. I have recently updated Sayit and downloaded Clipman and Battery Analyser.

    ST100-2

    Thanks for any help!
    01-08-14 02:12 PM
  2. RedMace's Avatar
    I had the same problem after updating Sayit - I have deleted it for the time being

    Posted using the awesome Z30
    01-08-14 02:14 PM
  3. greenberry666's Avatar
    Ok thanks! I will try it.
    01-08-14 02:27 PM
  4. greenberry666's Avatar
    Yippee. That was it! Got my sound back. Hopefully Sayit will be fixed as I like that app.
    01-08-14 02:39 PM
  5. Bor Navas's Avatar
    I wish I had read this before setting my alarm and going to sleep..

    C000F331C channel
    01-09-14 03:53 AM
  6. irweezyy's Avatar
    After I updated Sayit, my Z30 lost all sounds.

    My theory is that since it is running headless, the phone thinks there is media open, so for example when you have the volume keys set to adjust notification volume, and sayit is running headless, the volume still controls media and not notifications. After a little troubleshooting here is what I found:

    If sayit is running headless, and you press the middle button to activate sayit, then go and play music or a video, there is no sound, but if you press the middle again to I guess close your sayit request, then go play a song or video, your sound is back. So effectively when you are pressing the middle key to use sayit, but forget to close the sayit request, you have no sound because I guess the device is trying to take in your sayit request, however if you close the sayit request by pressing the key a second time, sayit is no longer active so you get your sound back.

    Edit: after playing around more I have confirmed that this is most likely what is happening:

    I have my volume control set to control notification volume.

    Sayit running headless

    If I press the middle button to activate sayit, then try to adjust notification volume, it adjusts media volume not notification volume, and if I play a song or a video there is no sound.

    If I press the middle button again to stop sayit, then try and adjust the volume it now adjusts the notification volume again, and if I play a song or video my sound is back.

    So in essence, when you purposely or accidentally hit the middle button once, it opens a sayit request (for lack of a better term), and this makes the phone think there is media running, so it's like if your playing a song, then play a video, the song stops and video takes priority, or the other way around, so sayit must be taking priority over media, then when you close the sayit request, the media mode or whatever sayit is taking control of stops, and you can continue on with your other media.

    Not sure if I would classify this is a bug or just user error for opening and not closing the sayit request. But maybe there should be a timeout, or something in the top to show sayit is open and accepting a voice request. Maybe make the media "play" icon show up to signify sayit is actively listening? And then that can show a user they need to close the request.

    I'm running 1055 leak. Sorry for the long post, but just wanted to be clear with my findings to help the dev out.

    Edit2: sorry but another finding, if I am playing a song and there is sound, and then press the middle key to make a sayit "request", it cuts off the music sound until I close the sayit request. What I find weird with this though is that it doesn't pause or stop the song, it just cuts out the sound and the song keeps playing with no soynd, and when I close the sayit "request" by pressing the middle button again, the song sound comes back on.

    Posted via CB10

    Posted via CB10
    mirren likes this.
    01-09-14 12:22 PM
  7. greenberry666's Avatar
    Thanks for all your findings! I will try this out later
    01-09-14 12:39 PM
  8. d_abes's Avatar
    Same with sayit, and it happens after connection to my in car blutooth. Battery pull required for recovery, and sayit now deleted.

    Posted via CB10
    01-09-14 03:52 PM
  9. yardmon's Avatar
    Agreed on Sayit being the likely culprit. Updated yesterday. Noticed today when in my car, the bluetooth voice activation will automatically come on, although I haven't pressed any buttons. Also when in the office, no alerts were sounding. Reset my phone and seems ok now.

    I'll make sure not to open Sayit... dev needs to fix this asap.
    01-10-14 12:26 PM
  10. irweezyy's Avatar
    Agreed on Sayit being the likely culprit. Updated yesterday. Noticed today when in my car, the bluetooth voice activation will automatically come on, although I haven't pressed any buttons. Also when in the office, no alerts were sounding. Reset my phone and seems ok now.

    I'll make sure not to open Sayit... dev needs to fix this asap.
    I noticed when using sayit with in car bluetooth it opens up a call screen in my car and I have to use the cars hangup button, then I get access back to media. All in all I believe these issues were probably already present before headless was added, it's just that now since it runs automatically in headless, everyone is being effected that has the app, whereas before the issue would only become apparent when doing your normal activities and the running sayit.

    Posted via CB10
    01-10-14 01:26 PM

Similar Threads

  1. BlackBerry Z10 to Q10
    By AndersoOn1 in forum General BlackBerry News, Discussion & Rumors
    Replies: 11
    Last Post: 01-15-14, 07:58 AM
  2. Z30 - any Z10 converts here?
    By BlackBerry USA in forum BlackBerry Z30
    Replies: 37
    Last Post: 01-12-14, 05:05 PM
  3. Replies: 7
    Last Post: 01-08-14, 11:36 AM
  4. undelete messges on z10
    By navi_dhaliwal in forum General BlackBerry News, Discussion & Rumors
    Replies: 1
    Last Post: 01-07-14, 10:53 PM
  5. BlackBerry launches BlackBerry work drives( Beta 2.0)
    By 40blind40 in forum General BlackBerry News, Discussion & Rumors
    Replies: 2
    Last Post: 01-07-14, 06:07 PM
LINK TO POST COPIED TO CLIPBOARD