1. Chiranjeevi chiru1's Avatar
    I did security wipe and it worked one day fine and showed some error on the screen, and i did factory reset, it started well after that and took latest update as well.

    I started downloading skype app on my beloved z10 then it got stuck, i tried to restart it , there the problem comes. It hasnt moved from blackberry wording logo, i stuck there only for almost hour, i tried all the ways like pulling battery and stuff. sometimes with the charging cable plugged logo is not going off even after battery removed. I started doing factory reset again using BB link, it throwed a software error in the system and started blinking the red LED forever until battery got over i think. Since that time it is not working at all. No led , no sound. Please help

    Its jst four months old and no warranty for it, since i bought it from amazon US.

    Model STL 100-1
    12-17-13 03:58 AM
  2. FF22's Avatar
    Here's some ideas that I have captured (although what finally worked for me was loading the Leak found in the Leak subforum)

    Reload OS Software bricked

    How to reload the OS on a BlackBerry Z10 or BlackBerry Q10 | CrackBerry.com

    How to do a Security Wipe (factory reset) the BlackBerry Z10 | CrackBerry.com

    How to reload the OS on a BlackBerry Z10 or BlackBerry Q10 | CrackBerry.com


    On PC, kill link, blackberry desktop software and then go to task manager and kill any BlackBerry or link processes.

    Take the battery out the phone and disconnect from USB. On the PC, launch the autoloader. Plug in phone via USB to PC. Once the autoloader has connected to your phone slap the battery back in and let it finish.
    12-17-13 08:52 AM

Similar Threads

  1. Charging My Z10 by using Samsung S4 Charger.
    By Henry Ho1 in forum BlackBerry Z10
    Replies: 34
    Last Post: 12-23-13, 02:36 AM
  2. Z10 not working.
    By Chiranjeevi chiru1 in forum BlackBerry 10 OS
    Replies: 16
    Last Post: 12-21-13, 02:54 PM
  3. Replies: 8
    Last Post: 12-19-13, 02:39 PM