1. HanisPF's Avatar
    Hello. I got problem with my z10 stl100-1. I didnt use my phone for 3 days and the battery is completely drained. when i connected it to the charger, the led turns red and shows the blackberry logo and then off and repeat. and this keep on repeating if connected it with charger. any solutions ?
    03-19-14 08:17 PM
  2. cloudberry's Avatar
    Hello. I got problem with my z10 stl100-1. I didnt use my phone for 3 days and the battery is completely drained. when i connected it to the charger, the led turns red and shows the blackberry logo and then off and repeat. and this keep on repeating if connected it with charger. any solutions ?
    have u tried battery pull ?
    03-19-14 08:48 PM
  3. FF22's Avatar
    See if you can turn the power OFF when you start to see the logo and give it a chance to charge. Are you using the original charger that came with the phone? How old - warranty?
    03-19-14 10:25 PM
  4. opta danantya's Avatar
    Mine, sometimes when i used it until it's fully drain, it wont turn the phone on. I have to do battery pull until the phone displaying the charged battery(not the exclamation mark inside battery), then i turn on the phone. It happens after i update from .2141 to .2228.

    I'm on Z10 STL 100-1

    Posted via CB10
    03-19-14 11:28 PM

Similar Threads

  1. Help: Honda Bluetooth Handsfree Link
    By CrackedRosco in forum General BlackBerry Discussion
    Replies: 14
    Last Post: 10-10-14, 12:10 PM
  2. OS update 10.2.1.2012 Help
    By Patrick Pinho in forum BlackBerry 10 OS
    Replies: 6
    Last Post: 03-20-14, 01:36 PM
  3. Spotted a Z10 in the wild
    By officially_juju in forum BlackBerry Z10
    Replies: 7
    Last Post: 03-20-14, 08:17 AM
  4. The squircle lives on in bb10...
    By Karan Mohal in forum General BlackBerry Discussion
    Replies: 13
    Last Post: 03-19-14, 09:05 PM
  5. Z30 LTE not working on my Z30
    By dobiefan in forum BlackBerry Z30
    Replies: 4
    Last Post: 03-19-14, 08:31 PM
LINK TO POST COPIED TO CLIPBOARD