1. Lincoln Liking's Avatar
    My Z10 is not loading past the boot screen. I have tried battery pull, doing a factory reset from blackberry link, tried using a boot loader and it doesn't work. My PC is just not picking up the Z10. It won't turn off only resets. Not sure what else to do.
    07-18-14 10:48 PM
  2. rebroker2009's Avatar
    Not sure if it will work but try a stack charge like what people do to revive a playbook. Search the playbook forums

    Q10 with Telus on 10.3.0.296
    07-18-14 11:14 PM
  3. nelsonningombam's Avatar
    You can download autoloader for 10.2.1 are fix it. However you will lose all your data on your phone. If you have back up your data in the past then you may restore it gain.

    You can also check my Previous post. I have similar issues
    07-18-14 11:15 PM
  4. nelsonningombam's Avatar
    07-18-14 11:18 PM
  5. nelsonningombam's Avatar
    If your pc is not detecting you BlackBerry you can try connecting with different data cable and even try with different computer.

    Posted via CB10
    07-18-14 11:21 PM
  6. Andy Wijaya's Avatar
    Stl 100-1? Maybe the problem is the battery. Do a battery pull, and let them for 10 minutes. The put the battery while plugging the device.
    07-19-14 12:20 AM
  7. Lincoln Liking's Avatar
    Thank you all. I will let you know the results.
    07-19-14 02:17 AM
  8. andi-bsd's Avatar
    Happened to me more than twice. Dont know the problem but pull battery, start device, then do a restart, always work on me. Weird bb. That is why i dont trust z3 or even nonremovable z30. Hope passport do have removable battery or i will skip those gem.

    Posted via CB10
    07-19-14 02:51 AM
  9. Lincoln Liking's Avatar
    Ok, so tried the battery pull and that didn't work. Blackberry Link not detecting the Z10 and the cable is fine, the boot loader gets stuck at BootRom phase. It's not seeing the Z10 at all. I pulled the battery plugged it in and leaving it to see if that works...
    07-19-14 06:53 AM
  10. Andy Wijaya's Avatar
    Now that sounds serious. Take it to the service center maybe? Try pressing the power button for 30 sec while charging? Can you give us the picture of the stuck booting phase? It might give some people who wants to help a better understanding of your situation.

    Posted via CB10
    07-19-14 11:30 AM
  11. nelsonningombam's Avatar
    Have you tried using data cable?

    Posted via CB10
    07-19-14 08:23 PM
  12. Paul Wambura's Avatar
    hi every one i have a problem with my blackberry z10
    i was trying to to restore the setting to the factory settings but it is still loading. on screen
    08-26-14 06:40 AM
  13. FF22's Avatar
    hi every one i have a problem with my blackberry z10
    i was trying to to restore the setting to the factory settings but it is still loading. on screen
    Why were you restoring? Any other problems? Which model and OS were you running? Carrier?

    Is it showing a "shredder" icon or the Blue logo?

    How long has it been like that?

    Welcome to Crackberry and sorry your first post is about a problem.
    08-26-14 08:59 AM

Similar Threads

  1. Replies: 21
    Last Post: 04-12-15, 06:32 PM
  2. Replies: 3
    Last Post: 07-21-14, 11:04 AM
  3. Screen shot on a z30?
    By zakk lott in forum BlackBerry Z30
    Replies: 5
    Last Post: 07-18-14, 11:36 PM
  4. Amazon Music on BB Z10
    By PJDrohan in forum Ask a Question
    Replies: 3
    Last Post: 07-18-14, 10:55 PM
LINK TO POST COPIED TO CLIPBOARD