1. CrackBerry Question's Avatar
    This is an interesting problem that I'm searching over the Internet from last few weeks. And finally posting here for a possible solution.

    I can charge the Z10 from PC USB connection but no other USB connections like USB mass storage and connection to BB Link / Blend is not getting established.

    Installed BB Link and Blend on my system and connected the Z10, but it says no device found. Even on Blackberry device manager (opened from taskbar notification area) doesn't show any device connection but at the same time it's charging from the USB port.

    Few notes:
    1. I can access my files using Wifi share.
    2. OS version is 10.3
    3. No SD Card is installed
    4. I remeber on past, I accessed my Z10 internal storage without any drivers.
    5. I can see a greyed out 'Removable disk' under My computer if I connect Z10 with USB mass storage / choose 'Access internal storage' from connection prompt.
    09-01-15 06:49 AM
  2. paulwallace1234's Avatar
    Just in case, check Settings- Storage and Access- Access Using USB and make sure Charge only mode isn't switched on
  3. paulwallace1234's Avatar
    Just in case, check Settings- Storage and Access- Access Using USB and make sure Charge only mode isn't switched on
    09-01-15 07:17 AM

Similar Threads

  1. Replies: 28
    Last Post: 09-29-15, 07:10 PM
  2. Solution For Phone App Lag in BlackBerry Z10
    By Nikidroid in forum BlackBerry Z10
    Replies: 18
    Last Post: 09-23-15, 12:18 PM
  3. Having sensor issues in my BlackBerry z10
    By zohaibinred in forum Ask a Question
    Replies: 13
    Last Post: 09-04-15, 10:23 AM
  4. Replies: 12
    Last Post: 09-01-15, 09:37 PM
  5. Z10 Xfat Driver
    By Old_Mil in forum BlackBerry Z10
    Replies: 1
    Last Post: 09-01-15, 12:54 AM
LINK TO POST COPIED TO CLIPBOARD