1. immpsmith's Avatar
    Yesterday my z10 keyboard input stopped working and can't figure out why or how to fix. When I type the key press pop up is working and so are key press sounds but nothing shows up where I am typing.

    I can cut and paste words in email or web browsing but can't type. Also the phone digits works ( I can make calls)

    I have done a battery pull and soft resets and turn power and all with no luck.
    Any suggestions? I am lost and have to write this on my wife's ipad (boo!)

    Now what may help answer is Yesterday I went to the states and swapped out my canadian carrier sim with a roam mobility sim. The keyboard was working for a bit but then it stopped possibly after rebooting my phone when the hub was not loading.

    My phone is unlocked and I have swapped out sim before in the last year a few times with no problems.

    Please help!

    12-21-13 08:49 AM
  2. FF22's Avatar
    If you can BACK UP, definitely do that.

    So, you replaced your original sim card? You've done

    Try a restart:

    Press and HOLD both Vol Up/Down buttons. Keep holding while the screen goes fully black, keep holding through the Black/White logo and when the Colored Logo shows up, release those buttons.

    If you have the STL100-1 variant the volume button reset method doesn't work. In that case, Press and HOLD the Power On Button until you see the LOGO as above

    What OS do you have? Official or leaked?

    You might have to reload the OS.

    Let's see if anyone has suggestions. Numbers work and not letters (just mulling that oddity!)?
    12-21-13 10:19 AM
  3. BBUniq01's Avatar
    Happened to me when the Z10 was just released. I had to do a compete restore on BlackBerry Link. Never had the problem since, especially with the better updates. I am on 10.1 stikl.

    BB Uniq BB Bold -Z10
    12-21-13 10:47 AM
  4. immpsmith's Avatar

    I tried this reset already and it didn't work. I have just swapped out my original sim for my travel sim. Tried my original one again and same problem.

    I have an stl 100-3 and running latest bb10.2 as an official release.

    Numbers don't work also - nothing using keyboard works. But phone keypad does,

    I figure I have to just reload software when home. I do have a recent backup I can go to so all is not lost. Just frustrating as I am travelling now and need my phone to work... Hoping for an easier trick and I know that's unlikely.
    12-21-13 11:02 AM
  5. FF22's Avatar
    If you have access to a computer and have dropbox... You can get the Firechest app and backup calendar and contacts and more to Dropbox. And access to a computer you can load the OS using Internet Explorer and would not have to load any programs on someone else's computer.

    Using Internet Explorer, navigate to BlackBerry 10 Software Updates - New Update Software for BlackBerry Smartphones - US, (that url spelled out is //www.blackberry.com/updates) scroll down the page and click the Check for Updates button.
    Connect the BlackBerry 10 smartphone that cannot be booted up.
    Hold the power button for 10 seconds until the BlackBerry smartphone turns off, then press the power button again to power it on. A prompt will appear and the BlackBerry smartphone will show in the drop down list shortly after the LED lights up red (USB: UNKNOWN or USB: BlackBerry (PIN) may also be displayed).
    Click the OK button within 15 seconds to continue.
    12-21-13 11:24 AM
  6. immpsmith's Avatar
    Thanks I'll try that

    Posted via CB10
    12-21-13 12:11 PM
  7. mbranscum's Avatar
    Maybe you spilled coke in between the keys. Lol.
    Seriously though, hard reset or battery pull.

    Posted via CB10
    12-21-13 12:29 PM
  8. immpsmith's Avatar
    Thanks all. Both hard reset or battery pull did not work. Back home now and had to restore my phone to a backup that was a week or so old.

    That worked. I can now type again!

    I think the problem started with difficulty loading hub after I swapped my sim card and having to power off or battery pull the phone a number of times to finally get it to load. In doing so I probably corrupted the os.

    We are all good now. Thanks again for suggestions.

    Posted via CB10
    12-26-13 10:49 AM

Similar Threads

  1. sim card not detected
    By antonio akut in forum BlackBerry Q10
    Replies: 7
    Last Post: 12-29-13, 02:59 AM
  2. Replies: 2
    Last Post: 12-21-13, 10:20 AM