1. dob0's Avatar
    Hello, guys! I hope, I'll find help for solving my problem here.
    Exume me for a long post.

    Yesterday my PC was upgraded (i think it matters, because i can't see any other reason why the situation happened). I connected my Z10 with PC via USB to charge the battery (it was about 35%). In 10 minutes I took the phone - it was turned off and very hot. I removed the battery and put it back then - I saw a white Blackberry logo and then a red sign of empty battery. After that the phone turned off completely.

    Z10 doesn't connect with other PC via BBLink or Desktop manager (with/without battery). When I try to charge it by original adapter, the LED is lighting (it's red or pink, sometimes it's blinking - i think it's 1 and 3 times -and then LED becomes white until it turns off in a few minutes). The phone doesn't work at all.

    I really want to save the files on the phone memory - is there a chance if I plug a new battery into my phone? Maybe, there's something different that I can do?
    Thanks to everyone!
    05-28-19 10:06 AM
  2. Dunt Dunt Dunt's Avatar
    You can try a new battery.....
    05-28-19 11:10 AM
  3. dob0's Avatar
    Ive just tried, but nothing's changed.
    06-01-19 09:20 AM
  4. Craigrich2's Avatar
    I bought one of the"BB LS1 charger + battery bundle" off fleabay for about $20 , charged it's new battery until full (about 2hrs) and put it in my z10 that was "playing possum.." and it came back to life, then put it's 3 year old battery in the charger, after 6 hours it was usable but only lasts about 70% as long as the other - and I realloy thought my old Z10 was dead - IT'S ALIVE !
    06-14-19 03:04 AM
  5. BBfishingaddict's Avatar
    At least with my Z10, when the battery is dead I have to play a game to get it to charge. It won't charge with either a charger or computer directly. I have to take the battery out plug it into my laptop, turn it on and then put the battery in. I then let it charge for a bit before unplugging, put the back cover back on and then plug into the charger. I only use mine for an alarm now so it's few and far between the number of times I have to do this dance
    06-18-19 09:22 AM
  6. m3ach's Avatar
    At least with my Z10, when the battery is dead I have to play a game to get it to charge. It won't charge with either a charger or computer directly. I have to take the battery out plug it into my laptop, turn it on and then put the battery in. I then let it charge for a bit before unplugging, put the back cover back on and then plug into the charger. I only use mine for an alarm now so it's few and far between the number of times I have to do this dance
    Do you let the battery drain completely?

    If you do this is very bad for the battery, you should charge it before it goes below 20%.

    Posted via CB10 using my Classic running 10.3.3.3216
    06-18-19 12:13 PM
  7. TrumpetTiger's Avatar
    Ive just tried, but nothing's changed.
    Hey dob0,

    Did you get this resolved? If not, does the Z10 with both batteries not charge normally when connected by USB to both of your computers? I'm not asking about Link right now--just what happens on the device when you connect it via USB.
    06-19-19 04:17 AM
  8. BBfishingaddict's Avatar
    Do you let the battery drain completely?

    If you do this is very bad for the battery, you should charge it before it goes below 20%.

    Posted via CB10 using my Classic running 10.3.3.3216
    It happens when I knock it loose from the charger in the morning and I don't realize it. Don't care about the battery since I have a replacement and it's a Z10, ancient tech.
    06-20-19 07:55 PM
  9. dob0's Avatar
    what happens on the device when you connect it via USB.
    Hi!

    when Z10 is connected via usb:
    1. LED shines brighter (the colour is a mix of several lights that looks like white light);
    2. phone warms up;
    3. sometimes the phone starts to vibrate
    4. Z10 can't connect with PC
    06-23-19 10:40 AM
  10. TrumpetTiger's Avatar
    Hi!

    when Z10 is connected via usb:
    1. LED shines brighter (the colour is a mix of several lights that looks like white light);
    2. phone warms up;
    3. sometimes the phone starts to vibrate
    4. Z10 can't connect with PC
    So does the device start up at all or no?
    06-23-19 09:52 PM
  11. BBfishingaddict's Avatar
    Hi!

    when Z10 is connected via usb:
    1. LED shines brighter (the colour is a mix of several lights that looks like white light);
    2. phone warms up;
    3. sometimes the phone starts to vibrate
    4. Z10 can't connect with PC
    Have you tried taking the battery out like I described above? I've had to follow that routine a bunch of times and everything goes back to normal.
    06-24-19 06:55 PM
  12. dob0's Avatar
    So does the device start up at all or no?
    it doesn't(((
    07-07-19 02:22 PM
  13. dob0's Avatar
    Have you tried taking the battery out like I described above? I've had to follow that routine a bunch of times and everything goes back to normal.
    do you mean
    I have to take the battery out plug it into my laptop, turn it on and then put the battery in. I then let it charge for a bit before unplugging
    ?
    if you mean this, i may tell you, i have not tried this way.
    07-07-19 02:28 PM
  14. TrumpetTiger's Avatar
    it doesn't(((
    You might try letting it charge for a few hours via USB connection to your computer dob0. I've occasionally found that that will help when wall chargers do not work. Feel free to attempt what you describe to BBfishingaddict as well.
    07-08-19 04:37 AM

Similar Threads

  1. Which KEY² Variant Works On Verizon?
    By Zukadomis in forum BlackBerry KEY2
    Replies: 27
    Last Post: 08-09-19, 09:29 PM
  2. DTEK60 and Galaxy Watch Active
    By Fire In The Bones in forum BlackBerry DTEK60
    Replies: 2
    Last Post: 07-19-19, 05:14 PM
  3. Update on KEY2 LE Dual SIM
    By bberrysuper in forum BlackBerry KEY2 LE
    Replies: 3
    Last Post: 06-27-19, 10:33 AM
  4. playstore on key2
    By X-Sym in forum Ask a Question
    Replies: 1
    Last Post: 06-16-19, 03:06 PM
LINK TO POST COPIED TO CLIPBOARD