1. vegetto_456's Avatar
    Since the latest update my brothers Z10 is dead. It wont turn on fully and keeps restarting it. Factory resetting via Link didn't do anything. And no it has nothing to do with the battery.

    I tried loading an autoloader but it won't work. Anything else I can try to fix it? Otherwise its on to iphone or android for him

    Thanks in advance
    07-19-15 01:21 PM
  2. CyberMan2013's Avatar
    Take out the battery, run SIC wipe then autoloader. Read and follow SIC wipe instructions carefully. Proper drivers must be installed for SIC wipe and the Autoloader to connect to the phone.

    Posted via CB10
    07-19-15 01:30 PM
  3. vegetto_456's Avatar
    Take out the battery, run SIC wipe then autoloader. Read and follow SIC wipe instructions carefully. Proper drivers must be installed for SIC wipe and the Autoloader to connect to the phone.

    Posted via CB10
    whats sic wipe? I ran the autoloader and it reloaded the os and but it dies after restarting it again
    07-19-15 01:49 PM
  4. CyberMan2013's Avatar
    Sounds like you have a miscalibrated battery. Try and see if you can get your hands on a new or another battery. If not, then you can try taking out the battery for an hour when the phone dies then recharging it with the original Z10 charger.

    Posted via CB10
    07-19-15 08:24 PM
  5. vegetto_456's Avatar
    Sounds like you have a miscalibrated battery. Try and see if you can get your hands on a new or another battery. If not, then you can try taking out the battery for an hour when the phone dies then recharging it with the original Z10 charger.

    Posted via CB10

    Nope, nothing to do with the battery. Tried it with different batteries and it seems to be the same issue. Thanks I appreciate the help so far
    07-19-15 08:34 PM
  6. yeo123's Avatar
    Since the latest update my brothers Z10 is dead. It wont turn on fully and keeps restarting it. Factory resetting via Link didn't do anything. And no it has nothing to do with the battery.

    I tried loading an autoloader but it won't work. Anything else I can try to fix it? Otherwise its on to iphone or android for him

    Thanks in advance
    Reset by hold power button until the BlackBerry Logo appear and then release the button.

    BlackBerry Z10/STL100-2
    07-20-15 05:00 AM
  7. CyberMan2013's Avatar
    Nope, nothing to do with the battery. Tried it with different batteries and it seems to be the same issue. Thanks I appreciate the help so far
    Can you give some more details accompanied by pics showing exactly what is taking place. Or even share a video. Don't be so quick to rule out the batteries. It's not uncommon for a miscalibrated battery to cause a Z10 to shut down before the battery meter reaches 0% and then spontaneously corrupt the OS. If this happens you would have 2 issues to deal with at the same time. The corrupted OS would cause a boot loop and you may not be able to restore the phone using an autoloader once this is taking place. In that case you would have to take the battery out, then run the Autoloader or SIC Wipe (search the forums) and then plug the phone in without the battery. You might have to press the power button to turn it back on. After its finished turn off the phone, put back in the battery then plug in the charger and attempt to recharge it. Please send pics so that I can see what's going on. Even if a battery is miscalibrated it can be brought back to good health. Just make sure you're using your original charger, the charger and cable must be working properly though.

    Posted via CB10
    07-20-15 09:09 AM
  8. conite's Avatar
    You say it's not the battery, but it could very well be the pin connector. Maybe a loose connection (which would affect all batteries).

    Try jamming the battery up against the pins with some paper. If that doesn't work, it may be a service issue.

    Z30STA100-5/10.3.2.2339
    07-20-15 09:15 AM
  9. CyberMan2013's Avatar
    Also it might be helpful to get some info as to how the phone was behaving before this happened or what if anything was done before or if some strange event took place leading up to this issue. Don't rule out the replacement battery from being miscalibrated if he used to charge them both using chargers other then the original Z10 charger.

    Posted via CB10
    07-20-15 09:19 AM

Similar Threads

  1. Can I get a black dial pad on my Z-10 with updated OS?
    By CrackBerry Question in forum BlackBerry Z10
    Replies: 4
    Last Post: 07-23-15, 09:43 AM
  2. Please help think my Z10 has died :(
    By Ferrari430Spider in forum BlackBerry Z10
    Replies: 22
    Last Post: 07-22-15, 01:46 PM
  3. MY Blackberry Z10, wont turn on after I charge it. What do i do?
    By Badong Manalili1 in forum BlackBerry Z10
    Replies: 2
    Last Post: 07-21-15, 09:02 AM
  4. BES Cloud and Android app permissions
    By meagvg in forum General BlackBerry Discussion
    Replies: 0
    Last Post: 07-19-15, 10:09 AM
  5. 10.3.2.2339 OTA application update?
    By pghrox18 in forum BB10 Leaked/Beta OS
    Replies: 3
    Last Post: 07-19-15, 08:50 AM
LINK TO POST COPIED TO CLIPBOARD