1. Saukuy's Avatar
    Hi all. This is my first post here. Ive been visiting the site for a while now and have had a BB for quite a few years now (torch and now the z10), but this is the first time ive come accross a need to ask for help with the thing:

    The phone, out of the blue, has become stuck on speaker when I call or get called. I initially noticed this when switching on some music to play out loud and it not producing any sound. Something like this happened before and I recalled it having to do with the headphones being plugged in and the phone "not realising" they were removed again. So, I attached the headphones and changed the call setting to handset (this worked the last time and again on another z10 within our family which also had that very same problem), however this time it reverted to speaker mode. The phone now works exactly like it should and produces sound but during calles instead of the default handset I have speaker turned on and clicking on it to try change it does nothing but highlight the "button". Headphones work regularly too: plugging them in switches to the headphones and taking them out reverts back to the speaker. I am at a bit of a loss as to what to do as I do not really have my headphones about all the time, but use my phone on a regular basis for work and social reasons.

    I have tried finding some online help both here and generally googling, but have been unable to find any definitive answers. Just other cases of the same fault with no resolution.

    Im running the latest Z10 OS (not sure what the numbers are exactly). So far I have tried the above plugging in headphones, restarting the phone, removing the battery and restarting it that way. I have just backed up the data to my drive, but am reluctant to do a system factory restore as I am unsure whether it will help and how much of the data on my phone it removes in the process (as well as if the backup of the data on my phone encompasses the music, video and photo files as well as the downloaded files I have on it or if its just about settings and contacts). If anyone would be kind enough to give me some advice on how this may be solved and if anyone else has had this occur to them, or at least to inform me of the aspects of the backup and factory reset, Id be very greatful.

    Thanks in advance

    PS: happy to provide any info I may have missed to help.
    03-12-14 08:19 PM
  2. FF22's Avatar
    download the free blackberry virtual expert and run the tests.
    03-13-14 12:02 AM
  3. Saukuy's Avatar
    Thanks for the reply. I have checked with the tests the app provides and it has given me an all clear and everything is fine. I also seem to not be seeing the issue any more. The button no longer stayes "pressed" for the speakerphone and it works fine. I honestly dont know what happened to sort this issue but i noticed the change when i got a call earlier today. Maybe the phone was just slow in recognising the change after the initial plugging in and removing of earphones. Either way, thanks for replying and pointing towards a good app .
    FF22 likes this.
    03-13-14 11:25 AM
  4. TheBBguru's Avatar
    This happened to me once before where apart from being locked into speaker mode, the end call button wouldn't react either preventing me from ending a call.

    my fix for this issue discovered by accident was rotating the phone into landscape mode and back to portrait again quickly. This somehow seemed to 'unfreeze' the phone app.

    Just another OS10 quirk. Having said that, since the 10.2.1 update, I haven't had this issue again.

    Hope you don't see the issue again

    Posted via CB10
    03-13-14 11:50 AM
  5. Dhilipan Dushendran's Avatar
    Hello, im running the latest BB10 os on my z10.. I have the issue with my speaker,it does not ring on calls,cant use speaker mode while calling,cant play music...

    I tried restarting my phone even after that the same problem persists...

    Posted via CB10
    05-23-14 03:34 AM
  6. FF22's Avatar
    Hello, im running the latest BB10 os on my z10.. I have the issue with my speaker,it does not ring on calls,cant use speaker mode while calling,cant play music...

    I tried restarting my phone even after that the same problem persists...

    Posted via CB10
    It could be a hardware problem - do you have a warranty?

    Did you plug in headphones? You can try plugging and UNplugging headphones a few times.

    When listening to music (or trying), Press the Three-dots More Menu. Scroll down to Audio. See if switching between modes helps.

    Download Blackberry Virtual Expert (it may be included in newer versions of the OS). It contains a series of tests.


    Try a restart:

    Press and HOLD both Vol Up/Down buttons. Keep holding while the screen goes fully black (ignore the screenshot), keep holding through the Black/White logo and when the Colored Logo shows up, release those buttons.

    If you have the STL100-1 variant the volume button reset method doesn't work. In that case, Press and HOLD the Power On Button until you see the LOGO as above
    05-23-14 11:23 AM

Similar Threads

  1. Anyone got Limelight working on BB10
    By ArmedHitman in forum Android Apps (Amazon Store & APK Files)
    Replies: 6
    Last Post: 03-19-14, 12:06 PM
  2. Just ordered a Z10
    By StayClassy101 in forum BlackBerry Z10
    Replies: 35
    Last Post: 03-17-14, 04:01 PM
  3. Looking to buy a z10/q10
    By Sean Fanelli in forum BlackBerry Z10
    Replies: 7
    Last Post: 03-15-14, 12:16 PM
  4. z10 lcd repair
    By cdfegab in forum BlackBerry Z10
    Replies: 1
    Last Post: 03-12-14, 11:06 PM
  5. Gifting on BlackBerry World
    By NeoFighter170 in forum BlackBerry World
    Replies: 2
    Last Post: 03-12-14, 05:42 PM
LINK TO POST COPIED TO CLIPBOARD