1. askzeke's Avatar
    I live in Saskatchewan and have my Z10 date and time set to Sask -6. I go to the calendar, create a new event, enter the time as 7:30 am and save the event. The calendar shows the event at 8:30 am instead of 7:30. If you select the item and edit it, it is correctly listing the time as 7:30. I am guessing that there is a bug to do with the daylight savings time (the time never changes in Saskatchewan) and I cannot find any setting to disable the time change.
    04-09-13 01:03 PM
  2. Sith_Apprentice's Avatar
    Are you entering this in a web based calendar such as Gmail or is this local to the device only and not synced to any cloud?
    04-09-13 01:16 PM
  3. Branta's Avatar
    It certainly sounds like a time zone database error. The only test I can suggest to prove it is to change your location setting and system time to somewhere which uses DST, and see if the error goes away. You could also try swinging the date back to before DST and see if that resolves it. If these ideas prove the bug all you can do is report to RIM via your carrier, and any other direct means you can find.
    04-09-13 01:16 PM
  4. darkehawke's Avatar
    The only thing I can suggest is a security wipe

    Posted via CB10
    04-09-13 01:24 PM
  5. tfp's Avatar
    How long has this been happening? When did you get your phone?

    I know when the time change happened in March, it took a day for the calendar to catch up.
    04-09-13 01:29 PM
  6. askzeke's Avatar
    I got the phone the day they were released in Canada. It was working fine until recently (the alarms go off at the correct time, so never noticed the problem till a few days ago). I do have a calendar that is synced with outlook.com, but the problem shows up on my local calendar as well. I have reported to bbry,so am sure it will get fixed. I believe my 9810 had a checkbox where you could toggle the DST time change or not.
    04-09-13 01:37 PM
  7. askzeke's Avatar
    I received an answer from bbry with a confirmation of the problem and a workaround as follows:

    Select Mountain (-7 GMT) as the Time Zone on the smartphone using these steps:

    Open the Settings application.
    Select Date and Time.
    Change the Time Zone to Mountain Time (-7).

    I had to reset my phone before it worked, but now all is fine!!
    04-10-13 02:56 PM
  8. SchmoopieRawks's Avatar
    Thanks, I am in Saskatchewan and have the same problem. I was starting to wonder if I was the only one with this problem, as I hadn't seen anything in the forums.
    If I change to Mountain (-7) will it change all my appointment times by an hour?
    04-19-13 05:52 PM

Similar Threads

  1. Desktop Manager calendar choices do not match with ICal
    By jasiurek in forum Desktop Software
    Replies: 0
    Last Post: 10-17-09, 09:23 AM
  2. Upgradedto .151 and I do not have service books/no browser...help!
    By MyAlterEgo in forum BlackBerry Storm Series
    Replies: 3
    Last Post: 07-13-09, 10:12 PM
  3. Bold and coffe do not mix
    By TEEH in forum General BlackBerry News, Discussion & Rumors
    Replies: 16
    Last Post: 06-23-09, 05:50 PM
  4. Touch screen and button do not work!
    By MarkNH in forum BlackBerry Storm Series
    Replies: 6
    Last Post: 12-28-08, 03:31 PM
  5. Blackberry and Water do not mix..A long Story
    By Ottojr in forum General BlackBerry News, Discussion & Rumors
    Replies: 23
    Last Post: 04-16-08, 09:37 AM
LINK TO POST COPIED TO CLIPBOARD