1. wanttobelieve's Avatar
    I have a z10... this is my THIRD z10 since February. I have the latest official software from Bell Canada (10.2?) I would give more details but it's totally bricked...

    I downloaded a number of apps on the Black Friday sale overnight (some of the EA games were on sale). Phone was working fine before this. This morning the phone rebooted, and then hung. Did a battery pull, still hung. Tried BB Link to connect & got nowhere. So I tried using BB Link to Reload device software. When I hooked up my phone this morning it was on "Checking for BlackBerry Device Software Updates". When I got home 9 hours later, it was still on "Checking for BlackBerry Device Software Updates". I tried a few forum ideas (pulling battery and then reconnecting to BB Link to wait for the green light, etc), and now my phone will not start up at all and I do not even get the blinking red light.

    Now when I connect it to BB Link it asks me to power the phone off to reset it. Holding the power button for 10 seconds gives two quick red blinks. Then... nothing... pressing the power button again gets.... nothing... not even a red blink. After a while I get an error message from BB Link that it could not establish a connection.

    Any ideas? The last two times this happened it was under similar situations -- downloading more than one app at a time and then it bricks. I'm more than a little frustrated.
    11-29-13 07:07 PM
  2. Q100's Avatar
    Pull the battery and connect it to link.
    Or try to charge the battery for awhile maybe it's low.
    11-29-13 07:20 PM
  3. wanttobelieve's Avatar
    Have pulled the battery & connected to Link.... not working.

    Battery should be fine (it was plugged in all night & then connected to the USB all day. But I will try this again & see.

    thanks
    11-29-13 07:34 PM
  4. wanttobelieve's Avatar
    Charged battery all night... still dead. If I hold the power button for 10 seconds I get two quick red blinks. Nothing else. BB Link does not recognize the phone.

    Any suggestions????
    11-30-13 06:34 AM
  5. twstd.reality's Avatar
    Try reloading through the BlackBerry update website.

    http://www.crackberry.com/how-reload...erating-system

    Posted via CB10
    11-30-13 06:43 AM
  6. mtvictor's Avatar
    Download an autoloader, and pull out your battery and try to install it without it.

    Posted via CB10
    11-30-13 07:30 AM
  7. wanttobelieve's Avatar
    I eventually gave up; I couldn't get it to even register as a USB device. I brought it back to Bell. Have a replacement for now. Hoping that they simply replace it - no one else I know has had similar problems.

    Thanks for the suggestions everyone!


    Posted via CB10
    12-01-13 04:38 PM

Similar Threads

  1. Blackberry z10 not booting
    By samdan in forum BlackBerry Z10
    Replies: 27
    Last Post: 06-26-17, 06:42 PM
  2. BBM IOS messages not getting through reported
    By gtifreak190 in forum General BBM Chat
    Replies: 15
    Last Post: 12-09-13, 10:30 AM
  3. My Z10 Experience
    By AlfieBriggs in forum BlackBerry Z10
    Replies: 2
    Last Post: 11-30-13, 06:41 AM
  4. Z10 wont power on
    By rjshahan in forum BlackBerry Z10
    Replies: 2
    Last Post: 11-29-13, 05:54 PM
  5. Z10 Unlocked on Sale
    By mkelley65 in forum BlackBerry Z10
    Replies: 4
    Last Post: 11-29-13, 04:19 PM
LINK TO POST COPIED TO CLIPBOARD