1. steery666's Avatar
    Sorry if this has already been covered.
    Yesterday I was on the road a lot with limited coverage, so I took along a genuine spare battery. Burnt through both batteries in under 8 hours.

    Now, after fully recharging both batteries, I can't get a restart. Just hangs with a blank screen and a solid red light.
    Tried pulling the sim and SD and swapped over batteries. Nothing happens. Tried connecting to PC and link with no luck
    08-15-13 06:34 PM
  2. fivesevensuited's Avatar
    Have you tried popping in a charged battery and holding the volume up and volume down buttons for 30 seconds?
    08-15-13 06:44 PM
  3. steery666's Avatar
    Yes, thanks mate.
    Just gave it a try now. No change though.
    I forgot to mention that the solid red light goes away after maybe 5 minutes, but if I try to restart I just get the blank screen and solid red light again
    08-15-13 07:00 PM
  4. teamryan15's Avatar
    Pretty sure it's dead. Happened to me. I hope you have a warranty

    Posted via CB10
    08-15-13 07:04 PM
  5. fivesevensuited's Avatar
    You might have to reinstall the OS. There are plenty of threads on how to do it. Just download the OS you need and SACHESI and plug your phone in to your PC and click and drag the OS to Sachesi and itll do it all for you. Downloading it takes a while. But once that's done, installing it is pretty quick
    08-15-13 07:10 PM
  6. fivesevensuited's Avatar
    Just make sure you download the AUTOLOADER and not just the files. Also, you might want to consider just downloading the latest leak. It works great on my Z10. its BB 10.2.0.1047
    08-15-13 07:12 PM
  7. steery666's Avatar
    Thought of trying to reinstall the OS, but even when connected to a PC, doesn't recognise that there is a phone connected?
    08-15-13 07:18 PM
  8. fivesevensuited's Avatar
    well... you are in quite the predicament...
    08-15-13 07:49 PM
  9. trinichindian's Avatar
    Pretty sure it's dead. Happened to me. I hope you have a warranty

    Posted via CB10
    +1
    steery666 likes this.
    08-15-13 07:53 PM
  10. steery666's Avatar
    Thanks for everyones help
    I think it is time to return it.
    Disappointed
    08-15-13 08:57 PM
  11. project_x's Avatar
    What was the verdict?
    10-07-13 04:53 PM
  12. johnniemo's Avatar
    Mine just did this too. Bought it on the day it was released. Red light for a few minutes, then nothing. Good thing I bought the Future Shop warranty.
    11-26-13 08:03 PM

Similar Threads

  1. Reboot, Restart, Hard Reset??
    By ndorazio in forum BlackBerry Z10
    Replies: 6
    Last Post: 09-10-15, 01:23 PM
  2. Where to find Red Q5 in Canada or anywhere else?
    By ontherock3 in forum BlackBerry Q5
    Replies: 51
    Last Post: 10-05-13, 12:16 AM
  3. BB App World Won't Open Yet it is Running!
    By 65er in forum BlackBerry Bold Series
    Replies: 5
    Last Post: 08-18-13, 12:28 PM
  4. BB Protect set to OFF after restart 2.0.1047
    By Young Z in forum BlackBerry 10 OS
    Replies: 11
    Last Post: 08-16-13, 01:19 AM
  5. BBM convo won't open :(
    By zifonicz in forum General BBM Chat
    Replies: 1
    Last Post: 08-15-13, 07:26 PM
LINK TO POST COPIED TO CLIPBOARD