1. Cheesyporkyrabbit's Avatar
    Actually, my sister drained its battery and she didn't charge it for a day and when I charged it, it just displays the word "BlackBerry" and the red led will show for 5-10 seconds and the word "BlackBerry" will show again and it's a loop. I charged it for 6 hours but nothing happened!. I bought a battery 2 times just to use it but when I also drained it, it does the same as I stated lately. I use a 750mA charger!.
    12-26-14 06:25 PM
  2. anon(9208252)'s Avatar
    Make sure your plugged into the wall charger and let it sit over night, or you can also hold down the power button for a few seconds while plugged in might work also, maybe take the battery out while plugged in and try also then put battery back in.
    12-26-14 06:42 PM
  3. kenzo_44's Avatar
    Remove the battery and leave it for 30 minutes. Put it back in and long press on the power button, let it turn on and then put it for charging.

    Posted via CB10
    12-26-14 06:49 PM
  4. goodayeh's Avatar
    Actually, my sister drained its battery and she didn't charge it for a day and when I charged it, it just displays the word "BlackBerry" and the red led will show for 5-10 seconds and the word "BlackBerry" will show again and it's a loop. I charged it for 6 hours but nothing happened!. I bought a battery 2 times just to use it but when I also drained it, it does the same as I stated lately. I use a 750mA charger!.
    I am having the same problem.

    I believe it is the battery that is faulty and needs to be replaced.

    Do you have a spare charged battery to try ?
    12-26-14 07:21 PM
  5. Cheesyporkyrabbit's Avatar
    I already did that but nothing happened, it's just showing the cycle
    12-26-14 07:38 PM
  6. Cheesyporkyrabbit's Avatar
    Remove the battery and leave it for 30 minutes. Put it back in and long press on the power button, let it turn on and then put it for charging.

    Posted via CB10

    Nothing happened also!
    12-26-14 07:40 PM
  7. tickerguy's Avatar
    See the other thread.... Betcha I know what's going on..

    Posted via CB10
    12-26-14 07:44 PM
  8. goodayeh's Avatar
    I have been advised to use an autoloader to reinstall the OS.

    I still have not attempted this since it erases all info on the device.

    My question is : Has someone with a similar problem been able to revive the Z10 using this technique ?
    12-26-14 07:45 PM
  9. Cheesyporkyrabbit's Avatar
    I have been advised to use an autoloader to reinstall the OS.

    I still have not attempted this since it erases all info on the device.

    My question is : Has someone with a similar problem been able to revive the Z10 using this technique ?

    I also tried to reinstall the os because I think that the os has an error that makes the device not power up. My friend says that I should use an ipad charger to make the device power up because the ipad charger has more power than the blackberry one and it can make the device to force power up. Should I buy another battery again or wait for a fix?
    12-26-14 07:54 PM
  10. goodayeh's Avatar
    I thought it was due to the battery. I have ordered one from eBay.
    I will try as soon as I receive.

    Also read on other threads that it will not make any difference.
    12-26-14 08:00 PM
  11. goodayeh's Avatar
    I also tried to reinstall the os because I think that the os has an error that makes the device not power up. My friend says that I should use an ipad charger to make the device power up because the ipad charger has more power than the blackberry one and it can make the device to force power up. Should I buy another battery again or wait for a fix?
    Have you tried with ipad charger ?
    ( curious if it works )
    12-26-14 08:41 PM
  12. Cheesyporkyrabbit's Avatar
    Have you tried with ipad charger ?
    ( curious if it works )

    Yes I have tried it but nothing happened. It just stays in the reboot cycle. I think I should not let my battery drain again because I think that it is normal in BlackBerry Z10!
    12-26-14 10:31 PM
  13. anon(9208252)'s Avatar
    Try holding the volume up and down buttons in together for a while until you see the loading circle,
    12-26-14 10:37 PM
  14. goodayeh's Avatar
    Try holding the volume up and down buttons in together for a while until you see the loading circle,
    Nothing happens .
    It just continues to loop.
    Red light on 5 secs / then off /BlackBerry screen 5 secs. then off and starts loop again.
    12-26-14 10:41 PM
  15. Cheesyporkyrabbit's Avatar
    Search for this:
    Fully depleted battery may not charge when BlackBerry 10 smartphone is connected to charger
    KB36038
    12-27-14 11:33 PM
  16. goodayeh's Avatar
    Earlier today , I tried with another charged battery.

    It started without problems.

    For the future , will be very careful not to let battery drain completely.
    12-28-14 12:00 AM
  17. CecilTsunami's Avatar
    Had a similar loop on a Z30. Sometimes also try pulling the SIM. Was the only way out of the loop on the Z30.

    Posted via CB10
    12-28-14 01:18 AM
  18. Cheesyporkyrabbit's Avatar
    Earlier today , I tried with another charged battery.

    It started without problems.

    For the future , will be very careful not to let battery drain completely.

    The real fix for our problem is that we need to push the battery downwards the 4 golden cell that connects the battery to the phone, we should plug it to the wall socket and not on the pc. We need to push the battery before the red light appears and just keep pushing the battery like push and hold then the red battery logo with the lightning icon appears and wait for a minute then unplug the charger and try to power the phone on and it will start normal. I tried this and it worked and to avoid the depletion, I did not let the phone to go to 0% and automatically shuts off!
    01-16-15 04:00 AM
  19. jas1978's Avatar
    Tried turning on my old Z10 and found that the phone wasn't charging. It was just like OP described: red light but wouldn't start up.

    After trying many things to turn on the phone I finally:
    1. Took the battery out for 30 seconds.
    2. Plugged in the charger to the phone.
    3. Put the battery in.
    4. Pressed the power button for a few seconds.

    The BlackBerry logo came on and then the picture of the red battery with the electric bolt through it. After a few minutes the phone turned on. I have it charging now.

    I had read these threads before on dead Z10s, but I thought it would never happen to me. I don't know if my phone turned on again because of what I did, or I was just lucky.

    Posted via CB10
    01-16-15 01:56 PM

Similar Threads

  1. Suggested replacements to gmail for BlackBerry users
    By BBHermes in forum General BlackBerry News, Discussion & Rumors
    Replies: 167
    Last Post: 06-16-15, 05:24 AM
  2. On BB 10.3, do ALL Amazon apps work?
    By firesale1 in forum Ask a Question
    Replies: 4
    Last Post: 12-26-14, 10:18 PM
  3. Blackberry Passport
    By missgrumps in forum More for your BlackBerry 10 Phone!
    Replies: 5
    Last Post: 12-26-14, 06:23 PM
  4. 10.3 Os for Q5?
    By halux in forum BlackBerry 10 OS
    Replies: 2
    Last Post: 12-26-14, 05:51 PM
  5. IPhone 5s vs z10 extended battery vs unlikely z10 all touch successor
    By Acvdm in forum General BlackBerry News, Discussion & Rumors
    Replies: 1
    Last Post: 12-26-14, 05:34 PM
LINK TO POST COPIED TO CLIPBOARD