1. willowbeast's Avatar
    Just wondering why BlackBerry decided not to add it to the z and only to the q.

    Z10 on Rogers
    05-02-13 07:22 PM
  2. wentouch's Avatar
    Edit: Oops; my bad. Read wrong.
    Last edited by wentouch; 05-02-13 at 07:40 PM.
    sam1231 likes this.
    05-02-13 07:29 PM
  3. Phill_UK's Avatar
    Just wondering why BlackBerry decided not to add it to the z and only to the q.
    2600mhz LTE is supported on the STL100-2
    05-02-13 07:32 PM
  4. willowbeast's Avatar
    2600mhz LTE is supported on the STL100-2
    Really? Thank you. I have the 100-3 so I take it I'm good.

    Z10 on Rogers
    05-02-13 08:39 PM
  5. Phill_UK's Avatar
    Really? Thank you. I have the 100-3 so I take it I'm good.
    Yes, really... but only on the STL100-2
    05-02-13 08:40 PM
  6. willowbeast's Avatar
    Yes, really... but only on the STL100-2
    Alright so back to my question. Why no 2600 for z10?

    Z10 on Rogers
    05-02-13 08:46 PM
  7. Phill_UK's Avatar
    Alright so back to my question. Why no 2600 for z10?
    Back to my answer, it is there... just not on your model.
    habs_fan likes this.
    05-02-13 08:53 PM
  8. zeeten's Avatar
    Back to my answer, it is there... just not on your model.
    I'll rephrase the question, if it's supported on 000-2, why is Rogers selling 000-3?

    Posted via CB10
    05-02-13 09:53 PM
  9. zten's Avatar
    My rogers stl3 has lte

    Posted via CB10
    05-02-13 09:55 PM
  10. smoothrunnings's Avatar
    I'll rephrase the question, if it's supported on 000-2, why is Rogers selling 000-3?

    Posted via CB10
    Rogers is likely selling the -3 model because their network doesn't support LTE 2600. Do you really need someone to tell you that? Maybe you should call Rogers and ask them since I doubt anyone at the level that would be required to answer that question is on here from Rogers.
    05-02-13 10:06 PM
  11. wasabiGT's Avatar
    Lol people don't know how to read.

    The Rogers Z10 has LTE but not the 2600mhz LTE (higher frequency than the standard LTE)

    The Q10 runs on this frequency as does the LG Optimus G and the Samsung Galaxy S4.

    The question from the OP is why didn't Rogers offer the model that runs on the higher frequency LTE for the Z10.

    I myself am wondering the same question actually.

    Posted via CB10
    05-02-13 10:07 PM
  12. smoothrunnings's Avatar
    Alright so back to my question. Why no 2600 for z10?

    Z10 on Rogers
    Call BlackBerry and Rogers to find your answer.
    05-02-13 10:07 PM
  13. wasabiGT's Avatar
    Lol you are funny. Of course Rogers runs on the 2600mhz signal. The Optimus G was the first phone to run on it. Now the S4 and the Q10 also take advantage of the higher frequency

    Rogers is likely selling the -3 model because their network doesn't support LTE 2600. Do you really need someone to tell you that? Maybe you should call Rogers and ask them since I doubt anyone at the level that would be required to answer that question is on here from Rogers.


    Posted via CB10
    05-02-13 10:09 PM
  14. cjcampbell's Avatar
    Rogers is likely selling the -3 model because their network doesn't support LTE 2600. Do you really need someone to tell you that? Maybe you should call Rogers and ask them since I doubt anyone at the level that would be required to answer that question is on here from Rogers.
    Rogers is the only carrier in Canada running that frequency so yes, they do offer it. Why they didn't equip themselves with the model that supports it I have no idea. That said, the current LTE that it does run is more than sufficient. In fact, I have it turned off and regular 4G is still more than fast enough.

    Posted via CB10
    05-02-13 10:10 PM

Similar Threads

  1. Why is the settings screen so laggy on the z10?
    By yelmonster in forum General BlackBerry News, Discussion & Rumors
    Replies: 22
    Last Post: 08-06-13, 06:37 PM
  2. Replies: 1
    Last Post: 04-30-13, 11:47 PM
  3. Old OS Ringtones on the Z10 deleting. WHY?
    By Jonathank in forum BlackBerry Z10
    Replies: 2
    Last Post: 04-20-13, 02:14 PM
  4. Why no charging contacts on the Torch?
    By mestes1999 in forum BlackBerry Torch Series
    Replies: 3
    Last Post: 08-19-10, 01:28 PM
  5. no volume when on the phone
    By Mimi1 in forum BlackBerry 71xx Series
    Replies: 0
    Last Post: 10-16-07, 09:10 PM
LINK TO POST COPIED TO CLIPBOARD