1. Muffella's Avatar
    Hello! I have had a Z10 since June 2014 (and I love it!), but two days ago, after I powered off to charge it overnight (as usual), it would not charge. It is the same outlet that I usually use, I checked the connections, I tried another outlet, I tried it from my tablet, and nothing - it would not even begin a charging cycle. I tried again yesterday, and still nothing. It only seems to charge when powered on.

    I am wondering if maybe I accidentally changed a setting. Or, maybe it is just the plug. Hope you can help. Thanks!
    04-14-15 02:13 PM
  2. WITHDRAWL's Avatar
    I believe these new batteries work better when left on and charged more often, as these do not have the same type of memory as the old.
  3. anon(9208252)'s Avatar
    I have a stupid question, why do you power it off, i haven't turned my phone off in months.
    04-14-15 03:23 PM
  4. Muffella's Avatar
    Not necessarily a stupid question My understanding - or at least, there are two camps here - is that by powering off and charging while off helps preserve the battery. With my old BB Curve, the battery fried after only two and a half years, and I believe it was at least party due to charging while on.
    04-14-15 03:28 PM
  5. anon(9208252)'s Avatar
    I believe these new batteries work better when left on and charged more often, as these do not have the same type of memory as the old.
    04-14-15 03:30 PM
  6. Muffella's Avatar
    Hmmm, interesting, thanks!
    04-14-15 05:39 PM
  7. vbdwork's Avatar
    With my old BB Curve, the battery fried after only two and a half years, and I believe it was at least party due to charging while on.
    Two and a half years on one battery is actually very good.
    04-14-15 06:11 PM
  8. Bonnie Bonzai's Avatar
    I usually turn my phone off at night and let it charge. I feel like it's taking a much needed rest that way....

    Posted via CB10
    Muffella likes this.
    04-14-15 06:13 PM
  9. anon(9353145)'s Avatar
    That's definitely an odd issue, especially if it will charge when turned on. If you have other devices like a tablet have you tried charging it with a different cable / usb power dock while it's turned off?
    Muffella likes this.
    04-14-15 06:19 PM
  10. anon(9208252)'s Avatar
    That's definitely an odd issue, especially if it will charge when turned on. If you have other devices like a tablet have you tried charging it with a different cable / usb power dock while it's turned off?

    I think ink it was a bug in that OS if my memory serves me.
    anon(9353145) likes this.
    04-14-15 06:30 PM
  11. vbdwork's Avatar
    I think ink it was a bug in that OS if my memory serves me.
    Yes, but reports were coming from Classic users only.
    04-14-15 06:32 PM
  12. anon(9208252)'s Avatar
    Yes, but reports were coming from Classic users only.
    I think it was around for the z10 as the problem was here before the classic showed up.
    04-14-15 06:41 PM
  13. vbdwork's Avatar
    I think it was around for the z10 as the problem was here before the classic showed up.
    Actually... what OS version? I don't find it mentioned in OP posts.
    04-14-15 06:49 PM
  14. anon(9208252)'s Avatar
    Actually... what OS version? I don't find it mentioned in OP posts.
    Either did I , I just remember seeing it in the forums, about not charging when turned off.
    04-14-15 06:58 PM
  15. Muffella's Avatar
    Yes, I did also try it powered off with the tablet but with its original BB usb cable, at least that's why I remember, so I will try it again. I just don't think that the phone should be on all the time...
    04-15-15 04:30 PM
  16. Muffella's Avatar
    Agreed!
    04-15-15 04:30 PM
  17. Gatmyer's Avatar
    That's strange. My z10 charges while off pulsating red light to solid green when charged. I'm on official 10.3.1 O/S

    Posted via CB10
    04-15-15 04:53 PM
  18. Muffella's Avatar
    So, the current status is: I powered off the phone last night, plugged it into the tablet with its original BB usb cable. Nothing...until several seconds later, it powered itself back on. What the?!?
    04-16-15 05:42 PM
  19. anon(9353145)'s Avatar
    So, the current status is: I powered off the phone last night, plugged it into the tablet with its original BB usb cable. Nothing...until several seconds later, it powered itself back on. What the?!?
    Does that mean it's charging now or just that it turned on and is somehow getting juice? If it's back to charging the phone, best not to question it, just be happy, lol.
    04-17-15 06:49 PM
  20. Sergeant_Im's Avatar
    Instead of turning off, set it to airplane mode and the phone will charge slightly faster than normal. Probably not the kind of answer you're looking for, but turning off the phone while charging does not yield any significant benefit.

    Posted via CB10
    04-19-15 09:52 AM
  21. kbz1960's Avatar
    You expect a tablet to charge your phone?
    04-19-15 10:04 AM
  22. geppoG1's Avatar
    I've had same problem with my old Q10 since upgrade it to 10.3.xxxx...now all works well on my Z10 and it charge normal wile power off.
    04-19-15 01:06 PM
  23. anon(9353145)'s Avatar
    You expect a tablet to charge your phone?
    I assumed the OP meant that they were using a tablet cube / cable to charge the Z10 to give it some extra kick.
    kbz1960 likes this.
    04-19-15 04:35 PM

Similar Threads

  1. Replies: 12
    Last Post: 05-30-15, 05:57 PM
  2. Why do my downloads keep restarting on my Z10 since the 10.3 upgrade?
    By CrackBerry Question in forum BlackBerry Z10
    Replies: 2
    Last Post: 04-16-15, 04:25 AM
  3. Replies: 4
    Last Post: 04-14-15, 05:22 PM
  4. So I was in my local O2.....
    By BBnewbie57 in forum BlackBerry Passport
    Replies: 1
    Last Post: 04-14-15, 04:36 PM
LINK TO POST COPIED TO CLIPBOARD