1. Cheesyporkyrabbit's Avatar
    This is very frustrating, and also I cannot find a fix for this. My bb z10's battery displays 100% when fully charged but when the phone discharges it is on 100% then goes to 97%. But when I open device monitor, it says that it is on 99 or 98%. The main problem is why the battery indicator on the home screen discharges from 100 to 97% without displaying 99 and 98%. Please give me a permanent solution. My z10 model is STL100-1 and I have os 10.2.1.3062. And also when it discharges to 0% it doesn't turn off and it is just normal. Can you also give me os versions that removes this problem. Thank you very much!
    02-08-15 06:22 AM
  2. chalx's Avatar
    I did SIC multiwipe and reloaded OS via BlackBerry link and my battery meter is ok for more than a month. Others are saying that SIC didn't do the job, but in my case battery meter is now OK.

    Posted via CB10
    02-08-15 06:30 AM
  3. tdaye's Avatar
    Just do a security wipe. All will be fine.

    Posted via CB10
    02-08-15 06:32 AM
  4. rawkerboi 07's Avatar
    First of all you should be happy that atleast your phone charges 100%! In many ST-100 it gets stuck at 90,94 or 97%!!
    It's a very common issue and there are some solutions which work, some are
    - Try charging your phone via Laptop or PC
    - A security wipe may help
    - let your battery get drained and then remove, memory card, battery and Simcard, keep it aside for an hour or two

    Last, Reload your OS!

    Posted via CB10
    02-08-15 07:15 AM
  5. George Guirguis's Avatar
    I have that same problem with my Q10. Its no big deal though

    Posted via CB10
    02-08-15 07:30 AM
  6. semperfi45's Avatar
    Had my Z 10 since they came out and never had this problem.
    02-08-15 07:34 AM
  7. girinath's Avatar
    It's a problem with all stl100-1 devices.
    Whenever it happens wait until all the battery discharges then remove the battery and keep it after 2hours. It is not a permanent solution but you can di whenever it creates problems.

    Posted via BlackBerry z10
    02-08-15 08:11 AM
  8. wojt7's Avatar
    This is very frustrating, and also I cannot find a fix for this. My bb z10's battery displays 100% when fully charged but when the phone discharges it is on 100% then goes to 97%. But when I open device monitor, it says that it is on 99 or 98%. The main problem is why the battery indicator on the home screen discharges from 100 to 97% without displaying 99 and 98%. Please give me a permanent solution. My z10 model is STL100-1 and I have os 10.2.1.3062. And also when it discharges to 0% it doesn't turn off and it is just normal. Can you also give me os versions that removes this problem. Thank you very much!
    Don't worry it's a bug in the system. No matter What you do this 100% to 98% discharge will always be there at least in official release.
    Everybody has that bug even all the posters that answered above. They just don't really Understand what you're asking about.

    Maybe 10.3 will fix that. We will find out next week.
    02-08-15 08:27 AM
  9. Cheesyporkyrabbit's Avatar
    Don't worry it's a bug in the system. No matter What you do this 100% to 98% discharge will always be there at least in official release.
    Everybody has that bug even all the posters that answered above. They just don't really Understand what you're asking about

    Maybe 10.3 will fix that. We will find out next week.

    Thank you for saying that it is just a bug in the os. That was my first thought when I encounter the problem. I thought that I am the only one who has this problem but not. I have read all about the os 10.3 but it has so many errors. Btw I'll just wait for the official release of bb os 10.3 for z10 stl100-1
    Batibreaker likes this.
    02-09-15 05:29 AM
  10. Cheesyporkyrabbit's Avatar
    It's a problem with all stl100-1 devices.
    Whenever it happens wait until all the battery discharges then remove the battery and keep it after 2hours. It is not a permanent solution but you can di whenever it creates problems.

    Posted via BlackBerry z10

    Doesn't work for me!
    02-09-15 05:30 AM
  11. Cheesyporkyrabbit's Avatar
    First of all you should be happy that atleast your phone charges 100%! In many ST-100 it gets stuck at 90,94 or 97%!!
    It's a very common issue and there are some solutions which work, some are
    - Try charging your phone via Laptop or PC
    - A security wipe may help
    - let your battery get drained and then remove, memory card, battery and Simcard, keep it aside for an hour or two

    Last, Reload your OS!

    Posted via CB10

    How long does the os reload takes. I'm scared to reload my os because of what I have read in other threads that the boot screen on the z10 won't load to 100% but I'll try to conquer my fear and try the reload!
    02-09-15 05:32 AM
  12. Cheesyporkyrabbit's Avatar
    I did SIC multiwipe and reloaded OS via BlackBerry link and my battery meter is ok for more than a month. Others are saying that SIC didn't do the job, but in my case battery meter is now OK.

    Posted via CB10
    I'll try this!
    02-09-15 05:34 AM
  13. Cheesyporkyrabbit's Avatar
    Just do a security wipe. All will be fine.

    Posted via CB10
    I tried so many times but nothing happens!
    02-09-15 05:34 AM
  14. JRF_1986's Avatar
    Apparently it is a common issue on the STL100-1. I have one and it was so frustrating having the indicator show 100% and then turning off, only to plug it in and see it has 57% and so on. I ended up retiring it and left it in its box, a phone that shuts off every 15-20 min isn't much use. I read on the BB forums that installing a leaked 10.3 OS would help. So, I'm going to try that. Hope the advice given here helps you, everyone seems to have mixed results.
    02-09-15 11:17 AM
  15. ferchu's Avatar
    With the lastest versions, this issues are more rare.... not at all, but really decreases.
    02-09-15 11:32 AM
  16. shakur_steve1's Avatar
    Thank you for saying that it is just a bug in the os. That was my first thought when I encounter the problem. I thought that I am the only one who has this problem but not. I have read all about the os 10.3 but it has so many errors. Btw I'll just wait for the official release of bb os 10.3 for z10 stl100-1
    Most definately it's a bug in the software.. I also had the same z10 stl100-1 and I just sold it and got the Q10.. but I know the 10.3.1 update will fix it.. but for me I loaded the leak 10.3.1.1154 and it's verry stable especially with the battery life it improved.try loading that specific leak it won't hurt

    Blackberry Q10
    02-09-15 01:09 PM
  17. JRF_1986's Avatar
    I installed 10.3.1 (I think it's. 1955) and it still has the glitch. Guess it'll stay retired for now.

    Posted via CB10 on my Q10
    02-10-15 12:26 AM
  18. chalx's Avatar
    Apparently it is a common issue on the STL100-1. I have one and it was so frustrating having the indicator show 100% and then turning off, only to plug it in and see it has 57% and so on. I ended up retiring it and left it in its box, a phone that shuts off every 15-20 min isn't much use. I read on the BB forums that installing a leaked 10.3 OS would help. So, I'm going to try that. Hope the advice given here helps you, everyone seems to have mixed results.
    Hm, there is something wrong with your phone or battery.
    02-10-15 04:46 PM
  19. Dale Turner1's Avatar
    Another question along the lines of battery....

    When charging and not using any heavy apps at the same time (perhaps browsing the news during charging) the battery charges at approximately 1% per minute (z10-2). That is until it gets to about 85/88% when the app manager will show that there's 30/40 minutes of charging time remaining. The battery itself is about a year old the phone a little older.

    Just wondered if there was a reason for this or just one of the peculiarities of the z10's batttery....

    Posted via CB10
    02-11-15 02:22 PM
  20. wojt7's Avatar
    Another question along the lines of battery....

    When charging and not using any heavy apps at the same time (perhaps browsing the news during charging) the battery charges at approximately 1% per minute (z10-2). That is until it gets to about 85/88% when the app manager will show that there's 30/40 minutes of charging time remaining. The battery itself is about a year old the phone a little older.

    Just wondered if there was a reason for this or just one of the peculiarities of the z10's batttery....

    Posted via CB10
    Yes that's normal. Thats how battery charging electronics work on z10. Fast charging first, but the last 20% considerably slower.
    02-11-15 03:42 PM

Similar Threads

  1. Replies: 3
    Last Post: 02-10-15, 04:47 PM
  2. Z10
    By manikantamaka in forum Ask a Question
    Replies: 17
    Last Post: 02-10-15, 11:37 AM
  3. Missing icons in 10.3
    By gopeshpkpnr in forum Ask a Question
    Replies: 4
    Last Post: 02-09-15, 06:51 PM
  4. How to restart a blackberry playbook without using power button?
    By CrackBerry Question in forum Ask a Question
    Replies: 1
    Last Post: 02-08-15, 02:18 AM
  5. 10.3.1 in Pakistan
    By hassan khan7 in forum Ask a Question
    Replies: 3
    Last Post: 02-08-15, 01:27 AM
LINK TO POST COPIED TO CLIPBOARD