1. Miketrader1710's Avatar
    Hey guys I have bb z10s with AT&T and AIO. In order to get LTE service I need LTE at 700MHZ frequency. The only model that have support this frequency is the STL100-3 anyone knows where can I buy that model??
    11-03-13 07:57 PM
  2. SteveBB10's Avatar
    Maybe http://www.gsmnation.com/ has some.

    Canadian cities BBM Channel C001234A4
    11-03-13 08:00 PM
  3. tlegend2012's Avatar
    STA-1 variant is the one for AT&T.. STL is for Zs not sure where though..
    11-03-13 08:01 PM
  4. raino's Avatar
    Title threw me off.

    If you want the Z10 STL100-3, you can buy one directly from BlackBerry here.

    If you want the Z30 STA100-1, i.e. the Z30 that's supposed to work on AT&T's LTE network, it is not available for sale.
    Last edited by raino; 11-03-13 at 09:16 PM.
    11-03-13 08:04 PM
  5. Z30Man's Avatar
    I have the BB Z30 STA-100-5 thru Sasktel.

    Posted via my BlackBerry Z30.
    11-03-13 09:13 PM
  6. zocster's Avatar
    Moved, and title edited

    Op please PM me if you've made a mistake
    11-03-13 10:28 PM
  7. eyecrispy's Avatar
    You can check the cb marketplace. There are some there. Also, ebay and swappa.

    SQN100-1 10.2.0.1791
    11-03-13 10:57 PM
  8. R Field's Avatar
    Canadian carriers sell them (Rogers Bell Telus Future Shop)

    CB10 - Z10 -10.2.0.1791
    11-04-13 12:05 AM
  9. BuuKarim88's Avatar
    Me

    Posted via CB10
    11-04-13 12:33 AM
  10. curvezzz's Avatar
    Ebay

    AT&T Z10
    11-04-13 01:28 AM

Similar Threads

  1. how can I get Palringo on my blackberry curve with BB OS 7.1?
    By salimdeaibes in forum General BlackBerry News, Discussion & Rumors
    Replies: 5
    Last Post: 02-26-14, 11:13 PM
  2. "Play On" and XBMC... can anyone get this to work?
    By ceckland in forum BlackBerry 10 OS
    Replies: 7
    Last Post: 11-05-13, 11:13 AM
  3. Where Did All The Negative Posters Go?
    By Gnomesane in forum General BlackBerry News, Discussion & Rumors
    Replies: 1
    Last Post: 11-03-13, 10:19 PM
  4. Z10 Waiting for device to restart loop
    By oakvillerelopro in forum BlackBerry Z10
    Replies: 1
    Last Post: 11-03-13, 08:04 PM
LINK TO POST COPIED TO CLIPBOARD