1. klauh's Avatar
    Hi everyone,
    I am posting here, because I can't find any solution to my problem on French BlackBerry forums (I'm a French girl)
    My son broke my Z10 screen, so I decided to replace it myself. It was easy, the new screen works fine, but my microphone doesn't works anymore

    I can hear people who is calling me, but they can't hear me at all...
    I have the latest update : 10.2.1.2977

    Everything seems to be correctly pluged Inside, I have just replace my screen !!
    Any idea about my microphone?
    I love my Z10, don't want to change my phone!!!

    Thanks for having read my message, and sorry for the poor English...
    10-17-14 07:11 AM
  2. RoseBud68's Avatar
    Welcome to the Board. Its possible that your microphone was damage along with the screen.
    p.s. your English is fine.
    10-17-14 11:50 AM
  3. FF22's Avatar
    Run b b virtual expert and the speaker test
    10-17-14 09:27 PM
  4. klauh's Avatar
    Thanks for the answers!

    Rosedub68: you probably right, I had not thought about that !!

    F2: I did the speaker test. When I speak to the phone to check the microphone, at the end of the test I can't hear anything, just some "grrr zzz grrr " noise.

    I just forgot to tell something: people can hear me when I put the loud speaker. Does it means the microphone is realy damage?

    Thanks a lot.
    10-21-14 07:36 AM
  5. duckshooter's Avatar
    Yes, it seems to be a somewhat known issue. I had the same thing happen where I could hear people when they called me but they couldn't hear me, yet speaker phone worked. I've read that is because the second microphone picks up the sound.

    Spreading the love with my Z10
    10-21-14 08:10 AM
  6. endevour's Avatar
    I have the exact same issue.
    Funny thing is, once i blow in the microphone for some seconds, press the bottom bezel (kinda where the brand logo is) my microphone starts working fine again.
    I do have that issues like every few days and keep doing the same "fix" over and over. Not sure if it's some hardware failure, connectors not as tight as they should be or if it's just a random software bug.
    I always got it to work again...
    10-21-14 08:44 AM
  7. tommo7788's Avatar
    I think the microphone only attaches too the main board by touching it, maybe if u took the board out again and re seat it, sometimes they don't go back in place correctly and therefore won't make a good connection with the mic.
    Good luck!

    Posted via CB10
    jamesharmeling and endevour like this.
    10-21-14 02:55 PM
  8. Snakepitboy's Avatar
    This might or might not help...

    I had this problem on my Q10. People I called could hear me only if I used the earphones or speakerphone.

    I gently cleaned the microphone with a safety pin. (The microphone is that tiny circular hole at the bottom of the handset that is hard to see, and it becomes easily clogged.)

    This worked for me.
    10-29-14 06:27 AM

Similar Threads

  1. Anyone hae a problem logging into BB Link after update?
    By CrackBerry Question in forum Ask a Question
    Replies: 1
    Last Post: 10-20-14, 01:54 PM
  2. How to find out the PRD from the Passport? (For Unlocking)
    By Blackerthanblack in forum BlackBerry Passport
    Replies: 4
    Last Post: 10-18-14, 01:57 AM
  3. Spooky gaming with Jack & the Creepy Castle - free today from Amazon
    By CrackBerry News in forum CrackBerry.com News Discussion
    Replies: 0
    Last Post: 10-17-14, 06:12 AM
  4. How to do a best photo editing to my old photos?
    By Bestimageclipping in forum Ask a Question
    Replies: 1
    Last Post: 10-17-14, 05:24 AM
  5. Replies: 1
    Last Post: 10-17-14, 05:15 AM
LINK TO POST COPIED TO CLIPBOARD